0

Adafruit HUZZAH ESP8266 breakout - my computer can not see U
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Adafruit HUZZAH ESP8266 breakout - my computer can not see U

by rmetcalf9 on Tue Nov 27, 2018 2:13 pm

I have a Adafruit HUZZAH ESP8266 breakout (https://learn.adafruit.com/adafruit-huzzah-esp8266-breakout/) and I can't it to talk to my computer.

I already have the feather version of this board (https://www.adafruit.com/product/2821) which has a USB connector. I can use this with my computer and program it using Arduino. As soon as I plug it in to my machine if I type 'ls /dev | grep USB' I see ttyUSB0 appear and it all works good.

I can't get the breakout boards working - my computer can't see their serial port. My process for putting this together has been:

Take an old spare USB printer cable. Cut the end off printer end off - I found there were 4 wires black, red, green and white. I got my continuity tester out and compared it with https://electronics.stackexchange.com/questions/183218/can-the-data-wires-of-a-usb-cable-power-a-led. The Standard A wires match the colours as descried.

I then solidered the cables directly to the ESP8266 board as per second picture here: https://learn.adafruit.com/adafruit-huzzah-esp8266-breakout/using-arduino-ide

When I plug it into my computer I do not see any ttyUSB0 appear in the /dev directory. When I press the GPI0 button the red light comes on. I have tried the process of holding GPI0, pressing then releasing reset and releasing GPI0. ttyUSB0 still dosen't appear.

Of course all of the further Arduino instructions do not make sense.
As I have two brakout boards I have repeated the process with a second board and a shorter (not printer) USB cable and it exhibits exatcly the same behavour. I am confident in my solidering and have done various contunity tests.


In summary, when I plug my feather in I see ttyUSB0 appear but when I plug in the breakout version nothing appears. Beacuse the feather works I don't think I need

I have tried the dmesg command and when I plug in the working feather I can see info about the device being connected and disconnected. When I plug in the brakeout board there are no entries at all added to the end of dmesg.

Am I doing anything wrong, does anyone know of anything else I can try?

rmetcalf9
 
Posts: 3
Joined: Tue Nov 27, 2018 2:12 pm

Re: Adafruit HUZZAH ESP8266 breakout - my computer can not s

by adafruit_support_carter on Tue Nov 27, 2018 5:56 pm

You need a USB to TTL serial adapter to talk to the breakout. Something like this:
https://www.adafruit.com/product/954

There's more to that than just a cable. There's a chip inside the plastic housing. A similar chip is included on the Feather version of the HUZZAH, that's why you can plug the Feather directly in. However, there is not such chip on the breakout version.

adafruit_support_carter
 
Posts: 12971
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.