0

Configuring I2c with SAMD21 MCU and BNO055
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Configuring I2c with SAMD21 MCU and BNO055

by rahul_ada on Mon Jan 14, 2019 3:02 pm

It was all set, BNO055 was successfully configured in fusion mode(IMU) with the Atmel SAMD21 MCU. Somehow, I don't know what happened and sensor stopped working, what I know is all the voltages on the board are good and interrupt pin is coming high. I tried to reset the interrupts but nothing good has happened to sensor board. Please help.

rahul_ada
 
Posts: 2
Joined: Mon Jan 14, 2019 2:51 pm

Re: Configuring I2c with SAMD21 MCU and BNO055

by adafruit_support_mike on Tue Jan 15, 2019 12:27 am

Post a photo showing your hardware and connections and we'll take a look. 800x600 images usually work best.

adafruit_support_mike
 
Posts: 58480
Joined: Thu Feb 11, 2010 2:51 pm

Re: Configuring I2c with SAMD21 MCU and BNO055

by rahul_ada on Tue Jan 15, 2019 1:29 am

It is not possible for me to upload the picture, you please assume that all connections are perfectly ok. Other BNO055 sensors are working, only two stopped.
I have not configured any interrupts, then why interrpt pin is coming high.
Any possible ways to rectify?

rahul_ada
 
Posts: 2
Joined: Mon Jan 14, 2019 2:51 pm

Re: Configuring I2c with SAMD21 MCU and BNO055

by adafruit_support_mike on Wed Jan 16, 2019 12:04 am

We can only offer advice based on the information we have. So far, all I have is "it doesn't work" and "trust me, all the connections are good."

adafruit_support_mike
 
Posts: 58480
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.