0

2.8 TFT DISPLAY WHITE SCREEN
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

2.8 TFT DISPLAY WHITE SCREEN

by acorbat on Mon Mar 04, 2019 6:04 pm

I recently purchased a 2.8" TFT Touch Shield for Arduino. I installed it on a metro. After loading in all the correct libraries. I could not get the example program's to run. The TFT display only showed a white screen. After hours of reviewing this forum, I just went a head and ordered a new TFT display. Installed that one to the same metro and it works great. How do I return the one with the white screen of death?

acorbat
 
Posts: 3
Joined: Thu Jan 17, 2019 4:11 pm

Re: 2.8 TFT DISPLAY WHITE SCREEN

by adafruit_support_carter on Mon Mar 04, 2019 11:55 pm

Posting your issue here is the start of the return process.

But first let's see if it might be something obvious and fixable. Can you post a photo of the backside of the problematic display, similar to this:
https://cdn-shop.adafruit.com/1200x900/1651-04.jpg

And just to be sure - everything else is the same? Same Metro / same code / etc. Just swapping TFT's and one works / one doesn't?

adafruit_support_carter
 
Posts: 12726
Joined: Tue Nov 29, 2016 2:45 pm

Re: 2.8 TFT DISPLAY WHITE SCREEN

by acorbat on Tue Mar 05, 2019 10:06 am

Yes. same metro, same code. I was just using the adafruit graphic test example code to start. Worked flawlessly after I installed the new shield.
Attachments
20190305_083011.jpg
20190305_083011.jpg (253.51 KiB) Viewed 82 times

acorbat
 
Posts: 3
Joined: Thu Jan 17, 2019 4:11 pm

Re: 2.8 TFT DISPLAY WHITE SCREEN

by adafruit_support_carter on Tue Mar 05, 2019 11:34 am

Thanks for the photo. It looks like maybe one of the ribbon cable retaining clamps isn't fully pushed in. See image below. It just pushes in so it looks like the other one. The ribbon cable itself looks fully seated, but also check that.

See if that helps.
tab.jpg
tab.jpg (56.98 KiB) Viewed 77 times

adafruit_support_carter
 
Posts: 12726
Joined: Tue Nov 29, 2016 2:45 pm

Re: 2.8 TFT DISPLAY WHITE SCREEN

by acorbat on Tue Mar 05, 2019 12:29 pm

The locking pins too some effort to seat but once both of them did, the TFT is now working thank you. It is running the example program as it should. Thank you.

acorbat
 
Posts: 3
Joined: Thu Jan 17, 2019 4:11 pm

Re: 2.8 TFT DISPLAY WHITE SCREEN

by adafruit_support_carter on Tue Mar 05, 2019 12:35 pm

Awesome. Sorry it arrived like that. Glad that fixed.

adafruit_support_carter
 
Posts: 12726
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.