0

USB Malfunction
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

USB Malfunction

by dcharato on Mon Mar 18, 2019 10:24 am

Good Morning,

We recently received a bunch of items from Adafruit including a few ADABOX 002 for our school. When using the Bluefruit LE Feather 32u4, we get a USB malfucntion USB Device not recognized. The last USB device you connected to this computer malfunctioned.

I have tried it on several computers and with several different USB cables. Using one from another ADABOX 002 works fine with no issues.

Any help would be appreciated.

dcharato
 
Posts: 11
Joined: Thu Feb 28, 2019 11:23 am

Re: USB Malfunction

by adafruit_support_mike on Tue Mar 19, 2019 12:40 am

If you power the Feather from a LiPo or a charge-only USB cable, what does the red LED do when you double-click the reset button?

adafruit_support_mike
 
Posts: 59156
Joined: Thu Feb 11, 2010 2:51 pm

Re: USB Malfunction

by dcharato on Tue Mar 19, 2019 8:31 am

One of the red lights blinks three times Pause Blinks three times continuously.

When clicking the reset button twice another red light next to the LiPO briefly comes on and then shuts off.

dcharato
 
Posts: 11
Joined: Thu Feb 28, 2019 11:23 am

Re: USB Malfunction

by adafruit_support_mike on Tue Mar 19, 2019 11:47 pm

Thank you. Are you only seeing the failure with one Feather 32u4?

adafruit_support_mike
 
Posts: 59156
Joined: Thu Feb 11, 2010 2:51 pm

Re: USB Malfunction

by dcharato on Wed Mar 20, 2019 8:15 am

I have not tried it on the other one that we have. I plugged the second one in and it was recognized and showed the COM port in device manager. I can certainly try it out if you wish.

dcharato
 
Posts: 11
Joined: Thu Feb 28, 2019 11:23 am

Re: USB Malfunction

by adafruit_support_mike on Thu Mar 21, 2019 2:48 am

Please do. Comparison tests rule out a lot of possible options.

adafruit_support_mike
 
Posts: 59156
Joined: Thu Feb 11, 2010 2:51 pm

Re: USB Malfunction

by dcharato on Thu Mar 21, 2019 9:10 am

So on the other one I went through all the steps up to the following image and tried to do the DCmotor test. While it was uploading the script to run, the USB malfunction popped up again and now the second one is able to find any com ports.

When you first plug in the USB it will briefly come up with the COM port it wants to use, that quickly goes away and then the USB malfunction error comes up. I tried it on multiple computers with the same results.
Attachments
robotics_Screen_Shot_2016-12-13_at_11_09_41_AM.png
robotics_Screen_Shot_2016-12-13_at_11_09_41_AM.png (134.42 KiB) Viewed 257 times

dcharato
 
Posts: 11
Joined: Thu Feb 28, 2019 11:23 am

Re: USB Malfunction

by adafruit_support_mike on Fri Mar 22, 2019 12:40 am

Post a photo showing your harwdware and connections please. It sounds like the motor is trying to draw more current than the USB port will provide, and the Mac is temporarily shutting down the USB port because it thinks a device connected to it has failed.

adafruit_support_mike
 
Posts: 59156
Joined: Thu Feb 11, 2010 2:51 pm

Re: USB Malfunction

by dcharato on Mon Mar 25, 2019 8:16 am

Thank you. I will take and post photos today.

dcharato
 
Posts: 11
Joined: Thu Feb 28, 2019 11:23 am

Re: USB Malfunction

by dcharato on Tue Mar 26, 2019 10:14 am

Here are some photos. I am using a laptop PC for this with Windows 10. I had tried plugging both devices into other PC's with the same results. I also tried it in my MAC. I followed the ADABOX002 directions and had the issue at the DCmotor test.

Image
Image
Image
Image
Image
16 line poems about life

dcharato
 
Posts: 11
Joined: Thu Feb 28, 2019 11:23 am

Re: USB Malfunction

by adafruit_support_mike on Wed Mar 27, 2019 2:25 am

Double-check your AA battery holder to make sure the switch has been flipped to 'ON'. That's what provides power to the motors.

adafruit_support_mike
 
Posts: 59156
Joined: Thu Feb 11, 2010 2:51 pm

Re: USB Malfunction

by dcharato on Wed Mar 27, 2019 8:24 am

Switch on or off makes no difference on both units. Not able to upload programs to the device.

dcharato
 
Posts: 11
Joined: Thu Feb 28, 2019 11:23 am

Re: USB Malfunction

by adafruit_support_mike on Wed Mar 27, 2019 11:27 pm

Hmm.. take the Feather that isn't connected to the robot and try connecting that to the computer on its own. Do you still get the USB failure message?

adafruit_support_mike
 
Posts: 59156
Joined: Thu Feb 11, 2010 2:51 pm

Re: USB Malfunction

by dcharato on Thu Mar 28, 2019 8:19 am

I have tried both connected directly to the robot and still get the USB message. Tried on several computers as well with same results.

dcharato
 
Posts: 11
Joined: Thu Feb 28, 2019 11:23 am

Re: USB Malfunction

by adafruit_support_mike on Thu Mar 28, 2019 11:46 pm

It's possible the microcontroller's USB firrmware has crashed. That can happen sometimes.

In the Arduino IDE, go to the Preferences and enable verbose messages during upload. Then try to upload a simple sketch like Blink without bothering to select a USB port. When you see the lines that begin with 'PORTS' start to scroll past in the debug pane, double-click the Feather's reset button to force the bootloader to restart. The first thing the bootloader does is make a USB connection to the computer, and the IDE will be waiting for a device to do that.

adafruit_support_mike
 
Posts: 59156
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.