0

Pyportal Display
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Pyportal Display

by toddmac12 on Tue Mar 26, 2019 8:37 pm

The display on my Pyportal only shows a bright screen. I have checked and reinserted the display ribbon but it still has the same display. I have attached the code I am using and snapshots of the files on the device.

circuitipy drive.jpg
circuitipy drive.jpg (39.63 KiB) Viewed 210 times


lib file list.jpg
lib file list.jpg (242.45 KiB) Viewed 210 times


code.txt
(1.32 KiB) Downloaded 49 times

toddmac12
 
Posts: 13
Joined: Wed Dec 10, 2014 6:14 pm

Re: Pyportal Display

by adafruit_support_carter on Wed Mar 27, 2019 3:09 pm

Was this one of the ones from AdaBox011? Go ahead and try the update process here:
https://learn.adafruit.com/adafruit-pyp ... r-pyportal

Note that to get WiFi working you'll need to edit the secrets.py file:
https://learn.adafruit.com/adafruit-pyp ... -file-17-1

adafruit_support_carter
 
Posts: 12987
Joined: Tue Nov 29, 2016 2:45 pm

Re: Pyportal Display

by toddmac12 on Wed Mar 27, 2019 5:51 pm

Yes, it is from Adabox 011. I have installed the updates but the screen is still bright and blank!! I used the MU Serial and have found that the program code is working but the Pyportal does not display the results.

toddmac12
 
Posts: 13
Joined: Wed Dec 10, 2014 6:14 pm

Re: Pyportal Display

by adafruit_support_carter on Wed Mar 27, 2019 5:58 pm

See if it might be the ribbon cable on the back:
https://learn.adafruit.com/adafruit-pyp ... -faq#faq-2

adafruit_support_carter
 
Posts: 12987
Joined: Tue Nov 29, 2016 2:45 pm

Re: Pyportal Display

by toddmac12 on Wed Mar 27, 2019 8:22 pm

I tried reinserting the cable again but I still have the bright blank display.

toddmac12
 
Posts: 13
Joined: Wed Dec 10, 2014 6:14 pm

Re: Pyportal Display

by adafruit_support_carter on Thu Mar 28, 2019 12:45 pm

OK, it might still be software related. Part of this may the firmware and libraries also. Let's first check the version of the CircuitPython firmware you are running. To do that, paste the contents of the boot_out.txt file here.

adafruit_support_carter
 
Posts: 12987
Joined: Tue Nov 29, 2016 2:45 pm

Re: Pyportal Display

by toddmac12 on Thu Mar 28, 2019 12:54 pm

I have figured out the problem. The ribbon connection for the display is broken. How can I get a replacement?

toddmac12
 
Posts: 13
Joined: Wed Dec 10, 2014 6:14 pm

Re: Pyportal Display

by adafruit_support_carter on Thu Mar 28, 2019 1:00 pm

Oh wow, that would explain it. Can you post a photo. We'll replace it. Just want to document what happened.

adafruit_support_carter
 
Posts: 12987
Joined: Tue Nov 29, 2016 2:45 pm

Re: Pyportal Display

by toddmac12 on Thu Mar 28, 2019 3:44 pm

I have attached a photo of the display ribbon.
Attachments
IMG_20190328_153207.jpg
IMG_20190328_153207.jpg (41.63 KiB) Viewed 128 times

toddmac12
 
Posts: 13
Joined: Wed Dec 10, 2014 6:14 pm

Re: Pyportal Display

by adafruit_support_carter on Thu Mar 28, 2019 4:16 pm

Thanks. Let's replace it. Send an email to support@adafruit.com with a link to this thread and they can get you a replacement PyPortal. Sorry about the broken ribbon cable.

adafruit_support_carter
 
Posts: 12987
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.