0

Feather Proto no longer recognized as USB device
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Feather Proto no longer recognized as USB device

by CoorsTek on Sun Jul 14, 2019 11:58 am

For the past two days I have been happily playing with my Feather 32u4 Basic Proto board without any issues. This morning I woke up my Windows 10 laptop and began editing my code in the Arduino IDE (1.8.9). I tried uploading the sketch and got the dreaded "Couldn't find a Board on the selected port." error. Here is the full error message:
IDE Error 1.txt
Device not found
(11.27 KiB) Downloaded 14 times


As instructed, I can press the reset button as the code is uploading and once in a blue moon the IDE does connect and successfully uploads and verifies the the code. However, about 5 to 10 seconds later I get the "Couldn't find a Board on the selected port." error. Here is the full error message:
IDE Error 2.txt
Code uploads but device disappears error
(14.46 KiB) Downloaded 16 times


I have the device on a breadboard functioning without issue for the past two days and have made no hardware changes since early yesterday. Looking at the device manager I can see the Feather show up as COM12 for about 5 seconds then it disappears and I get the Windows 10 error message "USB device not recognized". I tried the "Uninstall this device" when it was briefly connected then reconnected it. Same problem.

I then went into my Adafruit goodies box and pulled out an Adafruit ItsyBitsy M4 and found the same thing is happening. Connecting it to the USB it shows up briefly in the Device Manager list then disappears and getting the same Windows error. I swapped USB cables and had the same results (these are both known good cables because they work fine with my Digilent USB oscilloscope).

Of course when this first started happening I rebooted my laptop several times and even powered down, removed the battery then booted back up not connected to the docking station. I have no other USB com devices connected (just keyboard, wireless mouse and my iPhone which all seem to be stable in their connection).

I am at my wits end as to what to try next. Any suggestions?

CoorsTek
 
Posts: 4
Joined: Mon May 07, 2018 10:22 am

Re: Feather Proto no longer recognized as USB device

by miguelash on Mon Jul 15, 2019 10:37 pm

I'm facing a very similar issue but with the Fona version + GPS Feather wing.

I've noticed that when I add some more code to my existing, functioning one, it stops being recognized as USB device. When I revert to the previous version, I works as expected.

the resulting sketch (the working version) uses 94% of the program storage space, while the faulty one, uses 96%.

My guess was that it had to do with the size of the sketch, but since the files you share show that your "Sketch uses 5084 bytes (17%)", that leads me to believe it has nothing to do with the sketch size.

I found this in the Adafruit website:

I don't understand why the COM port disappears, this does not happen on my Arduino UNO!
UNO-type Arduinos have a seperate serial port chip (aka "FTDI chip" or "Prolific PL2303" etc etc) which handles all serial port capability seperately than the main chip. This way if the main chip fails, you can always use the COM port.
M0 and 32u4-based Arduinos do not have a seperate chip, instead the main processor performs this task for you. It allows for a lower cost, higher power setup...but requires a little more effort since you will need to 'kick' into the bootloader manually once in a whil


So, as I said, it probably has nothing to do with the size of the sketch but, because of the limited resources of the 32u4, it might be running out of memory, but I cannot debug it since I'm not able to open the serial monitor because of obvious reasons.

The only variable that changes the behavior of my feather is the new variables I add, so I don't have any other clue. Maybe you can try and see if adding or removing local variables makes any difference?

I wish you luck!
Miguel

miguelash
 
Posts: 10
Joined: Sat Jan 31, 2015 8:43 pm

Please be positive and constructive with your questions and comments.