📣📪 🚚 Adafruit will not be shipping USPS orders Monday January 20, 2020 🗓. Expedited USPS orders placed after 11am ET 🕚 Friday January 17 will go out Tuesday January 21 📣📪🚚

Pi zero (not a W) SSH trouble - public key error
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Pi zero (not a W) SSH trouble - public key error

by Ravens_Shadow on Tue Jul 23, 2019 9:51 pm

Description of problem: When I attempt to ssh into my pi zero, putty always throws an error reading "No supported authentication methods available (server sent: publickey)" after I type the username into the prompt.

I should note that I have had a pi zero W for a while that works just fine, I can ssh to it with no problem.

Process I used to arrive at this most frustrating error:
So I went ahead and flashed the latest image of rasbian light to my mini SD card using etcher. following this tutorial https://www.tomshardware.com/reviews/raspberry-pi-headless-setup-how-to,6028.html (the part for pi zero directly through USB ) I edited the config and command line documents and created the ssh file. I also downloaded the bonjour print services and Putty 64 bit is installed on my computer. I plugged in the pi to my computer using the micro usb port not the power port. I was able to get a response from the pi in my windows command prompt using 'ping raspberrypi.local'. When I try to use putty to connect however, I run into an error. I have tried using raspberrypi.local as well as the IP address (obtained from pinging the pi in my windows cp). No matter what I do putty opens a terminal window as expected and prompts for me to login. I use the default username pi and putty throws an error that says "No supported authentication methods available (server sent: publickey)".

I honestly don't understand what the problem is, every tutorial has the same basic steps for a plain pi zero. There was an image of the code with the files already edited available on some other forum so I tried that out to make sure it wasn't an error in my editing of the code files on the SD card but I ran into the exact same error. I apologize that I don't have the link to that anymore. I don't know what it means by a "public key" or how to even go about fixing the issue. I must be missing some fundamental piece of information. I also don't understand why I would be able to ping it at my command prompt yet be unable to ssh. I don't want to connect it to my router with an Ethernet cord because it seems to be, as a general consensus, possible to only connect the pi via a usb port to my computer. Is it possible I have a bad pi zero? Any help or insight would be a huge help, I have run myself round in circles reading and trying a myriad of things (I could not list them all above) just to get the same error every time. Thanks in advance!

Posts: 1
Joined: Tue Jul 23, 2019 8:48 pm

Re: Pi zero (not a W) SSH trouble - public key error

by adafruit_support_mike on Wed Jul 24, 2019 1:08 pm

Have you run ‘ssh keygen’ for the user account? That will create the .ssh directory and the keyfiles sshd wants to see when you try to log in.

Posts: 60177
Joined: Thu Feb 11, 2010 2:51 pm

Please be positive and constructive with your questions and comments.