Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

V-USB "USB Device not recognised"
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

V-USB "USB Device not recognised"

by edwards.aus on Tue Sep 07, 2010 11:15 pm

Hi all,

I am having troubles with programming my ATMEGA88pa with V-USB software. I just get this extremely vague error "USB Device not recognised". I am using the hid-mouse software here (just a very simple project trying to get my computer to recognise the controller) with 12MHz crystal set. I know that this error is quite common and I have tried a variety of issues to get rid of it.

I tried almost all of ALAN's troubleshooting VUSB tips "http://vusb.wikidot.com/troubleshooting" to no avail :( .

I have attached my entire project (hid_mouse.zip) here, so you guys can have a look. I am using AVRStudio4 here with STK500. I have made changes to usbconfig.h to set the appropriate D+, D- pins, changed to a random product ID but 0x16c0 vendor ID, and set the self powered flag (i am using my laptop adapter for power).

In makefile I set appropriate fuses for external crystal of12MHz.

Basically, when I compile the project with the makfile I get a main.elf file that I just upload to the microcontroller via the ELF Production File format button on the programmer (as in upload_program.jpeg). I am uploading no other files to the controller.

upload_program.jpg
I am uploading only main.elf
upload_program.jpg (125.23 KiB) Viewed 1669 times


I have also taken an image (circuit_image.jpeg) of the circuit I am using (because I am quite new to vusb, there may be a hardware issues that I cannot foresee).

circuit_image.JPG
The way my circuit looks
circuit_image.JPG (335.01 KiB) Viewed 1669 times


Await your replies earnestly. :?

Thanks and Regards,

Edwards
Attachments
hid_mouse.zip
Project HID_mouse
(121.38 KiB) Downloaded 148 times
edwards.aus
 
Posts: 1
Joined: Tue Sep 07, 2010 8:54 am

Re: V-USB "USB Device not recognised"

by chatham on Fri Sep 24, 2010 8:48 pm

I have no real idea what is the issue with your setup... V-USB can be a real pain to work with.

Anyhow, I'm using a 328p in my setup, and I could get the code to work for it when I compiled for a 168, but not for an 88. I don't know what the difference is, but try the attached 168 .hex and see if it will load onto your chip. Although it might not work correctly, it does give you a file that at least works on a very similar setup. I usually just do my code uploads via programming just the flash memory - so double check the fuses in the fuses tab in AVR studio.

One thing I'd suggest would be to add some small capacitors on both sides of the chips - some standard .1uF decoupling caps over each pair of VCC/GND pins.

Hope it helps!
Attachments
hid_mouse_168.hex
(5.17 KiB) Downloaded 239 times
OpenChord.org - Open Source kits to let you play Guitar Hero with a real guitar, or build your own Wii/PS3/USB controllers.

chatham
 
Posts: 144
Joined: Thu Feb 04, 2010 2:30 am

Please be positive and constructive with your questions and comments.