0

Gemma m0 boards are not able to receive uploads
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Gemma m0 boards are not able to receive uploads

by live4film on Wed Mar 03, 2021 11:43 pm

I am struggling to get my gemma m0 working. Last week I uploaded some code, it worked fine then. And every time since then, nothing gets uploaded. I checked my device manager to ensure the port number. In Arduino IDE I see gemma m0 as the board, and the com port shows the gemma. I have tried every single example sketch for adafruit neopixels and fastLED. I check to make sure my data pin and number of LED is correct, compile, and then upload. It says "Uploading..." And it stays there forever.
I have tried uploading right to the board, and I have also tried in in bootloader mode with the little green light by pressing it twice. Still nothing. I've done library updates, reinstalled Arduino, made sure I have my latest win10 update and the USB port 3.0 drivers are up to date as well.

I'm not getting the orange upload failed bar across the window, but I do get some issues about port exceptions. Not sure why. I am plugged into com 12, Arduino recognizes it's plugged in, but still I'm getting the following message:

processing.app.debug.RunnerException
at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:152)
at cc.arduino.UploaderUtils.upload(UploaderUtils.java:77)
at processing.app.SketchController.upload(SketchController.java:732)
at processing.app.SketchController.exportApplet(SketchController.java:703)
at processing.app.Editor$UploadHandler.run(Editor.java:2055)
at java.lang.Thread.run(Thread.java:748)
Caused by: processing.app.SerialException: Error touching serial port 'COM12'.
at processing.app.Serial.touchForCDCReset(Serial.java:107)
at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:136)
... 5 more
Caused by: jssc.SerialPortException: Port name - COM12; Method name - openPort(); Exception type - Port busy.
at jssc.SerialPort.openPort(SerialPort.java:164)
at processing.app.Serial.touchForCDCReset(Serial.java:101)
... 6 more


This is frustrating. I've been dealing with this problem on various boards. Sometimes it will work. I come back to it a few weeks later without changing any settings, and suddenly it decides to work. It's really finicky. My success rate for uploading to boards is about 1 in 50, it's outrageous.

Anyone else have similar problems?

live4film
 
Posts: 46
Joined: Sat Nov 23, 2019 3:57 pm

Re: Gemma m0 boards are not able to receive uploads

by dastels on Thu Mar 04, 2021 10:10 am

It says the port is busy. Do you have a terminal/telnet/etc open on that port?

Dave

dastels
 
Posts: 6872
Joined: Tue Oct 20, 2015 3:22 pm

Please be positive and constructive with your questions and comments.