Please note: Friday June 18 is a holiday celebrating Juneteenth, please allow extra time for your order to arrive and plan accordingly.
0

MAX31856 reads 0.00c
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

MAX31856 reads 0.00c

by scyto on Sun Mar 28, 2021 2:05 am

First time user of a 31856 and an esp32 feather from ada
Got code uploaded using esphome.

Logs show the thermocouple connected (when I remove the thermocouple I get junction, cold, voltage and connection errors) as reading 0.00c which is wrong.

Trying to figure out if this is indication of bad soldering of pins, jumper wire issues or bad thermocouple. I bough the adafruit k type.

Or it’s I got the wrong idea about what pins to connect it to on the huzzah esp32?

scyto
 
Posts: 2
Joined: Sun Mar 28, 2021 1:59 am

Re: MAX31856 reads 0.00c

by adafruit_support_bill on Sun Mar 28, 2021 5:53 am

If you post some photos showing your soldering and connections we can take a look.

adafruit_support_bill
 
Posts: 81308
Joined: Sat Feb 07, 2009 10:11 am

Re: MAX31856 reads 0.00c

by scyto on Mon Mar 29, 2021 11:43 pm

Thanks, while my soldering is useless, turns out my issue was multiple failures caused by me!

1. Confusion over miso and mosi pins.
2. Confusion over what to put in the config file.
3. Breaking the rule only change one thing at a time.
4. Weirdly occasionally it would report 0c (which was impossible as pins were not wired or configured correctly!)

tl;dr got it working

scyto
 
Posts: 2
Joined: Sun Mar 28, 2021 1:59 am

Re: MAX31856 reads 0.00c

by adafruit_support_bill on Tue Mar 30, 2021 5:56 am

Good to hear you got things working. Thanks for the follow-up.

adafruit_support_bill
 
Posts: 81308
Joined: Sat Feb 07, 2009 10:11 am

Please be positive and constructive with your questions and comments.