Please note: Friday June 18 is a holiday celebrating Juneteenth, please allow extra time for your order to arrive and plan accordingly.
0

Can't upload to Feather BLuefruit 32u4 as COM is always diff
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Can't upload to Feather BLuefruit 32u4 as COM is always diff

by eugeneworldwide on Wed May 05, 2021 3:32 pm

Following online instruction, I uploaded the board support.

When I plug in my board I get the USB happy noise and the board shows on a COM port. Example 'COM6'. When I try and upload any sketch, at the end I get the simple error saying 'No device found on COM7'. Not referring to the OCM that's actually in play with the board. If I reset and another port is assigned, when I upload again it says can't find at port COMxx+1

Each time it seems to be trying to upload to a port number +1 of what's shown and selected in the Arduino IDE.

I have tried this on different desktops and notebooks and the same.

Any ideas of what this can be?

eugeneworldwide
 
Posts: 2
Joined: Wed May 05, 2021 3:26 pm

Re: Can't upload to Feather BLuefruit 32u4 as COM is always

by blnkjns on Wed May 05, 2021 4:01 pm

I'm not sure, it is familiar, I think it is a hiccup of Windows 10 with the 32U4 (Leonardo's and Micro's do the same). Sometimes I restart the IDE, sometimes I just upload to the wrong port (both are visible to select). Mostly some trial and error. Best remedy I have is put it in a Mac. Somehow the Mac has another USB identifier that does not walk around so much. I can even swap M0's, M4's and 32U4's and I never select the port, just selecting the board makes it auto-find the correct port.
Maybe you can try the experimental 2.0 IDE, it has a different approach on port selecting.
With Adafruit boards I believe even on the 32u4 ones, you can try double-tapping reset. Maybe that helps.

blnkjns
 
Posts: 624
Joined: Fri Oct 02, 2020 3:33 am

Re: Can't upload to Feather BLuefruit 32u4 as COM is always

by eugeneworldwide on Wed May 05, 2021 5:01 pm

Thanks for the advice.

I've been playing with it and seems what happens is that when I upload a sketch as soon as it has to load onto the unit, it changes port. It somehow disregards the port setting, uninstalls the device and then errors. Directly after that error on the IDE, the unit reloads itself on the port again.

I can hear the sound of the USB 'unplugged' as soon as it loads. Then after the IDE gives the error, I can hear the USB sound of reloading the Bluefruit back onto its port.

I cant figure out if it a IDE issue or the board itself.

The fact that it changes COM seems to be due to this resetting the port as soon as it needs to load onto the actual device. Apart from the loading process, it identified the board and port all seem fine.

eugeneworldwide
 
Posts: 2
Joined: Wed May 05, 2021 3:26 pm

Re: Can't upload to Feather BLuefruit 32u4 as COM is always

by blnkjns on Thu May 06, 2021 1:46 am

The thing is, on a 32u4 the USB port is also Serial. So it has to disconnect Serial communication before going to code-upload-mode. Never had it this bad though. What happens if you hold the reset until the IDE starts uploading (after compiling has finished)?

blnkjns
 
Posts: 624
Joined: Fri Oct 02, 2020 3:33 am

Please be positive and constructive with your questions and comments.