๐Ÿ“ฃ๐Ÿ“ช ๐Ÿšš Adafruit will not be shipping USPS orders Monday January 20, 2020 ๐Ÿ—“. Expedited USPS orders placed after 11am ET ๐Ÿ•š Friday January 17 will go out Tuesday January 21 ๐Ÿ“ฃ๐Ÿ“ช๐Ÿšš
0

Gemma won't enter bootloader mode
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Gemma won't enter bootloader mode

by absurdstarfish on Sat Aug 01, 2015 11:43 am

I have 3 gemma's (two adafruit and one arduino) that I can't seem to get into bootloader mode. I have tried 3 usb micro cables and both ports on my MacBook Pro (all of which function normally with other hardware) but still when I press the reset button the red light illuminates solid for ~3 seconds and then turns off without strobing. Attempting to load any code through IDE returns the "Could not find USBtiny device (0x1781/0xc9f)" error.

I couldn't find any previous threads relating to this, but if you know of one please link me :)

absurdstarfish
 
Posts: 2
Joined: Sat Aug 01, 2015 11:16 am

Re: Gemma won't enter bootloader mode

by adafruit_support_mike on Sun Aug 02, 2015 1:21 am

Try re-flashing the bootloader: https://learn.adafruit.com/introducing- ... bootloader

The tutorial is for the Trinket, but the Gemma uses the same microcontroller and firmware.

adafruit_support_mike
 
Posts: 60177
Joined: Thu Feb 11, 2010 2:51 pm

Re: Gemma won't enter bootloader mode

by absurdstarfish on Mon Aug 03, 2015 11:56 pm

Decided to try one more cable before I went through the trouble of flashing the bootloader, turns out that was the problem.

absurdstarfish
 
Posts: 2
Joined: Sat Aug 01, 2015 11:16 am

Re: Gemma won't enter bootloader mode

by adamjdanger on Thu Jul 28, 2016 4:22 pm

I had a similar problem on a macbook pro and solved it but plugging the gemma into a usb hub rather than straight into the mac's usb port.

adamjdanger
 
Posts: 3
Joined: Thu Jul 28, 2016 1:10 am

Re: Gemma won't enter bootloader mode

by socrates6 on Sat Feb 03, 2018 8:58 pm

I have the same problem. When I push reset on the gemma the LED goes through a rainbow of colors. Im assuming that isnt bootloader mode.

socrates6
 
Posts: 7
Joined: Sun May 15, 2011 6:32 pm

Re: Gemma won't enter bootloader mode

by adafruit_support_mike on Sun Feb 04, 2018 12:59 am

Verify your USB cable by using it to connect some other, known-working device to the computer.

There's a plague of charge-only cables out there with USB connectors at both ends but no wires for the data signals. We see people get caught by them every day.

adafruit_support_mike
 
Posts: 60177
Joined: Thu Feb 11, 2010 2:51 pm

Re: Gemma won't enter bootloader mode

by socrates6 on Sun Feb 04, 2018 6:05 pm

Yeah, the cable works for the trinket.

socrates6
 
Posts: 7
Joined: Sun May 15, 2011 6:32 pm

Re: Gemma won't enter bootloader mode

by adafruit_support_mike on Mon Feb 05, 2018 3:02 am

What do you see in the Device Manager or System Information USB pane when the Gemma is connected to the computer?

adafruit_support_mike
 
Posts: 60177
Joined: Thu Feb 11, 2010 2:51 pm

Re: Gemma won't enter bootloader mode

by tkwanjp on Thu Dec 13, 2018 11:48 am

I'm in the same situation.

I just got a new Gemma v2, have 4 cables.

Tried
cable 1, failed. Green LED lit but not for red LED.
cable 2, succeeded! Red LED also blinked fast.
So I uploaded a sketch. Then tried uploading another sketch, failed back to the same situation.

Tried
cable 3, failed.
cable 4, succeeded! Red LED also blinked fast.
So I uploaded a sketch. Then tried uploading another sketch, failed back to the same situation.
(tried all combination of cables 1-4.)

What can I do?

tkwanjp
 
Posts: 2
Joined: Thu Dec 13, 2018 11:40 am

Re: Gemma won't enter bootloader mode

by adafruit_support_mike on Fri Dec 14, 2018 1:02 am

@tkwanjp: Please start a new thread for your issue.

adafruit_support_mike
 
Posts: 60177
Joined: Thu Feb 11, 2010 2:51 pm

Re: Gemma won't enter bootloader mode

by tkwanjp on Sun Dec 23, 2018 5:33 am

@adafruit_support_mike essentially my problem is just as same as here; won't enter boot loader mode.

I've replaced the previous Gemma to a new one, but it still don't enter boot loader mode.

connect Gemma to the computer, green LED lit. Push the button on the Gemma, red LED lit for a couple of second then turns down.
Upload sketch, get an error:
"avrdude: Error: Could not find USBtiny device (0x1781/0xc9f)".

Using Adafruit Gemma (with a black PCB board). Got through the instruction of [Setting up with Arduino IDE https://learn.adafruit.com/introducing- ... rduino-ide].

tkwanjp
 
Posts: 2
Joined: Thu Dec 13, 2018 11:40 am

Please be positive and constructive with your questions and comments.