0

Windows 10 driver issues
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Windows 10 driver issues

by synaesdav on Thu May 19, 2016 8:43 pm

Hey all, a little problem here. I have recently updated my computer to windows 10, and now I am having trouble getting it to recognize some of my boards. It recognizes and will program my Arduino Uno, Feather 32u4, and Flora boards but does not recognize Adafruit Gemma, Arduino Gemma, Trinket 5v, or Pro Trinket 5v. I tried reinstalling the drivers by following the instructions at https://learn.adafruit.com/adafruit-ard ... dows-setup but the results were the same. I believe I am logged in as the administrator because I am the only one on the computer. Is there something I am overlooking? I have never had a problem with any of these boards on this computer before.
Thank-you in advance,
David

synaesdav
 
Posts: 23
Joined: Wed Feb 19, 2014 11:05 pm

Re: Windows 10 driver issues

by Franklin97355 on Fri May 20, 2016 1:40 am

Do they show up in the boards menu?

Franklin97355
 
Posts: 22674
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: Windows 10 driver issues

by synaesdav on Fri May 20, 2016 11:46 am

I am able to choose the boards in the Arduino IDE, but the port number doesn't show. I tried to upload anyway and got red text saying it couldn't find a board. My computer says a usb device is unrecognized or has malfunctioned. When I look in the device manager it says usb device descriptor failed.

synaesdav
 
Posts: 23
Joined: Wed Feb 19, 2014 11:05 pm

Re: Windows 10 driver issues

by adafruit2 on Fri May 20, 2016 2:51 pm

it sounds like bitbang USB devices are no longer loved...can you try going thru a USB hub?

adafruit2
Site Admin
 
Posts: 20956
Joined: Fri Mar 11, 2005 7:36 pm

Re: Windows 10 driver issues

by synaesdav on Fri May 20, 2016 3:27 pm

I'll pick one up and try that tomorrow.

synaesdav
 
Posts: 23
Joined: Wed Feb 19, 2014 11:05 pm

Re: Windows 10 driver issues

by synaesdav on Sat May 21, 2016 3:28 pm

OK, I picked up a generic USB hub to try out and got some interesting results. None of the boards I plugged in through the hub got an error message from Windows (good!), but the device manager didn't register them. When I try to upload in the Arduino 1.6.8 IDE, it still says it can't find the board. However, when I use codebender.cc I am able to program the Adafruit Gemma, Trinket 5v, and Pro Trinket 5v. Codebender does not support the Arduino Gemma, so I was unable to test that there. At least a partial success, but I am curious as to why I can't use certain boards with Arduino IDE directly. All my boards and libraries are up to date.

As a side note, I tried the same boards on an Asus tablet/notebook. The Feather, Flora, and Uno were recognized by both Arduino IDE and codebender.cc. Trinket 5v, Pro Trinket 5v, Adafruit Gemma, and Arduino Gemma were not recognized by either Arduino IDE or codebender.cc When I plugged them in, the device manager automatically loaded up the drivers, but the programs didn't register a port number.

synaesdav
 
Posts: 23
Joined: Wed Feb 19, 2014 11:05 pm

Re: Windows 10 driver issues

by adafruit2 on Sat May 21, 2016 7:30 pm

try 1.6.9

adafruit2
Site Admin
 
Posts: 20956
Joined: Fri Mar 11, 2005 7:36 pm

Re: Windows 10 driver issues

by tzikis on Mon May 23, 2016 3:56 am

@synaesdav, i just thought I'd pitch in since i'm the founder of codebender :)

nice to know you had some good success with codebender. as for the ports not showing up, that's normal, because Gemma, Trinket and Pro Trinket don't show up as Serial devices, so you wouldn't get any COM port when you plug them in. Regardless of that, If you click Run on Arduino, it should work fine.

If it doesn't, I'd encourage you to install our driver package, from the getting started page. It will make sure you have the right drivers installed, and it will log any errors in the process, so you can then contact us and we'll help you figure things out

And last but not least, you're right that we don't support the Arduino Gemma, but we should! Could you create a request for that at http://feedback.codebender.cc/forums/280540-board-requests?

tzikis
 
Posts: 30
Joined: Tue Sep 14, 2010 5:35 pm

Re: Windows 10 driver issues

by synaesdav on Mon May 23, 2016 2:19 pm

OK, I updated my Arduino IDE to 1.6.9 and was still having the same issue. I then noticed that I had the wrong programmer selected, corrected that and nothing. So I went through and uninstalled the individual boards from the program manager, re-plugged them in (through the USB hub) and let Windows find them and load up the drivers. Tried again with Arduino IDE and success! All my boards now work again!
Thanks for all the suggestions and help.

@tzikis - I love codebender, it's so easy and convenient to have my programs stored in the cloud. I made a request to have the Arduino Gemma board supported.

synaesdav
 
Posts: 23
Joined: Wed Feb 19, 2014 11:05 pm

Re: Windows 10 driver issues

by tzikis on Tue May 24, 2016 5:00 am

@synaesdev yay!

tzikis
 
Posts: 30
Joined: Tue Sep 14, 2010 5:35 pm

Please be positive and constructive with your questions and comments.