0

Issue installing drivers for Arduino Leonardo
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Issue installing drivers for Arduino Leonardo

by clamon on Sat Jun 23, 2012 3:57 pm

I am having an issue with installing the drivers for my recently purchased arduino leonardo. My computer, running windows 7, registers the device and I followed the steps to direct the device to the drivers, however it will not install them. I am using the arduino 1.0.1 software, and my computer works with the Arduino Uno. I see peoeple have had issues with the bootloader for this device, however my computer just says its not able to find the device driver software. Is this perhaps the same issue? If so is there a way to fix it or perhaps a different way to access to drivers? Any help is appreciated, thank you.
clamon
 
Posts: 8
Joined: Sat Jun 23, 2012 3:43 pm

Re: Issue installing drivers for Arduino Leonardo

by adafruit_support_rick on Sun Jun 24, 2012 8:59 am

You have followed the instructions at the Arduino site?
Do you see the Leonardo in the Device Manager under Ports (COM & LPT) (you can open the Device Manager by clicking on the Start Menu and typing "Device Manager" into the box labeled "Search programs and files").

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Issue installing drivers for Arduino Leonardo

by clamon on Sun Jun 24, 2012 3:12 pm

Yes I did, I am familiar with how to direct it to the drivers from using the Uno, however no matter what I do it won't recognize the drivers are there and install them.
clamon
 
Posts: 8
Joined: Sat Jun 23, 2012 3:43 pm

Re: Issue installing drivers for Arduino Leonardo

by adafruit_support_rick on Sun Jun 24, 2012 4:43 pm

We had a similar question a few days ago. In that case, the OP had not unzipped the Arduino folder he downloaded. The driver wizard allows you to browse inside of a zipped folder, but can't actually install anything from there.

So, if you haven't unzipped the Arduino folder, do that and try installing again.

If you have unzipped the folder, but it still won't find and install the driver, then try this procedure:
    Open the Device Manager (type 'Device Manager' in the Start Menu' search box)
    Look for the Leonardo in either "Other Devices" or "Ports"
    Right-click in the Leonardo and select "Update Driver Software…"
    In the dialog box, select "Browse my computer for driver software"
    In the next box, select "Let me pick from a list of device drivers on my computer", and click 'Next'
    In the next dialog, click "Have Disk" (you don't have to wait for the computer to retrieve the entire list)
    This will open an "Install From Disk" dialog. Browse to your arduino installation folder (on my computer, it's C:\Program Files\arduino-1.0.1\drivers\Arduino Leonardo)Click OK.
    Click Next (ignore any warnings about the driver being not digitally signed)
    If a Windows Security dialog appears, select "Install this driver software anyway"
    The dialog should say that Windows has successfully updated you driver software
    Close the dialog and restart your computer.
    After the restart, open the Device Manager again

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Issue installing drivers for Arduino Leonardo

by clamon on Sun Jun 24, 2012 7:20 pm

Hmm, I checked and it is unzipped, however when I followed your directions it crashes my computer everytime it gets to the driver updating.
clamon
 
Posts: 8
Joined: Sat Jun 23, 2012 3:43 pm

Re: Issue installing drivers for Arduino Leonardo

by franklin97355 on Mon Jun 25, 2012 12:30 am

Are you running 64bit windows?

franklin97355
 
Posts: 20753
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: Issue installing drivers for Arduino Leonardo

by clamon on Mon Jun 25, 2012 1:11 am

Yes.
clamon
 
Posts: 8
Joined: Sat Jun 23, 2012 3:43 pm

Re: Issue installing drivers for Arduino Leonardo

by adafruit_support_rick on Mon Jun 25, 2012 8:19 am

Sounds silly, but maybe you have a corrupted install. Try downloading the IDE again.

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Issue installing drivers for Arduino Leonardo

by clamon on Mon Jun 25, 2012 3:53 pm

I tried reintalling the software, multiple times, and it still crashes. It says the error is a BAD_POOL_CALLER. I looked into this and it seems it is an issue with the drivers, which doesn't make much sense because the drivers should be sound. Is there another place I can try downloading the software perhaps?
clamon
 
Posts: 8
Joined: Sat Jun 23, 2012 3:43 pm

Re: Issue installing drivers for Arduino Leonardo

by adafruit_support_rick on Mon Jun 25, 2012 3:59 pm

The BAD_POOL_CALLER problem is associated with computer hardware issues. Is this a computer you bought with 64-bit Win7, or have you upgraded from an earlier OS? It could also be related to improperly installed cards, RAM, etc. Make sure all cards are seated properly. You may want to contact the computer vendor's tech support for help

See this link

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Issue installing drivers for Arduino Leonardo

by adafruit on Mon Jun 25, 2012 9:26 pm

Our of curiousity, are you sure you're using the driver that is in the Arduino install folder?

adafruit
 
Posts: 12151
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Re: Issue installing drivers for Arduino Leonardo

by clamon on Tue Jun 26, 2012 12:44 am

Hmm, I am pretty sure I am using the drivers from the Install folder, I am using the drivers in the folder I extracted all of the files to. In addition It is a computer that I purchased with windows 7 on it and I attempted to upgrade all of my computers drivers and check for any hardware issues but I had no primary issues. I am just wondering what the difference is with the Leonardo drivers and the Uno drivers because my computer runs the Uno drivers correctly, because If there is a difference that could possibly lead me to the issue.
clamon
 
Posts: 8
Joined: Sat Jun 23, 2012 3:43 pm

Re: Issue installing drivers for Arduino Leonardo

by clamon on Tue Jun 26, 2012 7:46 pm

I attempted to run the leonardo on a Mac today, and it failed to work. When I plugged it in and attempted to run the blink sample code, I received the error "avrdude: stk500_getsync(): not in sync: resp=0x54 ". I looked into this and it seems there are many issues that could cause this error, however I troubleshooted all the areas I could find, and found I was having the same issue as someone else. See www.arduino.cc/forum/index.php?topic=106659.0 . Based off of this it seems as though it is the bootloader causing the issue, which would cause the problems I have been having using windows 7 and now OSX. I am sure it is a true Arduino Leonardo as well, so now I am unsure what to do. I do not have a programmer to burn the bootloader. What can I do? And I could be wrong as well, these are just the conclusions I have found. Any insight is much apreciated. Thank you.
clamon
 
Posts: 8
Joined: Sat Jun 23, 2012 3:43 pm

Re: Issue installing drivers for Arduino Leonardo

by adafruit_support_rick on Wed Jun 27, 2012 10:56 am

Please email [email protected] and reference this post

adafruit_support_rick
 
Posts: 35095
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Issue installing drivers for Arduino Leonardo

by clamon on Wed Jun 27, 2012 12:22 pm

Alright, thank you very much for the help.
clamon
 
Posts: 8
Joined: Sat Jun 23, 2012 3:43 pm

Please be positive and constructive with your questions and comments.