Can't get Alphanumeric FeatherWing + Metro ESP32-S2 to work

Post here about your Arduino projects, get help - for Adafruit customers!

Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.
Post Reply
User avatar
dfeldman
 
Posts: 14
Joined: Mon Jul 04, 2022 4:11 pm

Can't get Alphanumeric FeatherWing + Metro ESP32-S2 to work

Post by dfeldman »

I just purchased a Metro ESP32-S2 and a 14-Segment Alphanumeric FeatherWing and am trying to get things up and running. I am VERY new to Arduino development and electronics in general (but comfortable with software engineering).

So far I am unable to get the FeatherWing to do anything. I haven't soldered it yet, but have everything lined up as shown on the breadboard and (as far as I can tell) connected properly to the ESP32. In the Arduino IDE I tried the quadalphanum example but it doesn't do anything—no errors but no output either. The Adafruit TestBed library's I2C-Scan example runs but nothing comes back: I get "Default port (Wire) I2C scan" followed by two blank lines.

I've attached photos of my current setup in case that helps.

What am I missing? Thanks!
Attachments
IMG_4095 (1).jpeg
IMG_4095 (1).jpeg (672.28 KiB) Viewed 187 times
IMG_4094 (1).jpeg
IMG_4094 (1).jpeg (750.19 KiB) Viewed 187 times
IMG_4093 (1).jpeg
IMG_4093 (1).jpeg (706.09 KiB) Viewed 187 times

User avatar
dastels
 
Posts: 10632
Joined: Tue Oct 20, 2015 3:22 pm

Re: Can't get Alphanumeric FeatherWing + Metro ESP32-S2 to w

Post by dastels »

A couple things:
1) you MUST solder in the headers. You woun't have a stable electrical connection without doing that.
2) You need to connect the display board to power. Aref isn't power. Connect the wing's 3v pin (as shown in https://learn.adafruit.com/14-segment-a ... ns-1942325) To the Metro's 3v output.

Dave

User avatar
dfeldman
 
Posts: 14
Joined: Mon Jul 04, 2022 4:11 pm

Re: Can't get Alphanumeric FeatherWing + Metro ESP32-S2 to w

Post by dfeldman »

Thanks so much for the reply! A couple follow-ups:

1. I believe I've selected the right 3V pin on the wing—let me know if it looks wrong based on my photos.
2. What's the right pin for 3V output on the Metro, then? On the pinout, the AREF pin is labeled 3.3V, along with the ones whose on-board labels are IOref and 3.3.
3. I do plan to solder everything together—just need to get a soldering iron and learn to do it :). In the meantime, though, could I reasonably expect the I2C_Scan example to work, given the pin strips have a pretty tight fit into the header?

User avatar
dastels
 
Posts: 10632
Joined: Tue Oct 20, 2015 3:22 pm

Re: Can't get Alphanumeric FeatherWing + Metro ESP32-S2 to w

Post by dastels »

1, 2: OK, I see the confusion. Aref is indeed connected to 3.3v on this board, unlike older boards. The Aref label is misleading now since that's not what the pin is any more. So it look slike your problem is the connections.

3) No, I'm afraid you can't expect anything to work well without a solid electrical connection (in the case of headers and a breadboard that means soldered), especially a high speed signal like I2C.

Dave

User avatar
dfeldman
 
Posts: 14
Joined: Mon Jul 04, 2022 4:11 pm

Re: Can't get Alphanumeric FeatherWing + Metro ESP32-S2 to w

Post by dfeldman »

I'm back! I learned how to solder! Well, at least I'm learning. The soldering process for the Alphanumeric FeatherWing seemed to go well.

And now...still not working. No errors from the `quadalphanum` example—it gets to the "Start typing to display" prompt fine, but without anything lighting up. The Adafruit BusIO -> i2c_address_detect example set to 0x70 says, "Did not find device at 0x70," and the Wire -> WireScan example says, "No I2C devices found."

I suppose it's possible I screwed up the soldering but it seems unlikely I'd have screwed it up so badly that the ESP32 can't even see the FeatherWing board. So, now I'm stumped. (I don't suppose there's something I have to do to enable I2C overall, is there?)

Thanks again.
Attachments
IMG_4308.jpeg
IMG_4308.jpeg (307.69 KiB) Viewed 45 times
IMG_4307.jpeg
IMG_4307.jpeg (367.15 KiB) Viewed 45 times

User avatar
dastels
 
Posts: 10632
Joined: Tue Oct 20, 2015 3:22 pm

Re: Can't get Alphanumeric FeatherWing + Metro ESP32-S2 to w

Post by dastels »

3v, gnd, SDA, SCL. that's all you need. And your wiring looks good. Can you post closeups of the soldering? Specifically those pins and the LED pins.

Dave

User avatar
dfeldman
 
Posts: 14
Joined: Mon Jul 04, 2022 4:11 pm

Re: Can't get Alphanumeric FeatherWing + Metro ESP32-S2 to w

Post by dfeldman »

Took a whole bunch of photos; given the three-attachment limit here I've put them in Dropbox:
https://www.dropbox.com/scl/fo/tum3i294 ... m9y1uik8h4

Thanks!!

User avatar
dastels
 
Posts: 10632
Joined: Tue Oct 20, 2015 3:22 pm

Re: Can't get Alphanumeric FeatherWing + Metro ESP32-S2 to w

Post by dastels »

I see some problem soldering. There's lots of blobs, and in some cases there's solder on the pin but none (or very little) on the pad around the pin. The goal is for them to look like little round tents where the pin is the center pole; cones with slightly concave sides. See https://learn.adafruit.com/adafruit-gui ... -soldering and https://learn.adafruit.com/collins-lab-soldering

Dave

User avatar
dfeldman
 
Posts: 14
Joined: Mon Jul 04, 2022 4:11 pm

Re: Can't get Alphanumeric FeatherWing + Metro ESP32-S2 to w

Post by dfeldman »

Yeah, I’m definitely still learning. What’s your recommended course of action here? Is it salvageable?

And also: am I correct in thinking I could solder the pins onto the FeatherWing and test the i2c connection before going on to solder the LED modules on?

User avatar
dastels
 
Posts: 10632
Joined: Tue Oct 20, 2015 3:22 pm

Re: Can't get Alphanumeric FeatherWing + Metro ESP32-S2 to w

Post by dastels »

Yes, no worries. Just redo them. See those guides/videos. you want to heat the pin and pad with the iron tip on both, add a bit of solder. It should coat the area around the pin and get sucked into the hole around it with a bit left stuck to the pin. Again looking like a concave cone. Basically, balls are always bad. Gloopy and rough looking is bad.

Dave

User avatar
dfeldman
 
Posts: 14
Joined: Mon Jul 04, 2022 4:11 pm

Re: Can't get Alphanumeric FeatherWing + Metro ESP32-S2 to w

Post by dfeldman »

Gotcha. To get the LED modules off again do I use solder wick or a solder sucker or something? Or try and get at the bad joins without doing that?

User avatar
dastels
 
Posts: 10632
Joined: Tue Oct 20, 2015 3:22 pm

Re: Can't get Alphanumeric FeatherWing + Metro ESP32-S2 to w

Post by dastels »

There shouldn't be any need to remove them (or the headers). Sometimes all that's needed it a bit more heat to melt the solder and let it flow. Worst case you might need some wick to remove excess solder.

Dave

User avatar
dfeldman
 
Posts: 14
Joined: Mon Jul 04, 2022 4:11 pm

Re: Can't get Alphanumeric FeatherWing + Metro ESP32-S2 to work

Post by dfeldman »

That worked! Thank you so much!!

User avatar
dastels
 
Posts: 10632
Joined: Tue Oct 20, 2015 3:22 pm

Re: Can't get Alphanumeric FeatherWing + Metro ESP32-S2 to work

Post by dastels »

Awesome! You are very welcome.

Dave

Post Reply
Please be positive and constructive with your questions and comments.

Return to “Arduino”