Black Lives Matter - Action and Equality. ... Adafruit is open and shipping.
0

MatchPort Times Out - HELP!
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

MatchPort Times Out - HELP!

by wirelessjoe on Wed Mar 25, 2009 6:40 pm

I used some of ladyada's code and modified it to just turn on/off an LED. The matchport will serve up the webpage no problem but will time out when an on/off option is selected. Why is this happening and how can I fix it?!? Thank you. (BTW, ladyada's code works for both matchport and xport).
wirelessjoe
 
Posts: 13
Joined: Mon Mar 23, 2009 5:50 pm

Re: MatchPort Times Out - HELP!

by wirelessjoe on Wed Mar 25, 2009 6:58 pm

Perhaps I should also mention that sometimes (although I set it to port 80), the device still shows the webserver menu instead of the code embedded in the arduino. Odd...
wirelessjoe
 
Posts: 13
Joined: Mon Mar 23, 2009 5:50 pm

Re: MatchPort Times Out - HELP!

by franklin97355 on Thu Mar 26, 2009 11:26 am

It would be helpful if we could see the code you are running. Also you can edit your original message rather than adding a new one 18 minutes later.

franklin97355
 
Posts: 21508
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: MatchPort Times Out - HELP!

by wirelessjoe on Thu Mar 26, 2009 11:48 am

Sorry about the double post. The code on the arduino isn't the problem, it worked fine when i ran it non-wirelessly with the xport. Thus, im pretty sure it's some settings with the matchport like:

*** Channel 1
Baudrate 9600, I/F Mode 4C, Flow 00
Port 10001
Remote IP Adr: --- none ---, Port 00000
Connect Mode : D4
Disconn Mode : 00
Flush Mode : 00

I think i need to adjust/change some of them...not sure which though..
wirelessjoe
 
Posts: 13
Joined: Mon Mar 23, 2009 5:50 pm

Please be positive and constructive with your questions and comments.