0

communication breakdown between my arduino and servos
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

communication breakdown between my arduino and servos

by gr33nhorn on Thu May 07, 2009 9:16 am

Hi guys, i am currently working on a project that use arduino to control 12servos. I am using the pin 0 and 1(Communication: Multi drop Full Duplex UART serial communication) to send packets of commands to all servos which are connected in daisy chain manner. Initially, everything seems to work fine as all the servos respond according to the commands transmitted from arduino. But after a few weeks later, those packets commands seem to only able to transmit to a few servos and the rest of the servo didnt receive any commands. Can someone tell me what is going on or tell me what can i do? :'(

thanks in advance
gr33nhorn
 
Posts: 34
Joined: Sat Sep 20, 2008 4:36 pm

Re: communication breakdown between my arduino and servos

by mtbf0 on Thu May 07, 2009 9:39 am

what manner of servos are these?

must be digital to be talking over the usart.

you have supplied precious little data.
"i want to lead a dissipate existence, play scratchy records and enjoy my decline" - iggy pop, i need more
User avatar
mtbf0
 
Posts: 1645
Joined: Sat Nov 10, 2007 12:59 am
Location: oakland ca

Re: communication breakdown between my arduino and servos

by gr33nhorn on Fri May 08, 2009 11:36 pm

ya..they are digital servos.i will post my ugly code later if you want to see.


the info in the servo is in this linkhttp://www.tribotix.info/Downloads/RoboBuilder/wCK/User%20Manual%20_%20v1.07%20EN.pdf
gr33nhorn
 
Posts: 34
Joined: Sat Sep 20, 2008 4:36 pm

Please be positive and constructive with your questions and comments.