0

LEDs / Arduino / Oddity
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

LEDs / Arduino / Oddity

by servin on Tue Dec 25, 2018 6:33 pm

Seasons Greetings !
I made a little display using two different RGB LED strips; one 5v and one 12v. (from some random collections,
and I confess these were not necessarily bought from Adafruit - I really cant remember.)
I provide separate power from two different (5v & 12v) transformers for the lights.
I tie all the grounds together . The code uses the Ada Neopixel library.
All is well.
When I want to take the computer & USB cable out of the loop, and just drive the board (either UNO or DUE, I've tried both)
from the 5v power supply (2.5a) the 12v LED strip doesnt work anymore; the 5v is fine.
With the USB cable plugged into the board, all is well. When it's unplugged, and power provide by the 5v power supply,
then almost all is well; but the 12v LED strip wont light up !
??
It doesnt make any sense to me.
Any suggestions?

SErvin

servin
 
Posts: 8
Joined: Tue May 16, 2017 9:00 am

Re: LEDs / Arduino / Oddity

by caitlinsdad on Wed Dec 26, 2018 1:06 am

To figure things out, you may want to provide a picture of your setup and the code you are using to light the strips.
I'm not sure if your 5v strip is a neopixel LED or a regular RGB led strip. They are wired and coded differently.
Using 12V strips can damage your board if you don't have something like relays, power transistors or other circuitry to isolate the 12v from the 5v arduino chip.

caitlinsdad
 
Posts: 563
Joined: Fri Feb 24, 2012 4:23 pm

Re: LEDs / Arduino / Oddity

by AevaLighting on Fri Dec 28, 2018 12:42 am

the 12V led strip is not individully addressable?

The 2 type may different code, can not work together

AevaLighting
 
Posts: 5
Joined: Fri Dec 28, 2018 12:27 am

Re: LEDs / Arduino / Oddity

by adafruit_support_bill on Fri Dec 28, 2018 7:40 am

Sounds like a grounding issue. Photos of your setup would be helpful.

adafruit_support_bill
 
Posts: 73049
Joined: Sat Feb 07, 2009 10:11 am

Re: LEDs / Arduino / Oddity

by servin on Fri Dec 28, 2018 11:19 am

Thanks all for the response(s).
I do have separate power supplies for the LEDs & all grounds are firmly tied together.
In the course of more forensics, I found other flakiness with the 12v LED strip (which is, yes, compatible with Neopixel library, and individually addressable.)
So I have tossed it back into the scrap pile (perhaps to regret again later : ) and found some more 5V strips, and have moved on.
The observed relationship between USB vs power supplies still puzzles me (I did run a separate ground from the board to the computer , just in case...)
but its not worth puzzling over any more...

Thanks for the attention;
Happy New Year !

SErvin

servin
 
Posts: 8
Joined: Tue May 16, 2017 9:00 am

Please be positive and constructive with your questions and comments.