0

No joy trying to get going the HX8357
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

No joy trying to get going the HX8357

by ITAlexR on Sun Feb 10, 2019 2:29 pm

I'm having issues trying to get the HX8357 going. I am using the Particle Photon. I have the following definitions and the HX8357 is connected as indicated by the definitions except the RST, but all what I get is a blank screen. Any help will be appreciated. I soldered the SPI pad or jumper.

// These are 'flexible' lines that can be changed
#define TFT_DC A0
#define TFT_CS A1 // Can be any I/O pin
#define TFT_CLK A3
#define TFT_MISO A4
#define TFT_MOSI A5
#define TFT_RST -1 // RST can be set to -1 if you tie it to Arduino's reset

// Use hardware SPI (on Uno, #13, #12, #11) and the above for CS/DC
// For Particle: SPI A3, A4, A5 (SPI1 D5, D4, D3; SPI2 C3, C2, C1)
Adafruit_HX8357 tft(SPI, TFT_CS, TFT_DC, TFT_RST);

// Use software SPI
//Adafruit_HX8357 tft(A5, A4, D3, D11, -1, D2);

ITAlexR
 
Posts: 16
Joined: Tue Jan 01, 2019 10:55 pm

Re: No joy trying to get going the HX8357

by franklin97355 on Sun Feb 10, 2019 2:46 pm

Can you post the entire program or link to its location? Have you tried theexamples in the library?

franklin97355
 
Posts: 20510
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: No joy trying to get going the HX8357

by ITAlexR on Sun Feb 10, 2019 2:54 pm

franklin97355 wrote:Can you post the entire program or link to its location? Have you tried theexamples in the library?
Yes, actually I am trying the GraphicTest example.
The GraphicTest example has these definitions:
Code: Select all | TOGGLE FULL SIZE
#include "Adafruit_HX8357.h"
// These are 'flexible' lines that can be changed
#define TFT_CS A6   // if several devices share SPI otherwise CS = SS
#define TFT_DC A7
#define TFT_RST -1  // RST can be set to -1 if you tie it to Arduino's reset
// Use hardware SPI (on Uno, #13, #12, #11) and the above for CS/DC
// For Particle: SPI A3, A4, A5 (SPI1 D5, D4, D3; SPI2 C3, C2, C1)
Adafruit_HX8357 tft(SPI, TFT_CS, TFT_DC, TFT_RST);
// Use software SPI
//Adafruit_HX8357 tft(D6, D7, D5, D3, -1, D4);

So I changed those definitions, but It does not matter how that section is configured, still I get a blank screen.

ITAlexR
 
Posts: 16
Joined: Tue Jan 01, 2019 10:55 pm

Re: No joy trying to get going the HX8357

by franklin97355 on Sun Feb 10, 2019 4:13 pm

I don't see that code in the graphicstest example for the HX8357. Where did you get that code? Have you tried the Particle library for the HX8357?

franklin97355
 
Posts: 20510
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: No joy trying to get going the HX8357

by ITAlexR on Sun Feb 10, 2019 5:43 pm

[quote="franklin97355"]I don't see that code in the graphicstest example for the HX8357. Where did you get that code? Have you tried the Particle library for the HX8357?[/quot
That code, and two more examples are in the Particle library, I am getting from the Particle library. See attached screenshot.
Attachments
HX8357.PNG
HX8357.PNG (44.87 KiB) Viewed 114 times

ITAlexR
 
Posts: 16
Joined: Tue Jan 01, 2019 10:55 pm

Re: No joy trying to get going the HX8357

by franklin97355 on Sun Feb 10, 2019 5:55 pm

OK, let's look at the hardware. Can you post pictures of the boards and their connections between them? Also, your soldering from both sides would help.

franklin97355
 
Posts: 20510
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: No joy trying to get going the HX8357

by ITAlexR on Sun Feb 10, 2019 6:15 pm

franklin97355 wrote:OK, let's look at the hardware. Can you post pictures of the boards and their connections between them? Also, your soldering from both sides would help.


Here a couple pictures how is connected it. The blue wire is A0, etc. I have the ILI9341 and worked just fine, but this puppy refuse to cooperate. If I move the red wire to 3.3V and feed 3.3V , I get a black screen.
Attachments
Display Wiring2.jpg
Display Wiring2.jpg (291.27 KiB) Viewed 110 times
Board and DIsplay2.jpg
Board and DIsplay2.jpg (269.08 KiB) Viewed 110 times

ITAlexR
 
Posts: 16
Joined: Tue Jan 01, 2019 10:55 pm

Re: No joy trying to get going the HX8357

by ITAlexR on Mon Feb 11, 2019 1:27 pm

franklin97355 wrote:OK, let's look at the hardware. Can you post pictures of the boards and their connections between them? Also, your soldering from both sides would help.


Do you think this display is defective, should I send it back?

ITAlexR
 
Posts: 16
Joined: Tue Jan 01, 2019 10:55 pm

Re: No joy trying to get going the HX8357

by franklin97355 on Mon Feb 11, 2019 2:59 pm

Have you posted in the Particle forums? I don't see any reason it should not work.

franklin97355
 
Posts: 20510
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: No joy trying to get going the HX8357

by adafruit2 on Mon Feb 11, 2019 4:05 pm

try adding a reset pin to do a hardware reset. its *probably not* the display - we haven't had many issues. if you can test it with an arudino UNO that will help debug it a lot (we test against that for all boarsd)

adafruit2
Site Admin
 
Posts: 18327
Joined: Fri Mar 11, 2005 7:36 pm

Re: No joy trying to get going the HX8357

by ITAlexR on Mon Feb 11, 2019 4:31 pm

adafruit2 wrote:try adding a reset pin to do a hardware reset. its *probably not* the display - we haven't had many issues. if you can test it with an arudino UNO that will help debug it a lot (we test against that for all boarsd)


Sorry but I dont have Arduino Uno. I added the pin reset, that did not help/

ITAlexR
 
Posts: 16
Joined: Tue Jan 01, 2019 10:55 pm

Re: No joy trying to get going the HX8357

by adafruit2 on Mon Feb 11, 2019 4:42 pm

its going to be very hard to debug it without one :/ you may want to pick one up!

adafruit2
Site Admin
 
Posts: 18327
Joined: Fri Mar 11, 2005 7:36 pm

Re: No joy trying to get going the HX8357

by ITAlexR on Mon Feb 11, 2019 5:21 pm

adafruit2 wrote:its going to be very hard to debug it without one :/ you may want to pick one up!


The Arduino Uno is way too old. Can I send back this display?

ITAlexR
 
Posts: 16
Joined: Tue Jan 01, 2019 10:55 pm

Re: No joy trying to get going the HX8357

by adafruit2 on Mon Feb 11, 2019 5:24 pm

you'd use the Uno for testing only - it would at least tell you whats up with your display. (we dont take returns once you've used it)

adafruit2
Site Admin
 
Posts: 18327
Joined: Fri Mar 11, 2005 7:36 pm

Re: No joy trying to get going the HX8357

by ITAlexR on Tue Feb 12, 2019 2:21 am

adafruit2 wrote:you'd use the Uno for testing only - it would at least tell you whats up with your display. (we dont take returns once you've used it)


You got be out of touch, Pal! You want me to buy the Uno to debug your defective product? You are funny! I though this lady will stand by the product she sells, I guess I was wrong! One less customer for this lady.
Last edited by ITAlexR on Tue Feb 12, 2019 2:38 am, edited 1 time in total.

ITAlexR
 
Posts: 16
Joined: Tue Jan 01, 2019 10:55 pm

Please be positive and constructive with your questions and comments.