0

Dead on arrival Adafruit Bluefruit LE UART Friend
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Dead on arrival Adafruit Bluefruit LE UART Friend

by JayMauch on Sun May 05, 2019 8:42 pm

This BLE Friend won't power up_note screen and connection led resized.jpg
this unit doesn't power up or show up on my iPhone.
This BLE Friend won't power up_note screen and connection led resized.jpg (299.53 KiB) Viewed 241 times

I bought 2 units. The 1st one worked, but when I plugged the 2nd unit in place of the first one on my breadboard, it showed no sign of life. I checked to make sure I plugged into the correct holes and that there were no solder bridges or cold solder joints. All ok there.
I tried factory reset. It worked on the functional one, but not on the dead-out-of-the-bag one. The good one sends text in uart mode from Arduino serial monitor to iPhone, but not from phone to serial monitor. Same goes for commands in cmd mode. The dead one doesn't do either.
Right now, the only problem I would like to get taken care of is replacing my dead Friend.
Can you please help me out with that? If so, thanks.

I have other photos but could not get more than one to post on here.

JayMauch
 
Posts: 9
Joined: Sat May 04, 2019 5:04 pm

Re: Dead on arrival Adafruit Bluefruit LE UART Friend

by adafruit_support_carter on Mon May 06, 2019 4:38 pm

I have other photos but could not get more than one to post on here.

Was it complaining about size limits? In general, you should be able to post more, but there are some max limits in place.

Can you try posting one more that shows the soldering on the suspect board in a little more detail.

adafruit_support_carter
 
Posts: 13218
Joined: Tue Nov 29, 2016 2:45 pm

Re: Dead on arrival Adafruit Bluefruit LE UART Friend

by JayMauch on Mon May 06, 2019 7:20 pm

defective ble top resized.jpg

here are the solder joints
Last edited by JayMauch on Mon May 06, 2019 7:28 pm, edited 1 time in total.

JayMauch
 
Posts: 9
Joined: Sat May 04, 2019 5:04 pm

Re: Dead on arrival Adafruit Bluefruit LE UART Friend

by JayMauch on Mon May 06, 2019 7:25 pm



This is the 1st of the two Friends. It seems to work in one direction. When I swap the two friends, the 2nd doesn't show any brain activity.

JayMauch
 
Posts: 9
Joined: Sat May 04, 2019 5:04 pm

Re: Dead on arrival Adafruit Bluefruit LE UART Friend

by JayMauch on Mon May 06, 2019 7:34 pm

defective ble top resized 800x600.jpg
solder joints 800x600
defective ble top resized 800x600.jpg (111.05 KiB) Viewed 214 times


lemme try this one
Attachments
defective ble top resized.jpg
defective ble top resized.jpg (334.35 KiB) Viewed 214 times

JayMauch
 
Posts: 9
Joined: Sat May 04, 2019 5:04 pm

Re: Dead on arrival Adafruit Bluefruit LE UART Friend

by JayMauch on Mon May 06, 2019 7:38 pm

The attachment This BLE Friend powers up_ note screen resized 800x600.jpg is no longer available
Attachments
This BLE Friend  powers up_ note screen resized.jpg
This BLE Friend powers up_ note screen resized.jpg (296.24 KiB) Viewed 210 times

JayMauch
 
Posts: 9
Joined: Sat May 04, 2019 5:04 pm

Re: Dead on arrival Adafruit Bluefruit LE UART Friend

by JayMauch on Mon May 06, 2019 8:07 pm

I hope i'm not wasting our time. I'm trying to control my robot from my cell phone, through the Friend, to a Uno running the motor shield. Am I on the right track? I still need to get the commands to go from the phone to the Arduino Uno, not from the serial monitor to the Uno. Would be kinda nice to get feedback from Uno to phone, too.
I bought the 2nd Friend in hopes of Blue tooth controlling my lawn tractor to cut the front hill without having to be on it.

JayMauch
 
Posts: 9
Joined: Sat May 04, 2019 5:04 pm

Re: Dead on arrival Adafruit Bluefruit LE UART Friend

by adafruit_support_carter on Tue May 07, 2019 2:28 pm

Is the "MODE" LED blinking at all? You can check its behavior with your other BLE that you know works. Try removing all the connections except for power - so GND and VIN. The MODE LED should blink regardless of which position the UART/CMD switch is in.

The other LED, the "CONN" one, will only come on when a connection is established. So the other LED works better as a sanity check.

adafruit_support_carter
 
Posts: 13218
Joined: Tue Nov 29, 2016 2:45 pm

Re: Dead on arrival Adafruit Bluefruit LE UART Friend

by JayMauch on Tue May 07, 2019 3:39 pm

The working unit's MODE led blinks.

The dead unit's MODE led doesn't blink with only Vin and Ground connected.

JayMauch
 
Posts: 9
Joined: Sat May 04, 2019 5:04 pm

Re: Dead on arrival Adafruit Bluefruit LE UART Friend

by adafruit_support_carter on Tue May 07, 2019 3:56 pm

OK, one more check. Almost forgot about this one. Try grounding the DFU pin to see if it will go into firmware update mode:
https://learn.adafruit.com/introducing- ... fu-pin-5-2

You don't need to worry about removing the connection after 5 seconds for this check. Just jumper DFU to GND and wait 5 seconds. See if you get any activity on the LEDs then.

adafruit_support_carter
 
Posts: 13218
Joined: Tue Nov 29, 2016 2:45 pm

Re: Dead on arrival Adafruit Bluefruit LE UART Friend

by JayMauch on Tue May 07, 2019 4:02 pm

still nothing, even after 30 seconds

JayMauch
 
Posts: 9
Joined: Sat May 04, 2019 5:04 pm

Re: Dead on arrival Adafruit Bluefruit LE UART Friend

by adafruit_support_carter on Tue May 07, 2019 4:12 pm

OK, thanks for all the testing. Let's replace it. Send an email to support@adafruit.com with a link to this thread and your order number and they can see you a new BLE UART Friend.

adafruit_support_carter
 
Posts: 13218
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.