0

MPR121 Sensor Board... Hangs
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

MPR121 Sensor Board... Hangs

by Jimbee on Sun Aug 18, 2019 12:50 pm

Hi,
I just purchased and received both your CAP1188 and MPR121 cap sensor boards. I started out with the CAP1188 sensor using I2C and MetroM4 @ 3.3VDC and your example code everything works fine. I changed to the MPR121 sensor using the same setup with the exception of code (used your example MPR121 test code) and it cannot find the sensor - hangs at cap.begin(0x5A) initialization. Exactly the same error others have posted. For both sensors the 3.3VDC is supplied via a bench top power supply - not powered by the Metro USB. I have tried scanning the I2C bus and it finds both sensors at address CAP1188 @ 0x29 & MPR121 @ 0x5A. Also Tried changing the address from 0x5A the default address to 0x5B both hang. I believe the 121 sensor board may be defective.

Jimbee
 
Posts: 28
Joined: Wed Aug 01, 2018 12:49 pm

Re: MPR121 Sensor Board... Hangs

by adafruit_support_carter on Mon Aug 19, 2019 1:11 pm

Can you post a photo of your setup showing how everything is wired together.

And just to be clear - you are running this example:
https://github.com/adafruit/Adafruit_MP ... 21test.ino
and you don't see either of the serial prints after the call to begin?

adafruit_support_carter
 
Posts: 12958
Joined: Tue Nov 29, 2016 2:45 pm

Re: MPR121 Sensor Board... Hangs

by Jimbee on Mon Aug 19, 2019 3:03 pm

Hi Carter,

Thanks for your reply. My email is currently down and I can't get the photo off my cell phone right now. This is my basic setup both sensor boards are on the same breadboard and wired up on the same I2C bus. I have also tried them both wired up alone and only the MPR board hangs. The I2C scanner finds both boards. The CAP board works flawlessly and the MPR board does not work at all - only the serial.print before the cap.begin() is displayed and then it hangs. Yes, I am using the example code included with your lib. I will send the photo once my email is back up.

Jimbee
 
Posts: 28
Joined: Wed Aug 01, 2018 12:49 pm

Re: MPR121 Sensor Board... Hangs

by adafruit_support_carter on Mon Aug 19, 2019 3:21 pm

I just tested the example with an MPR121 and a Metro M4 Express and it ran fine.
Screenshot from 2019-08-19 12-16-12.png
Screenshot from 2019-08-19 12-16-12.png (24.24 KiB) Viewed 117 times


So will be good to check your hardware setup once you get it uploaded. Could have something to do with this:
For both sensors the 3.3VDC is supplied via a bench top power supply - not powered by the Metro USB.

adafruit_support_carter
 
Posts: 12958
Joined: Tue Nov 29, 2016 2:45 pm

Re: MPR121 Sensor Board... Hangs

by Jimbee on Thu Aug 22, 2019 3:05 pm

Hi Carter,

Here is a photo of my setup with both sensors on the I2C bus. I am using an old red PCB ground plane as a touch pad.
Attachments
IMG_0907.JPG
IMG_0907.JPG (749.4 KiB) Viewed 89 times

Jimbee
 
Posts: 28
Joined: Wed Aug 01, 2018 12:49 pm

Re: MPR121 Sensor Board... Hangs

by adafruit_support_carter on Thu Aug 22, 2019 3:22 pm

Thought this sounded familiar.
viewtopic.php?f=22&t=155458

For troubleshooting, please try powering from the Metro using the wiring shown in the guide:
https://learn.adafruit.com/adafruit-mpr ... ial/wiring
and only connect one item at a time. In this case, the MPR121.

adafruit_support_carter
 
Posts: 12958
Joined: Tue Nov 29, 2016 2:45 pm

Re: MPR121 Sensor Board... Hangs

by Jimbee on Fri Aug 23, 2019 11:17 am

Thanks for your reply.

I have tried powering the sensor from the Metro - no change.
I have tried setting it up with only one sensor on the I2C bus - no change.

Jimbee
 
Posts: 28
Joined: Wed Aug 01, 2018 12:49 pm

Re: MPR121 Sensor Board... Hangs

by adafruit_support_carter on Fri Aug 23, 2019 12:19 pm

Let's work the MPR121 issue first. Post a photo showing the MPR121 wired to the Metro per the guide linked above.

adafruit_support_carter
 
Posts: 12958
Joined: Tue Nov 29, 2016 2:45 pm

Re: MPR121 Sensor Board... Hangs

by Jimbee on Fri Aug 30, 2019 11:19 am

Hi Carter,
I have decided to go in a different direction. Thanks for your help.

Jimbee
 
Posts: 28
Joined: Wed Aug 01, 2018 12:49 pm

Re: MPR121 Sensor Board... Hangs

by adafruit_support_carter on Tue Sep 03, 2019 12:57 pm

OK, good luck. Not sure what was causing the original issue. We couldn't recreate it here.

adafruit_support_carter
 
Posts: 12958
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.