Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

ItsyBitsy32u4 5V
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

ItsyBitsy32u4 5V

by R1234 on Thu Jan 09, 2020 12:31 pm

Receive ItsyBitsy last week. Last two days it worked fine. Today is
seem to be in trouble. (Like it's stuck in download on power up)

Now when I plug in the usb cable the red led blinks like it downloading.

Comm port is shown while the red led is blinking. when it stop blinking
the comm port is gone.

Windows Device Manager Sees It while led is flashing but when it quits
flashing ItsyBitsy gone!

Pressing reset PButton after power up doesn't help!
Holding reset PButton while power up doesn't help!

Ron

R1234
 
Posts: 7
Joined: Wed Jan 08, 2020 9:43 pm

Re: ItsyBitsy32u4 5V

by dastels on Thu Jan 09, 2020 1:45 pm

Do you have anything connected to the ItsyBitsy? What did you work on with it yesterday? First thing today?

Dave

dastels
 
Posts: 3767
Joined: Tue Oct 20, 2015 3:22 pm

Re: ItsyBitsy32u4 5V

by R1234 on Thu Jan 09, 2020 4:47 pm

Dave:
Nothing connected to ItsyBitsy at this time. Did blink on board led when I first receive it.
Yesterday working on functions, passing variables back and forth nothing connected worked fine.
Today tried to program same function sketch. no download - no comm port.
Comm Port only shows up on connecting USB. Red LED blinks like it downloading
for about 15 seconds then no comm port
Ron

R1234
 
Posts: 7
Joined: Wed Jan 08, 2020 9:43 pm

Re: ItsyBitsy32u4 5V

by R1234 on Tue Jan 14, 2020 10:06 am

Dave

Tried ItsyBitsy on two other PCs, same problem. Unless you have some Idea, I think it lost.

What's the chance of a Replacement? Been using Mega, UNO, Huzzah, ILI9340 and ILI9341 for years< no problems.

Ron

Only worked for 3 days!

R1234
 
Posts: 7
Joined: Wed Jan 08, 2020 9:43 pm

Re: ItsyBitsy32u4 5V

by dastels on Tue Jan 14, 2020 10:58 am

I don't have anything more, but I've push it up the chain to see if anyone has insight.

dastels
 
Posts: 3767
Joined: Tue Oct 20, 2015 3:22 pm

Re: ItsyBitsy32u4 5V

by R1234 on Thu Feb 13, 2020 12:01 pm

Dave
Got tired of waiting for your reply, bought two more ItsyBitsys . First one worked OK fine for several uploads, but now windows doesn't recognize the device. Just as first one, problem with bootloader. Restarted windows (7), reinstalled drivers, no good. Windows Device Manager (unrecognized device). Not going to try the third one. If you can't come up with a fix, send me return address. I'll send them back.

Ron

R1234
 
Posts: 7
Joined: Wed Jan 08, 2020 9:43 pm

Re: ItsyBitsy32u4 5V

by dastels on Thu Feb 13, 2020 2:01 pm

You don't say what you're using to program it, but I'm guessing Arduino since you mention "sketch".
Have you tried double pressing reset while it's looking for the board to upload to?

I've also brought this to other folks' attention.

Dave

dastels
 
Posts: 3767
Joined: Tue Oct 20, 2015 3:22 pm

Re: ItsyBitsy32u4 5V

by R1234 on Thu Feb 13, 2020 3:09 pm

Dave
Using Arduino 1.8.10. Pressing reset now comm port shows up as comm18, but will not upload. Arduino IDE message uploading.
No blinking onboard led. Went back to UNO simple blink led13 same as itsybitsy. UNO works fine! Don't know what to try, seems to be lost in bootloader mode.
Ron

R1234
 
Posts: 7
Joined: Wed Jan 08, 2020 9:43 pm

Re: ItsyBitsy32u4 5V

by R1234 on Thu Feb 13, 2020 4:12 pm

Dave
Spent two hours trying different things. Reset windows changed comm port to 19, still no upload. Holding reset on power up, pressing reset while powered many times and comm went back to comm 18. Blink sketch now loads!!!!. Wanted to use this small form factor for two wheel robot. Spending too much time trying to get to upload. My first itsybitsy will not come to life, no mater what I try.
Never had any trouble with UNO or MEGA.

Ron

R1234
 
Posts: 7
Joined: Wed Jan 08, 2020 9:43 pm

Re: ItsyBitsy32u4 5V

by dastels on Fri Feb 14, 2020 12:01 am

Have you tried pressing reset (try once and twice) during upload?

Also, have a look at https://learn.adafruit.com/adafruit-feather-32u4-adalogger/faq, specifally the third question/advice and it's 7th step.

Dave

dastels
 
Posts: 3767
Joined: Tue Oct 20, 2015 3:22 pm

Re: ItsyBitsy32u4 5V

by danhalbert on Fri Feb 21, 2020 3:24 pm

If you double-click and then make sure the port is select in the Arduino IDE ports menu, that works for me.

danhalbert
 
Posts: 2134
Joined: Tue Aug 08, 2017 12:37 pm

Re: ItsyBitsy32u4 5V

by R1234 on Sat Feb 22, 2020 10:27 pm

Dave
Your things to try on feb 14 worked. My first ItsyBitsy came back to life!!!
Turning on Verbose Upload was the fix for my problem.
tks Ron

R1234
 
Posts: 7
Joined: Wed Jan 08, 2020 9:43 pm

Re: ItsyBitsy32u4 5V

by dastels on Sat Feb 22, 2020 11:58 pm

Excellent!

dastels
 
Posts: 3767
Joined: Tue Oct 20, 2015 3:22 pm

Please be positive and constructive with your questions and comments.