Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

Unresponsive VC0706 Camera and MicroSD breakoutboard
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Unresponsive VC0706 Camera and MicroSD breakoutboard

by KeanResearch on Wed Jan 22, 2020 7:21 pm

Hello,

I am using an Arduino Micro to run a photo logger apparatus. I am having issues getting the Adafruit VC0706 Camera 'TTL Serial JPEG Camera with NTSC Video' or the Adafruit microSD breakout board to initialize in my setup. I have run independent scripts to test these components and both of these scripts have indicated that there is some failure on the component's behalf. When running the supplied 'Camera_Check.ino' my serial monitor seems to only indicate "Failed to Snap!" and that an image of 0bytes was stored. As expected no data has been written to the SD card (which is formatted to FAT32). When individually checking my microSD card logger, I have been using the sketch under Examples--> SD---> Cardinfo.ino and modifying my chipselect accordingly. Running this sketch yields the following response: "initialization failed. Things to check: is a card inserted? is your wiring correct? did you change the chipSelect pin to match your shield or module?" I have checked the wiring and even used various MicroSDs and breakout board modules but still get this error.

Attached is my intended sketch, and a photo of my circuit.
Any help is much appreciated.
Thanks
Attachments
Microlab03_Button.ino
(2.66 KiB) Downloaded 9 times
Microlab03-Resize.PNG
Microlab03-Resize.PNG (297.14 KiB) Viewed 98 times
Camera_check.ino
(2.63 KiB) Downloaded 6 times

KeanResearch
 
Posts: 37
Joined: Sat Jan 11, 2020 12:22 am

Re: Unresponsive VC0706 Camera and MicroSD breakoutboard

by adafruit_support_carter on Wed Jan 22, 2020 8:03 pm

Looks like you have some other things going on. In particular, a couple of motors. Ignore those for now and see if you can wire things up per the guide and get the basic test to work:
https://learn.adafruit.com/ttl-serial-c ... uino-usage

If you are still having issues, post photos of your actual setup showing how everything is wired together.

adafruit_support_carter
 
Posts: 17071
Joined: Tue Nov 29, 2016 2:45 pm

Re: Unresponsive VC0706 Camera and MicroSD breakoutboard

by KeanResearch on Fri Jan 24, 2020 7:20 pm

Hello,

so I would like to clarify that my motors and their respective module each work just fine in the circuit detailed within the provided image.

Just in case, I separated the components of concern and rebuilt the circuit exactly as seen here: https://learn.adafruit.com/ttl-serial-c ... uino-usage, with the only exceptions being that I am using an Arduino Micro and do not have a video output attached to the 2nd ground & CVB pin on the camera module. Despite doing this I am still receiving errors on my test sketches that indicate neither the camera or the microSD breakout board are functioning. I have changed out these components for new ones and still receive the same errors.

Any possible solutions are much appreciated.
Thanks

KeanResearch
 
Posts: 37
Joined: Sat Jan 11, 2020 12:22 am

Re: Unresponsive VC0706 Camera and MicroSD breakoutboard

by adafruit_support_carter on Sat Jan 25, 2020 1:19 pm

Please post photos of your actual setup showing how everything is wired together.

adafruit_support_carter
 
Posts: 17071
Joined: Tue Nov 29, 2016 2:45 pm

Re: Unresponsive VC0706 Camera and MicroSD breakoutboard

by KeanResearch on Sat Jan 25, 2020 4:17 pm

Hello,

attached are the photos of the simplified circuit used to troubleshoot as all other components of my intended circuit are functional. (will attach final photo in separate comment)

I receive same results regardless. This wiring is exactly as prescribed by the link in my last comment.

Thanks
Attachments
CameraLogger3.jpg
CameraLogger3.jpg (102.92 KiB) Viewed 79 times
CameraLogger2.jpg
CameraLogger2.jpg (107.05 KiB) Viewed 79 times
CameraLogger1.jpg
CameraLogger1.jpg (107.75 KiB) Viewed 79 times

KeanResearch
 
Posts: 37
Joined: Sat Jan 11, 2020 12:22 am

Re: Unresponsive VC0706 Camera and MicroSD breakoutboard

by KeanResearch on Sat Jan 25, 2020 4:18 pm

Final image
Attachments
CameraLogger4.jpg
CameraLogger4.jpg (135.38 KiB) Viewed 79 times

KeanResearch
 
Posts: 37
Joined: Sat Jan 11, 2020 12:22 am

Re: Unresponsive VC0706 Camera and MicroSD breakoutboard

by adafruit_support_carter on Sat Jan 25, 2020 5:08 pm

The example sketch uses software serial by default:
https://github.com/adafruit/Adafruit-VC ... ot.ino#L61

It looks like you are wired to the hardware serial pins. Did you change the code to match? Have you tried using software serial on pins 2/3?

adafruit_support_carter
 
Posts: 17071
Joined: Tue Nov 29, 2016 2:45 pm

Re: Unresponsive VC0706 Camera and MicroSD breakoutboard

by KeanResearch on Sat Jan 25, 2020 5:29 pm

I did match my code according to this wiring using (0, 1) as seen the provided sketch. When referencing the specs for the Arduino Micro, it says that Tx=D1 while Rx=D0. For this reason, I have the Camera's Tx wired to the controller's Rx and vice versa for the camera's Rx with the addition of the 10Kohm voltage divider.
I receive the same results when attempting to use the digital pins 2 and 3 for serial communication. In both case the serial LEDs illuminate on the microcontroller, but as soon as I access my serial monitor via the arduino IDE, the TX LED is then the only lit indicator, blinking in sync with the 'No camera found' serial output.

Perhaps I am missing something because I am getting failed results on a circuit isolating and testing the the SDcard board as well as originally stated.

Any ideas will be entertained though!

Thanks

KeanResearch
 
Posts: 37
Joined: Sat Jan 11, 2020 12:22 am

Re: Unresponsive VC0706 Camera and MicroSD breakoutboard

by adafruit_support_carter on Sat Jan 25, 2020 5:59 pm

OK, let's go one step further in simplifying and focus on just the SD card breakout. It sounds like maybe you have already done this? Idea is to ignore the camera for now and just wire up the SD card breakout per this guide:
https://learn.adafruit.com/adafruit-mic ... ino-wiring
and then see if you can at least get the cardinfo example to work:
https://learn.adafruit.com/adafruit-mic ... no-library

adafruit_support_carter
 
Posts: 17071
Joined: Tue Nov 29, 2016 2:45 pm

Re: Unresponsive VC0706 Camera and MicroSD breakoutboard

by KeanResearch on Sat Jan 25, 2020 6:12 pm

Yes I have done this (just now repeated, removing camera from circuit). When using the CardInfo.ino my serial monitor gives me the failed to initialize response that I detailed in my first post. When running my intended Sketch(provided in original post), a red LED illuminates on the SDcard board for a few moments but this does not happen with the cardinfo.ino or when checking the camera logger isolated circuit. I have ensured that I alter my chip select pin to 10 in the code, and have even used the recommended format-er to ensure the SD card is FAT32.

Thanks for continuing your troubleshooting efforts.

KeanResearch
 
Posts: 37
Joined: Sat Jan 11, 2020 12:22 am

Re: Unresponsive VC0706 Camera and MicroSD breakoutboard

by adafruit_support_carter on Mon Jan 27, 2020 1:11 pm

Let's continue to focus on just the SD card reader. Clean up your breadboard setup so it's just the SD card reader and the Arduino Micro. Jumper wires directly between the SD card reader the Arduino Micro - don't use the power rails. Post a photo of that actual setup.

Can you also post a photo showing a close up of the solder job on the SD reader breakout:
pins.jpg
pins.jpg (20.46 KiB) Viewed 56 times

adafruit_support_carter
 
Posts: 17071
Joined: Tue Nov 29, 2016 2:45 pm

Re: Unresponsive VC0706 Camera and MicroSD breakoutboard

by KeanResearch on Mon Jan 27, 2020 1:52 pm

Hello, attached are the requested photos. I ran this setup using two different SD card readers for which I have attached photos of their respective solder jobs. I have also tired different SD cards within the different breakout boards. In my intended circuit I use female jumpers to liberate these components from a break board and ensure they are all directly connected, but I still get same results. (final photo in next comment)


Thank you so much for your help.
Attachments
SDcircuit3.jpg
SDcircuit3.jpg (44.29 KiB) Viewed 55 times
SDcircuit2.jpg
SDcircuit2.jpg (45.77 KiB) Viewed 55 times
SDcircuit1.jpg
SDcircuit1.jpg (126.37 KiB) Viewed 55 times

KeanResearch
 
Posts: 37
Joined: Sat Jan 11, 2020 12:22 am

Re: Unresponsive VC0706 Camera and MicroSD breakoutboard

by KeanResearch on Mon Jan 27, 2020 1:53 pm

Continued from last post:
Attachments
SDcircuit4.jpg
SDcircuit4.jpg (86.27 KiB) Viewed 55 times

KeanResearch
 
Posts: 37
Joined: Sat Jan 11, 2020 12:22 am

Re: Unresponsive VC0706 Camera and MicroSD breakoutboard

by adafruit_support_carter on Mon Jan 27, 2020 2:32 pm

Some of those pins might be a little cold soldered and not adequately wetted out on the breakout solder pads. See here:
https://learn.adafruit.com/adafruit-gui ... n-problems
Try reflowing them and see if that helps.

adafruit_support_carter
 
Posts: 17071
Joined: Tue Nov 29, 2016 2:45 pm

Re: Unresponsive VC0706 Camera and MicroSD breakoutboard

by KeanResearch on Mon Jan 27, 2020 5:26 pm

Hello,

I did reflow these solder points to ensure a solid connection. Are there limitations to the type of wire used to get these components to function? I am just using basic jumper cables that are thin and not as thick in gauge as what is used in the official circuit diagrams.

KeanResearch
 
Posts: 37
Joined: Sat Jan 11, 2020 12:22 am

Please be positive and constructive with your questions and comments.