Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

setup for adafruit feather express m4
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

setup for adafruit feather express m4

by jbdean on Tue Feb 04, 2020 12:41 am

While trying to follow the guide at:
https://learn.adafruit.com/adafruit-fea ... md51/setup
the board file for: "First up, install the latest Arduino SAMD Boards (version 1.6.11 or later)" doesn't exist; the latest version is 1.5.10.
When installed I get:
Arduino: 1.8.11 (Mac OS X), Board: "Adafruit Feather M4 Express (SAMD51), Enabled, 120 MHz (standard), Small (-Os) (standard), 50 MHz (standard), Arduino, Off"

fork/exec /bin/arm-none-eabi-g++: no such file or directory
Error compiling for board Adafruit Feather M4 Express (SAMD51).
Invalid library found in /Users/user/Library/Arduino15/packages/adafruit/hardware/samd/1.5.10/libraries/CI_Tests: no headers files (.h) found in /Users/user/Library/Arduino15/packages/adafruit/hardware/samd/1.5.10/libraries/CI_Tests
Invalid library found in /Users/user/Library/Arduino15/packages/adafruit/hardware/samd/1.5.10/libraries/CI_Tests: no headers files (.h) found in /Users/user/Library/Arduino15/packages/adafruit/hardware/samd/1.5.10/libraries/CI_Tests

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

can anybody explain how to get past this?

jbdean
 
Posts: 2
Joined: Mon Feb 03, 2020 2:18 pm

Re: setup for adafruit feather express m4

by franklin97355 on Tue Feb 04, 2020 2:01 am

I just looked at the Arduino IDE Board Manager and the Arduino SAMD file is 1.8.4. You might make sure you have all boards and libraries up to date

franklin97355
 
Posts: 21605
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: setup for adafruit feather express m4

by jbdean on Tue Feb 04, 2020 9:47 am

Hi
thank you for your reply, but it's not very helpful.
How do I make sure they are 'up to date'?
when I open the boards manager, the latest available to install is 1.5.9.
What next?

Thank you

jbdean
 
Posts: 2
Joined: Mon Feb 03, 2020 2:18 pm

Re: setup for adafruit feather express m4

by franklin97355 on Tue Feb 04, 2020 2:24 pm

That seems to be the Adafruit SAMD boards and not the Arduino SAMD boards. Go to boards manager and select Update-able and install all that show up.

franklin97355
 
Posts: 21605
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: setup for adafruit feather express m4

by sketchybiz on Fri Feb 07, 2020 3:30 pm

Just to concur, I got the same compile time errors after updating to Arduino 1.8.11, updating all of the libraries. I'm using the Adafruit Feather M0 board and a standard blinky program. Despite the errors, the program compiles and runs.

Invalid library found in /home/<user>/.arduino15/packages/adafruit/hardware/samd/1.5.10/libraries/CI_Tests:
no headers files (.h) found in /home/<user>/.arduino15/packages/adafruit/hardware/samd/1.5.10/libraries/CI_Tests

I looked in this directory and indeed there are no header files there, only an examples directory. Looks harmless to me :)

sketchybiz
 
Posts: 1
Joined: Fri Feb 07, 2020 3:16 pm

Re: setup for adafruit feather express m4

by TC1000 on Fri Feb 07, 2020 5:41 pm

Same problem - I updated the Adafruit SAMD library and now get a host of compile-time errors...

Invalid library found in /Users/xxx/Library/Arduino15/packages/adafruit/hardware/samd/1.5.10/libraries/CI_Tests: no headers files (.h) found in /Users/xxx/Library/Arduino15/packages/adafruit/hardware/samd/1.5.10/libraries/CI_Tests

I get this error about 40 times.

TC1000
 
Posts: 4
Joined: Thu Jan 30, 2020 2:43 pm

Re: setup for adafruit feather express m4

by TC1000 on Fri Feb 07, 2020 5:48 pm

I just rolled back to library 1.5.9 and the compile errors go away. So it appears to be something in 1.5.10 that is causing the error.

TC1000
 
Posts: 4
Joined: Thu Jan 30, 2020 2:43 pm

Re: setup for adafruit feather express m4

by eetaro on Sun Feb 09, 2020 2:54 pm

Same problem. downgrading works. thanks.
eetaro
 
Posts: 6
Joined: Wed Jul 31, 2013 4:29 pm

Re: setup for adafruit feather express m4

by cbabcock_epi on Mon Feb 17, 2020 4:58 pm

So, this is a cosmetic error in the Adafruit SAMD board definitions...

Until they release a fix, you can do this to make the warnings go away:
- browse to /home/<user>/.arduino15/packages/adafruit/hardware/samd/1.5.10/libraries/CI_Tests
- create a file called "empty.h" in this directory, save, but make sure the file has NOTHING in it

This will fix the cosmetic warning issue. The other compile error may still persist.

cbabcock_epi
 
Posts: 10
Joined: Mon Aug 18, 2014 10:29 pm

Please be positive and constructive with your questions and comments.