Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

Flora never connects
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Flora never connects

by savva on Sat Feb 08, 2020 3:09 pm

Hi, I recently bought an Adafruit Flora. I haven't been able to communicate with it at all.
I have a bare Flora - nothing connected to it; I then plug it to my computer using USB. At first the computer detects and initializes it, but then almost immediately disconnects it, without me interacting with the Flora at all. I attached the result of the
Code: Select all | TOGGLE FULL SIZE
dmesg
command below. Same behavior have been observed on Linux, Mac, and Windows machines.
I'd appreciate any help!
Attachments
Screenshot from 2020-02-08 14-06-34.png
Screenshot from 2020-02-08 14-06-34.png (87.69 KiB) Viewed 103 times

savva
 
Posts: 9
Joined: Thu Oct 17, 2019 9:57 pm

Re: Flora never connects

by adafruit_support_carter on Mon Feb 10, 2020 3:20 pm

Let's check the hardware. Can you post photos of both sides of the board so we can look for anything obvious.

adafruit_support_carter
 
Posts: 17135
Joined: Tue Nov 29, 2016 2:45 pm

Re: Flora never connects

by savva on Mon Feb 10, 2020 7:32 pm

Please find attached.
Attachments
IMG_9478.JPG
IMG_9478.JPG (167.16 KiB) Viewed 91 times

savva
 
Posts: 9
Joined: Thu Oct 17, 2019 9:57 pm

Re: Flora never connects

by savva on Mon Feb 10, 2020 7:33 pm

and the back
Attachments
IMG_9479.JPG
IMG_9479.JPG (156.71 KiB) Viewed 91 times

savva
 
Posts: 9
Joined: Thu Oct 17, 2019 9:57 pm

Re: Flora never connects

by adafruit_support_carter on Tue Feb 11, 2020 2:01 pm

It looks like something was at one point soldered to the pads. What was done there?

adafruit_support_carter
 
Posts: 17135
Joined: Tue Nov 29, 2016 2:45 pm

Re: Flora never connects

by savva on Wed Feb 12, 2020 2:13 am

of course! Sorry, should have done that at the very beginning.
I soldered two devices to the Flora with wires:
adafruit's analog joystick breakout
joystick Flora
--------------------------
Vcc 3.3V
Xout D9
Sel D10
GND GND

and the nRF24L01+
nrf Flora
--------------------------
Vcc 3v3
GND GND (spi pin 6)
CE D12
CSN D6
SCK SCK (spi pin 3)
MISO MISO (spi pin 1)
MOSI MOSI (spi pin 4)


after soldering all of the above I plugged the Flora into my computer for the first time; installed the board manager, attempted an upload, but nothing happened - Flora disconnected on its own. I should have tested the Flora prior to completing any soldering, I guess. But all the connections are correct, as far as I can tell.
After that I desoldered the wires and tried using the flora on Windows/Mac/Linux. No success.

savva
 
Posts: 9
Joined: Thu Oct 17, 2019 9:57 pm

Re: Flora never connects

by adafruit_support_carter on Wed Feb 12, 2020 12:22 pm

There's always a chance the external hardware did something. But from the dmesg output, it looks like the board still alive to a certain extent.

Try this trick and see if you can recover this way:
https://learn.adafruit.com/adafruit-fea ... aq-2704880

adafruit_support_carter
 
Posts: 17135
Joined: Tue Nov 29, 2016 2:45 pm

Re: Flora never connects

by savva on Wed Feb 12, 2020 6:25 pm

Thank you for the reply!

I just tried the joystick and the nRF24 I used with Flora on an Arduino Uno - both work properly, and I am certain that the connections to Flora were as described above. I did not connect the Flora to my computer prior to soldering stuff to it - so whatever was on it initially is still running.

I tried the steps that you suggested: the Flora continues to disconnect itself after about ten seconds. It goes like this:
I plug in the Flora; dmesg indicates that a device was recognized on a port; TX / RX LEDs blink a couple of times; in ten seconds the board gets disconnected.
If I try to reset the Flora during these ten seconds, dmesg disconnects and reconnects the Flora - and then the ~ten second countdown begins again.
If I try to upload code within these ten seconds, Arduino throws an error stating that the port is busy (see screenshot below).

It seems to me that I got a defected Flora...
Attachments
Screenshot from 2020-02-12 17-21-55.png
Screenshot from 2020-02-12 17-21-55.png (75.98 KiB) Viewed 70 times

savva
 
Posts: 9
Joined: Thu Oct 17, 2019 9:57 pm

Re: Flora never connects

by adafruit_support_carter on Wed Feb 12, 2020 6:55 pm

If I try to upload code within these ten seconds, Arduino throws an error stating that the port is busy (see screenshot below).

Instead, go the other way around. Don't press reset until *after* starting the upload from Arduino. See step 7 in the FAQ link.

adafruit_support_carter
 
Posts: 17135
Joined: Tue Nov 29, 2016 2:45 pm

Re: Flora never connects

by savva on Wed Feb 12, 2020 8:47 pm

Aha, I see. I thought that since the port is busy uploading wouldn't work regardless.

tried that; I am getting two types of errors: either it can't recognize the chip (??) or it can't find the port. Screenshots attached.
Attachments
Screenshot from 2020-02-12 19-37-37.png
Screenshot from 2020-02-12 19-37-37.png (22.57 KiB) Viewed 59 times

savva
 
Posts: 9
Joined: Thu Oct 17, 2019 9:57 pm

Re: Flora never connects

by savva on Wed Feb 12, 2020 8:47 pm

and this; the board is Flora, port is correct, programmer is AVRISP Mkll
Attachments
Screenshot from 2020-02-12 19-40-09.png
Screenshot from 2020-02-12 19-40-09.png (18.17 KiB) Viewed 59 times

savva
 
Posts: 9
Joined: Thu Oct 17, 2019 9:57 pm

Re: Flora never connects

by adafruit_support_carter on Wed Feb 12, 2020 8:53 pm

Hmmm. Have you tried other USB cables yet? Worth trying at least if you haven't.

adafruit_support_carter
 
Posts: 17135
Joined: Tue Nov 29, 2016 2:45 pm

Re: Flora never connects

by savva on Wed Feb 12, 2020 9:02 pm

just tried all of the above again with different cables/machines (linux/mac/windows) - same errors as before.

savva
 
Posts: 9
Joined: Thu Oct 17, 2019 9:57 pm

Re: Flora never connects

by adafruit_support_carter on Thu Feb 13, 2020 12:04 am

OK, let's try a replacement and see what happens. With the new one, test it with a basic Blink example before connecting anything to the pads. That way you know the basics work before moving on.

Send an email to support@adafruit.com with a link to this thread and your order number and they can send you a replacement Flora.

adafruit_support_carter
 
Posts: 17135
Joined: Tue Nov 29, 2016 2:45 pm

Re: Flora never connects

by savva on Thu Feb 13, 2020 2:04 am

Copy that, will post an update as soon as a new one arrives. Thank you for your help!

savva
 
Posts: 9
Joined: Thu Oct 17, 2019 9:57 pm

Please be positive and constructive with your questions and comments.