Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

Huzzah32 + ArduCam Mini 2MP Plus not working.
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Huzzah32 + ArduCam Mini 2MP Plus not working.

by dgenther on Mon Mar 02, 2020 2:14 am

Hi guys. I'm burnt out on trying to get these two to work together. The ArduCam the Mini 2MP Plus with the OV2640 camera, and I'm trying to interface it with an Adafruit "Huzzah" ESP32 standalone unit (one of these https://www.adafruit.com/product/3619 ).

I haven't been able to find any libraries for use specifically with esp32, but I have found some example sketches for things like the esp8266, which as far as I understand is very similar if not almost identical in terms of GPIO and functionality. Of course, I mainly just match up the pins on the ArduCam Mini 2MP with their respective labeled ports on the Huzzah32. The only one that doesn't have a specific label is the Chip Select pin, CS. I've put that on pin 16 for now.

I've tried multiple example sketches from the ArduCAM libraries with the labels of ArduCAM_Mini_2MP_Plus_*, and of ArduCAM_ESP8266_OV2640.

The farthest I've gotten was while using ArduCAM_Mini_2MP_Plus_VideoStreaming, it would compile but give me an SPI Interface Error. I'm not sure if anyone has any experience with this, but I can't seem to get these two devices to work together.

dgenther
 
Posts: 1
Joined: Tue Oct 08, 2019 9:26 pm

Please be positive and constructive with your questions and comments.