Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

How do I isolate a soldering wiring issue
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

How do I isolate a soldering wiring issue

by cr2n on Sun Mar 22, 2020 1:07 am

I am making an audio recording device using Arduino Pro mini, Adafruit micro lipo charger, MicroSD Breakout+ , a button to start the recording and an electet microphone. I assembled and soldered the entire project and it seemed to work perfectly until I decided to solder on a reset button.

The previous behaviour after turning on the power button was the red onboard LED (near the FTDI header) would turn on, the board would boot up and the SD card led would turn on while the software checked for acard.

After I soldered the reset button on, nothing happens when I turn on the power, except the recording button LED lights up (LED and button on pins 2 and 6 are Adafruit button product id 3105. Then, if I press the button connected to pin 2, the Mini turns on and boots etc.

I have done some basic troubleshooting checking my soldering, re-doing some of the soldering, ensuring rows on the protoboard are not soldered together. I have looked for any wires touching each other perhaps missing some insulation but found none. Below I have taken some readings with a multimeter but I could use some guidance interpreting what I found or suggesting where else to take readings.

Here is the schematic of my project and then a photo so you get an idea of the general layout of components on the proto board. The SD card reader is installed under the board:
AudioRecorder.png
AudioRecorder.png (40.33 KiB) Viewed 50 times

proto-board.jpg
proto-board.jpg (364.55 KiB) Viewed 50 times

And here is the schematic image with testing points in yellow indicating where I tested for either continuity or voltage.
AudioRecorder-tests.png
AudioRecorder-tests.png (44.15 KiB) Viewed 50 times

With multi-meter on voltage setting and power button (SPST bottom right) turned on, across points 1::2 I read 3.45v. When I turn off the power and test same points 1::2 I detect a decreasing voltage beginning at 0.5v dropping steadily. My guess is this is the capacitor discharging. I don't know if this is a problem or not.

Additional Readings with power button on:
    point 1 :: point 6 = 3.45v
    points 3::6 = 3.45v
    points 5::6 = 3.36v
    points 8::6 = 3.36v
    points 11::7 = 2.2v
    points 10::7 = 1.9v
    points 10::9 = 0.2v

And finally, when I change the multi-meter to continuity testing, I do not hear a sound when testing between points 4::6 (reset button) until I press the reset button.

Thank you in advance for any suggestions.

cr2n
 
Posts: 22
Joined: Mon Mar 31, 2014 9:41 pm

Re: How do I isolate a soldering wiring issue

by adafruit_support_bill on Sun Mar 22, 2020 7:24 am

Debugging circuits can be tricky. One thing to try is to undo the last change you made before it 'broke' to see if it returns to normal operation.

Another possibility is that you had one or more marginal solder joints that worked for a while, then failed. This guide has some tips on identifying and fixing some common soldering problems: https://learn.adafruit.com/adafruit-gui ... n-problems

In general, using a multimeter to check the continuity of solder joints can be misleading, since poking a marginal solder joint with the meter probe just tends to make it more conductive.

adafruit_support_bill
 
Posts: 78635
Joined: Sat Feb 07, 2009 10:11 am

Please be positive and constructive with your questions and comments.