0

Programmer Not Responding Error- Metro Mini
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Programmer Not Responding Error- Metro Mini

by Ardyjo on Sun Dec 06, 2020 3:46 pm

Was trying to upload new code to Adafruit Metro Mini 328 - Arduino-Compatible - 5V 16MHz and keep getting programmer not responding error.
It was connected on COM 3 but now only COM 1 is available.

Code: Select all | TOGGLE FULL SIZE
Arduino: 1.8.13 (Windows 10), Board: "Arduino Uno"

C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\ollyl\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\ollyl\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\ollyl\Documents\Arduino\libraries -fqbn=arduino:avr:uno -vid-pid=0000_0000 -ide-version=10813 -build-path C:\Users\ollyl\AppData\Local\Temp\arduino_build_284168 -warnings=none -build-cache C:\Users\ollyl\AppData\Local\Temp\arduino_cache_175794 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arduinoOTA.path=C:\Users\ollyl\AppData\Local\Arduino15\packages\arduino\tools\arduinoOTA\1.3.0 -prefs=runtime.tools.arduinoOTA-1.3.0.path=C:\Users\ollyl\AppData\Local\Arduino15\packages\arduino\tools\arduinoOTA\1.3.0 -prefs=runtime.tools.avrdude.path=C:\Users\ollyl\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17 -prefs=runtime.tools.avrdude-6.3.0-arduino17.path=C:\Users\ollyl\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17 -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc-7.3.0-atmel3.6.1-arduino7.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose C:\Users\ollyl\Documents\Arduino\NEOPIXEL2\NEOPIXEL2.ino

C:\Program Files (x86)\Arduino\arduino-builder -compile -logger=machine -hardware C:\Program Files (x86)\Arduino\hardware -hardware C:\Users\ollyl\AppData\Local\Arduino15\packages -tools C:\Program Files (x86)\Arduino\tools-builder -tools C:\Program Files (x86)\Arduino\hardware\tools\avr -tools C:\Users\ollyl\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files (x86)\Arduino\libraries -libraries C:\Users\ollyl\Documents\Arduino\libraries -fqbn=arduino:avr:uno -vid-pid=0000_0000 -ide-version=10813 -build-path C:\Users\ollyl\AppData\Local\Temp\arduino_build_284168 -warnings=none -build-cache C:\Users\ollyl\AppData\Local\Temp\arduino_cache_175794 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arduinoOTA.path=C:\Users\ollyl\AppData\Local\Arduino15\packages\arduino\tools\arduinoOTA\1.3.0 -prefs=runtime.tools.arduinoOTA-1.3.0.path=C:\Users\ollyl\AppData\Local\Arduino15\packages\arduino\tools\arduinoOTA\1.3.0 -prefs=runtime.tools.avrdude.path=C:\Users\ollyl\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17 -prefs=runtime.tools.avrdude-6.3.0-arduino17.path=C:\Users\ollyl\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17 -prefs=runtime.tools.avr-gcc.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -prefs=runtime.tools.avr-gcc-7.3.0-atmel3.6.1-arduino7.path=C:\Program Files (x86)\Arduino\hardware\tools\avr -verbose C:\Users\ollyl\Documents\Arduino\NEOPIXEL2\NEOPIXEL2.ino

Using board 'uno' from platform in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr

Using core 'arduino' from platform in folder: C:\Program Files (x86)\Arduino\hardware\arduino\avr

Detecting libraries used...

"C:\\Program Files (x86)\\Arduino\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10813 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\cores\\arduino" "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\variants\\standard" "C:\\Users\\ollyl\\AppData\\Local\\Temp\\arduino_build_284168\\sketch\\NEOPIXEL2.ino.cpp" -o nul -DARDUINO_LIB_DISCOVERY_PHASE

Alternatives for Adafruit_NeoPixel.h: [Adafruit_NeoPixel@1.7.0 BD1-Rear-Panel-Display-master]

ResolveLibrary(Adafruit_NeoPixel.h)

  -> candidates: [Adafruit_NeoPixel@1.7.0 BD1-Rear-Panel-Display-master]

"C:\\Program Files (x86)\\Arduino\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10813 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\cores\\arduino" "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\variants\\standard" "-IC:\\Users\\ollyl\\Documents\\Arduino\\libraries\\Adafruit_NeoPixel" "C:\\Users\\ollyl\\AppData\\Local\\Temp\\arduino_build_284168\\sketch\\NEOPIXEL2.ino.cpp" -o nul -DARDUINO_LIB_DISCOVERY_PHASE

Using cached library dependencies for file: C:\Users\ollyl\Documents\Arduino\libraries\Adafruit_NeoPixel\Adafruit_NeoPixel.cpp

Using cached library dependencies for file: C:\Users\ollyl\Documents\Arduino\libraries\Adafruit_NeoPixel\esp.c

Using cached library dependencies for file: C:\Users\ollyl\Documents\Arduino\libraries\Adafruit_NeoPixel\esp8266.c

Using cached library dependencies for file: C:\Users\ollyl\Documents\Arduino\libraries\Adafruit_NeoPixel\kendyte_k210.c

Generating function prototypes...

"C:\\Program Files (x86)\\Arduino\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -flto -w -x c++ -E -CC -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10813 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\cores\\arduino" "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\variants\\standard" "-IC:\\Users\\ollyl\\Documents\\Arduino\\libraries\\Adafruit_NeoPixel" "C:\\Users\\ollyl\\AppData\\Local\\Temp\\arduino_build_284168\\sketch\\NEOPIXEL2.ino.cpp" -o "C:\\Users\\ollyl\\AppData\\Local\\Temp\\arduino_build_284168\\preproc\\ctags_target_for_gcc_minus_e.cpp" -DARDUINO_LIB_DISCOVERY_PHASE

"C:\\Program Files (x86)\\Arduino\\tools-builder\\ctags\\5.8-arduino11/ctags" -u --language-force=c++ -f - --c++-kinds=svpf --fields=KSTtzns --line-directives "C:\\Users\\ollyl\\AppData\\Local\\Temp\\arduino_build_284168\\preproc\\ctags_target_for_gcc_minus_e.cpp"

Compiling sketch...

"C:\\Program Files (x86)\\Arduino\\hardware\\tools\\avr/bin/avr-g++" -c -g -Os -w -std=gnu++11 -fpermissive -fno-exceptions -ffunction-sections -fdata-sections -fno-threadsafe-statics -Wno-error=narrowing -MMD -flto -mmcu=atmega328p -DF_CPU=16000000L -DARDUINO=10813 -DARDUINO_AVR_UNO -DARDUINO_ARCH_AVR "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\cores\\arduino" "-IC:\\Program Files (x86)\\Arduino\\hardware\\arduino\\avr\\variants\\standard" "-IC:\\Users\\ollyl\\Documents\\Arduino\\libraries\\Adafruit_NeoPixel" "C:\\Users\\ollyl\\AppData\\Local\\Temp\\arduino_build_284168\\sketch\\NEOPIXEL2.ino.cpp" -o "C:\\Users\\ollyl\\AppData\\Local\\Temp\\arduino_build_284168\\sketch\\NEOPIXEL2.ino.cpp.o"

Compiling libraries...

Compiling library "Adafruit_NeoPixel"

Using previously compiled file: C:\Users\ollyl\AppData\Local\Temp\arduino_build_284168\libraries\Adafruit_NeoPixel\esp.c.o

Using previously compiled file: C:\Users\ollyl\AppData\Local\Temp\arduino_build_284168\libraries\Adafruit_NeoPixel\esp8266.c.o

Using previously compiled file: C:\Users\ollyl\AppData\Local\Temp\arduino_build_284168\libraries\Adafruit_NeoPixel\kendyte_k210.c.o

Using previously compiled file: C:\Users\ollyl\AppData\Local\Temp\arduino_build_284168\libraries\Adafruit_NeoPixel\Adafruit_NeoPixel.cpp.o

Compiling core...

Using precompiled core: C:\Users\ollyl\AppData\Local\Temp\arduino_cache_175794\core\core_arduino_avr_uno_0c812875ac70eb4a9b385d8fb077f54c.a

Linking everything together...

"C:\\Program Files (x86)\\Arduino\\hardware\\tools\\avr/bin/avr-gcc" -w -Os -g -flto -fuse-linker-plugin -Wl,--gc-sections -mmcu=atmega328p -o "C:\\Users\\ollyl\\AppData\\Local\\Temp\\arduino_build_284168/NEOPIXEL2.ino.elf" "C:\\Users\\ollyl\\AppData\\Local\\Temp\\arduino_build_284168\\sketch\\NEOPIXEL2.ino.cpp.o" "C:\\Users\\ollyl\\AppData\\Local\\Temp\\arduino_build_284168\\libraries\\Adafruit_NeoPixel\\esp.c.o" "C:\\Users\\ollyl\\AppData\\Local\\Temp\\arduino_build_284168\\libraries\\Adafruit_NeoPixel\\esp8266.c.o" "C:\\Users\\ollyl\\AppData\\Local\\Temp\\arduino_build_284168\\libraries\\Adafruit_NeoPixel\\kendyte_k210.c.o" "C:\\Users\\ollyl\\AppData\\Local\\Temp\\arduino_build_284168\\libraries\\Adafruit_NeoPixel\\Adafruit_NeoPixel.cpp.o" "C:\\Users\\ollyl\\AppData\\Local\\Temp\\arduino_build_284168/..\\arduino_cache_175794\\core\\core_arduino_avr_uno_0c812875ac70eb4a9b385d8fb077f54c.a" "-LC:\\Users\\ollyl\\AppData\\Local\\Temp\\arduino_build_284168" -lm

"C:\\Program Files (x86)\\Arduino\\hardware\\tools\\avr/bin/avr-objcopy" -O ihex -j .eeprom --set-section-flags=.eeprom=alloc,load --no-change-warnings --change-section-lma .eeprom=0 "C:\\Users\\ollyl\\AppData\\Local\\Temp\\arduino_build_284168/NEOPIXEL2.ino.elf" "C:\\Users\\ollyl\\AppData\\Local\\Temp\\arduino_build_284168/NEOPIXEL2.ino.eep"

"C:\\Program Files (x86)\\Arduino\\hardware\\tools\\avr/bin/avr-objcopy" -O ihex -R .eeprom "C:\\Users\\ollyl\\AppData\\Local\\Temp\\arduino_build_284168/NEOPIXEL2.ino.elf" "C:\\Users\\ollyl\\AppData\\Local\\Temp\\arduino_build_284168/NEOPIXEL2.ino.hex"

Multiple libraries were found for "Adafruit_NeoPixel.h"

 Used: C:\Users\ollyl\Documents\Arduino\libraries\Adafruit_NeoPixel

 Not used: C:\Users\ollyl\Documents\Arduino\libraries\BD1-Rear-Panel-Display-master

Using library Adafruit_NeoPixel at version 1.7.0 in folder: C:\Users\ollyl\Documents\Arduino\libraries\Adafruit_NeoPixel

"C:\\Program Files (x86)\\Arduino\\hardware\\tools\\avr/bin/avr-size" -A "C:\\Users\\ollyl\\AppData\\Local\\Temp\\arduino_build_284168/NEOPIXEL2.ino.elf"

Sketch uses 2538 bytes (7%) of program storage space. Maximum is 32256 bytes.

Global variables use 41 bytes (2%) of dynamic memory, leaving 2007 bytes for local variables. Maximum is 2048 bytes.

C:\Users\ollyl\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/bin/avrdude -CC:\Users\ollyl\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/etc/avrdude.conf -v -patmega328p -carduino -PCOM1 -b115200 -D -Uflash:w:C:\Users\ollyl\AppData\Local\Temp\arduino_build_284168/NEOPIXEL2.ino.hex:i



avrdude: Version 6.3-20190619

         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

         Copyright (c) 2007-2014 Joerg Wunsch



         System wide configuration file is "C:\Users\ollyl\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino17/etc/avrdude.conf"



         Using Port                    : COM1

         Using Programmer              : arduino

         Overriding Baud Rate          : 115200

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xb4

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xb4

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0xb4

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xb4

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0xb4

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xb4

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xb4

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xb4

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xb4

avrdude: stk500_recv(): programmer is not responding

avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xb4



avrdude done.  Thank you.



Problem uploading to board.  See http://www.arduino.cc/en/Guide/Troubleshooting#upload for suggestions.

Ardyjo
 
Posts: 9
Joined: Wed Feb 07, 2018 1:06 pm

Re: Programmer Not Responding Error- Metro Mini

by adafruit_support_carter on Mon Dec 07, 2020 8:12 pm


adafruit_support_carter
 
Posts: 18895
Joined: Tue Nov 29, 2016 2:45 pm

Re: Programmer Not Responding Error- Metro Mini

by Ardyjo on Wed Dec 09, 2020 12:17 am

Yes nothing has changed since I loaded code s few days ago. the board has a solid green light.
I did plug in try a brand new Metro Mini and the computer recognizes it and it now appears as COM 4 in the Arduino IDE. Is there something wrong with the other one?

adafruit_support_carter wrote:Did you install the drivers?
https://learn.adafruit.com/adafruit-met ... -ide-usage

Ardyjo
 
Posts: 9
Joined: Wed Feb 07, 2018 1:06 pm

Re: Programmer Not Responding Error- Metro Mini

by adafruit_support_carter on Wed Dec 09, 2020 1:49 pm

Sounds like it was originally working. Have you attached anything to the Metro Mini's pins? How has it been used between the time it was working to the time it stopped working?

adafruit_support_carter
 
Posts: 18895
Joined: Tue Nov 29, 2016 2:45 pm

Re: Programmer Not Responding Error- Metro Mini

by Ardyjo on Wed Dec 09, 2020 9:44 pm

Yes, I have been testing 8 NeoPixel RGBW LEDs w/ Integrated Driver Chips on 5050 Breakout PCBs & powered via USB. Only 6 of 8 LEDs would work and I have been trying different codes to get it to work. This last time I plugged it into the computer I ran into this issue.

adafruit_support_carter wrote:Sounds like it was originally working. Have you attached anything to the Metro Mini's pins? How has it been used between the time it was working to the time it stopped working?

Ardyjo
 
Posts: 9
Joined: Wed Feb 07, 2018 1:06 pm

Re: Programmer Not Responding Error- Metro Mini

by adafruit_support_carter on Thu Dec 10, 2020 12:35 pm

OK, let's see what the current state of the hardware looks like. It may be related to the attachment of the NeoPixels. Please post a photo of your setup showing how everything is connected.

adafruit_support_carter
 
Posts: 18895
Joined: Tue Nov 29, 2016 2:45 pm

Re: Programmer Not Responding Error- Metro Mini

by Ardyjo on Fri Dec 11, 2020 1:13 pm

This is primarily how I had it hooked up before it stopped connecting to the computer.

20201210_162005.jpg
20201210_162005.jpg (352.53 KiB) Viewed 152 times

20201210_162015.jpg
20201210_162015.jpg (236.34 KiB) Viewed 152 times

Ardyjo
 
Posts: 9
Joined: Wed Feb 07, 2018 1:06 pm

Re: Programmer Not Responding Error- Metro Mini

by adafruit_support_carter on Mon Dec 14, 2020 12:32 pm

Thanks. That looks generally OK. There's a chance it may be related to the attached hardware. Maybe something got shorted, etc.

Double check you USB cable is good. The disconnect all the NeoPixel connection and try just uploading a basic blink (for on board LED) example.

adafruit_support_carter
 
Posts: 18895
Joined: Tue Nov 29, 2016 2:45 pm

Re: Programmer Not Responding Error- Metro Mini

by Ardyjo on Mon Dec 14, 2020 9:33 pm

Yea I have tried different cords and a different computer. Still doesn't recognize the board to upload anything.

adafruit_support_carter wrote:Thanks. That looks generally OK. There's a chance it may be related to the attached hardware. Maybe something got shorted, etc.

Double check you USB cable is good. The disconnect all the NeoPixel connection and try just uploading a basic blink (for on board LED) example.

Ardyjo
 
Posts: 9
Joined: Wed Feb 07, 2018 1:06 pm

Re: Programmer Not Responding Error- Metro Mini

by adafruit2 on Wed Dec 16, 2020 1:03 am

if you don't even see a COM port appear when you plug it in, its fried compeltely and can't be repaired.
if you see a COM port, does the red LED blink a few times after pressing reset?

adafruit2
Site Admin
 
Posts: 19757
Joined: Fri Mar 11, 2005 7:36 pm

Re: Programmer Not Responding Error- Metro Mini

by Ardyjo on Thu Dec 17, 2020 9:15 pm

Bummer. I don't know why it would be fried, I have only connected to 5v & the new board works fine using the same setup.
Only a green light comes on when connecting to computer with only the default COM1 port available but no additional indicating the board is connected. Any attempt to load code results in the programmer not responding error. No chance of getting a replacement then ?

adafruit2 wrote:if you don't even see a COM port appear when you plug it in, its fried completely and can't be repaired.
if you see a COM port, does the red LED blink a few times after pressing reset?

Ardyjo
 
Posts: 9
Joined: Wed Feb 07, 2018 1:06 pm

Re: Programmer Not Responding Error- Metro Mini

by adafruit2 on Fri Dec 18, 2020 1:50 pm

if no COM port appears, yeah it was somehow damaged to the point you will not be able to get it working. it happens sometimes with exposed pins on electronics, no biggie :)

adafruit2
Site Admin
 
Posts: 19757
Joined: Fri Mar 11, 2005 7:36 pm

Please be positive and constructive with your questions and comments.