Due to high demand expect some shipping delays at this time, orders may not ship for 1-2 business days.
0

Seesaw soil sensor not measuring capacitance; only temperatu
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Seesaw soil sensor not measuring capacitance; only temperatu

by Rayben on Mon Apr 12, 2021 11:48 pm

This is super odd and I'm hoping it's not a fault with the device. I'm using the Seesaw 12C soil sensor which measures temperature and capacitance, but the capacitance reading is coming back as the same number as the temperature, in fact it's reading it as if it is the temperature sensor. Almost as if there are two temperature sensors on the device instead of a capacitance sensor.

The device is attached to an Arduino Uno R3, green to A5, white to A4, red to 5V and black to GND. The code I'm using is the example code library. Everything uploads correctly without errors (Although sometimes I have been getting an error with the COM4 port I'm using) and everything runs correctly except that it's not showing me the capacitance number, it displays Temperature: 29.40 C, Capacitive: 29 as an example. I increased the delay quite a bit to get slower readings but otherwise changed nothing.

ETA: I'd like to add that downgrading the version of the Seesaw library from 1.4 to 1.3.1 seems to have fixed the problem entirely. The problem seems to be with the library.

Rayben
 
Posts: 1
Joined: Mon Apr 12, 2021 11:42 pm

Re: Seesaw soil sensor not measuring capacitance; only tempe

by mikeysklar on Wed Apr 14, 2021 5:43 pm

@Rayben,

Yeah, the library just got a redo in the last 10 days which broke some things. You can add a note to the Issues page for the repository. There is another case open which is related, but a little different than yours.

https://github.com/adafruit/Adafruit_Seesaw/issues

mikeysklar
 
Posts: 4151
Joined: Mon Aug 01, 2016 8:10 pm

Please be positive and constructive with your questions and comments.