0

Gemma M0 not visible
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Gemma M0 not visible

by cgfb on Mon Jun 21, 2021 6:00 am

Hi,

I'm having trouble getting the Gemma M0 to show on a COM port on my windows 10 machine.

There is no problem when I plug in my Nano IoT, that is visible straight away. When I plug in the Gemma, windows recognises a device being plugged in (connection sound) and the device manager refreshes. I'm running Windows Defender, no other anti-virus / firewall.
The device flashes red with solid green when plugged in/reset, before the red turns off, leaving only solid green.
No USB storage device is visible in the file explorer.

These are the configurations I'm using:
Screenshot 2021-06-21 115417.png
Screenshot 2021-06-21 115417.png (42.83 KiB) Viewed 108 times


Any help/advice would be greatly appreciated :)

cgfb
 
Posts: 2
Joined: Mon Jun 21, 2021 5:48 am

Re: Gemma M0 not visible

by adafruit_support_carter on Tue Jun 22, 2021 12:57 pm

The green LED indicates things are working from the Gemma M0's point of view. See here for other reasons why the BOOT folder may not show up:
https://learn.adafruit.com/welcome-to-c ... leshooting

adafruit_support_carter
 
Posts: 20565
Joined: Tue Nov 29, 2016 2:45 pm

Re: Gemma M0 not visible

by cgfb on Sat Jul 24, 2021 8:32 am

Thanks for the reply.
I've gone through the troubleshooting, but still no dice.

I've gone as far as reinstalling windows 10.
The device drivers could not be found when I plugged it in. Therefore, I installed the drivers from the guide.
My computer now recognises tinyUSB as a device when it is plugged in (tried a different USB port). However, no drive is visible in my explorer.

Thanks again

cgfb
 
Posts: 2
Joined: Mon Jun 21, 2021 5:48 am

Re: Gemma M0 not visible

by adafruit_support_carter on Mon Jul 26, 2021 12:04 pm

You don't need drivers for Win 10. And installing them may cause issues. It's one of the scenarios covered on page linked above. Try uninstalling them:
Windows 10

Did you install the Adafruit Windows Drivers package by mistake, or did you upgrade to Windows 10 with the driver package installed? You don't need to install this package on Windows 10 for most Adafruit boards. The old version (v1.5) can interfere with recognizing your device. Go to Settings -> Apps and uninstall all the "Adafruit" driver programs.

adafruit_support_carter
 
Posts: 20565
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.