📬❄️📦Adafruit Holiday Shipping Deadlines 2019: Please place all UPS 3 Day orders by 11am ET Friday December 13 📬❄️📦
0

Issue installing drivers for Arduino Leonardo
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Re: Issue installing drivers for Arduino Leonardo

by adafruit on Wed Jun 27, 2012 1:23 pm

Please let us know if the replacement works - we havent seen this problem before so it would be good to know if it is a leo problem or a computer problem!

adafruit
 
Posts: 12151
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Re: Issue installing drivers for Arduino Leonardo

by AZNGear on Fri Aug 24, 2012 10:35 pm

I was having this exact issue. It seems that my Leonardo doesn't like two of the three USB ports on my notebook computer. I think this is related to USB 3.0 but I can't confirm.

AZNGear
 
Posts: 1
Joined: Fri Aug 24, 2012 10:30 pm

Re: Issue installing drivers for Arduino Leonardo

by hgmjr on Sat Sep 15, 2012 2:07 pm

diamus wrote:I was having this exact issue. It seems that my Leonardo doesn't like two of the three USB ports on my notebook computer. I think this is related to USB 3.0 but I can't confirm.

I too struggled with getting my laptop to load the Arduino Leonardo USB driver. After working for some time with my dell laptop running Wndows 7, I moved the cable to another USB port. The Arduino Leonardo loaded smooth as silk. I decided to look more closely at the port connection on the laptop. To my surprise I noticed that the USB symbol had a tiny "+" symbol in the upper right portion of the logo while the ports that I had been having trouble getting to work with the Leonardo did not have this "+" symbol. I then went to another laptop I have that is running Windows XP. Once again, I noticed that one of the USB ports had a "+" symbol on it. I plugged my Leonardo into this USB port on my XP laptop and it loaded up smooth as silk once again. I decided to retry the Leonardo in one of the USB ports without the "+" symbol and it still refused to be recognized by the laptop. The conclusion I drew was that whatever feature or features are associated with ports that have this "+" symbol make them more compatible with the Arduino Leonardo.

hgmjr
hgmjr
 
Posts: 1
Joined: Sat Sep 15, 2012 1:11 pm

Re: Issue installing drivers for Arduino Leonardo

by dkinfo on Mon Jan 28, 2013 10:43 am

Thanks for the insight, I had the same problem on my workstation class PC. I could not get Windows 7, 64 to recognize the device, no matter how I "held its hand" during installation. I switched the physical port and "voila!" It worked a treat.

Thanks for the post!

David W,
Melbourne, Florida.

dkinfo
 
Posts: 2
Joined: Sat Sep 08, 2012 5:20 pm

Re: Issue installing drivers for Arduino Leonardo

by Syn7 on Mon Jan 28, 2013 7:44 pm

Unfortunately I have no + near any of my ports. Anyone know what the + means?
Syn7
 
Posts: 152
Joined: Sat Nov 17, 2012 3:06 am

Please be positive and constructive with your questions and comments.