Due to high demand expect some shipping delays at this time, orders may not ship for 1-2 business days.
0

BME680 breakout board not working
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

BME680 breakout board not working

by akmishra_99 on Wed Oct 20, 2021 9:01 am

I bought two BME680 breakout board (PRODUCT ID: 3660) from Adafruit, one of them works and other one does not work, it keeps telling me that no valid BME680 found("Could not find a valid BME680 sensor, check wiring!") , can I get replacement for not working BME680 breakout

-Thanks
-Alok

akmishra_99
 
Posts: 64
Joined: Thu Nov 27, 2014 8:59 pm

Re: BME680 breakout board not working

by dastels on Wed Oct 20, 2021 9:49 am

Have you done an I2C scan (https://learn.adafruit.com/scanning-i2c-addresses) to see it it's even being seen? And can you post a clear photo of the wiring/connections to the sensor?

Dave

dastels
 
Posts: 7969
Joined: Tue Oct 20, 2015 3:22 pm

Re: BME680 breakout board not working

by akmishra_99 on Thu Oct 21, 2021 9:53 am

Hello,

I connected scl and sda line and it was displaying temperature and humidity and barometric pressure for some time then it stopped working , now it does not work at all, I double checked wiring and there is no change, since it worked for some time, I think i2c address is fine, this item seems to be very flaky, second one which I bought works fine.

-Thanks
-Alok

akmishra_99
 
Posts: 64
Joined: Thu Nov 27, 2014 8:59 pm

Re: BME680 breakout board not working

by dastels on Thu Oct 21, 2021 11:03 am

Could I see a photo of your connections to the board, please?

Dave

dastels
 
Posts: 7969
Joined: Tue Oct 20, 2015 3:22 pm

Re: BME680 breakout board not working

by akmishra_99 on Thu Oct 21, 2021 1:23 pm

IMG_0997_1MB.jpg
IMG_0997_1MB.jpg (976.6 KiB) Viewed 261 times
Here it is

akmishra_99
 
Posts: 64
Joined: Thu Nov 27, 2014 8:59 pm

Re: BME680 breakout board not working

by dastels on Thu Oct 21, 2021 2:03 pm

Have you checked the header soldering for shorts?

Dave

dastels
 
Posts: 7969
Joined: Tue Oct 20, 2015 3:22 pm

Re: BME680 breakout board not working

by akmishra_99 on Thu Oct 21, 2021 2:30 pm

Hello,

I am using stemma qt cable,Please see picture

-Thanks
-Alok

akmishra_99
 
Posts: 64
Joined: Thu Nov 27, 2014 8:59 pm

Re: BME680 breakout board not working

by dastels on Thu Oct 21, 2021 6:31 pm

Yes, but it looks like you also have header installed. They I2C connections are the same so if the soldering is botched, the STEMMA-QT connection may not work.

Dave

dastels
 
Posts: 7969
Joined: Tue Oct 20, 2015 3:22 pm

Re: BME680 breakout board not working

by akmishra_99 on Thu Oct 21, 2021 8:01 pm

IMG_6850_950KB.jpg
IMG_6850_950KB.jpg (902.64 KiB) Viewed 250 times
here are two pictures of close up of soldered pins


second picture

IMG_9416_913KB.jpg
IMG_9416_913KB.jpg (894.97 KiB) Viewed 250 times

akmishra_99
 
Posts: 64
Joined: Thu Nov 27, 2014 8:59 pm

Re: BME680 breakout board not working

by dastels on Thu Oct 21, 2021 8:17 pm

Awesome, thanks.

I don't see any shots between pins, though you seems to have an extra and the second from the bottom doesn't look very well done. It does look like the address jumper has some solder on it. which might be shorting it. If so, the sensor will show up on 0x76. Is it possible that something conductive got picked up by the board? It's odd for it to stop working without a reason.

Dave

dastels
 
Posts: 7969
Joined: Tue Oct 20, 2015 3:22 pm

Re: BME680 breakout board not working

by akmishra_99 on Thu Oct 21, 2021 10:35 pm

ok,

it is stray solder which was creating problem, I ran i2c scanner and it reported address to be 0x76, looks like address jumper was getting shorted, so I modified bme680 sketch/program to use i2c address 0x76 and it started working, then I cleaned up stray solder and used original bme680 sketch/program ( which uses i2c address 0x77) and now it works, I am going to run it for 48 hours to make sure that there is no problem with bme680 break out board.

thanks Dave for helping me in debugging it

-Thanks
-Alok

akmishra_99
 
Posts: 64
Joined: Thu Nov 27, 2014 8:59 pm

Re: BME680 breakout board not working

by dastels on Fri Oct 22, 2021 8:51 am

Awesome! I'm glad it was something that simple.

Dave

dastels
 
Posts: 7969
Joined: Tue Oct 20, 2015 3:22 pm

Please be positive and constructive with your questions and comments.