0

Particle Web IDE BME680 missing library
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Particle Web IDE BME680 missing library

by ITAlexR on Sun Jan 27, 2019 5:41 pm

Particle Web IDE the BME680 library is missing, it was available a couple days ago. Any idea?

ITAlexR
 
Posts: 16
Joined: Tue Jan 01, 2019 10:55 pm

Re: Particle Web IDE BME680 missing library

by franklin97355 on Sun Jan 27, 2019 6:31 pm

Which shield are you using and have you asked on the Particle site?

franklin97355
 
Posts: 20103
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: Particle Web IDE BME680 missing library

by ITAlexR on Sun Jan 27, 2019 9:04 pm

franklin97355 wrote:Which shield are you using and have you asked on the Particle site?


Yes, I asked the Particle site, someone is investigating. I am using a board from ncd.io designed for the Photon. The library was working fine a couple days ago. I just compiled the BME680 example, and this is I get now. Another screenshot shows that the library is listed but its contents is zero(0).
Attachments
BME680.PNG
BME680.PNG (42.68 KiB) Viewed 98 times
BME Error.PNG
BME Error.PNG (116.06 KiB) Viewed 98 times

ITAlexR
 
Posts: 16
Joined: Tue Jan 01, 2019 10:55 pm

Re: Particle Web IDE BME680 missing library

by franklin97355 on Sun Jan 27, 2019 10:33 pm

Have you tried to download it again? If there is nothing in it the download failed.

franklin97355
 
Posts: 20103
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: Particle Web IDE BME680 missing library

by ITAlexR on Sun Jan 27, 2019 11:52 pm

Still having same result.

ITAlexR
 
Posts: 16
Joined: Tue Jan 01, 2019 10:55 pm

Re: Particle Web IDE BME680 missing library

by franklin97355 on Mon Jan 28, 2019 12:22 am

Does your library folder still have nothing in it? The GitHub folder has many files.

franklin97355
 
Posts: 20103
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: Particle Web IDE BME680 missing library

by ITAlexR on Mon Jan 28, 2019 12:47 am

franklin97355 wrote:Does your library folder still have nothing in it? The GitHub folder has many files.

I am using the Particle Web IDE, and the libraries are own by whoever develop them, in this case Adafruit, I think. I know the github has all kind of files. I wish I can switch to the Arduino IDE, but the this IDE will not recognize the Photon.

ITAlexR
 
Posts: 16
Joined: Tue Jan 01, 2019 10:55 pm

Re: Particle Web IDE BME680 missing library

by franklin97355 on Mon Jan 28, 2019 12:55 am

Sorry, I don't know anything about that program. I'll see if someone else knows.

franklin97355
 
Posts: 20103
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: Particle Web IDE BME680 missing library

by ITAlexR on Mon Jan 28, 2019 1:00 am

franklin97355 wrote:Sorry, I don't know anything about that program. I'll see if someone else knows.
No a problem, thank you for your help.

ITAlexR
 
Posts: 16
Joined: Tue Jan 01, 2019 10:55 pm

Re: Particle Web IDE BME680 missing library

by ITAlexR on Mon Jan 28, 2019 2:04 am

I solved by manually adding the libraries. Something is wrong with those Particle Web IDE BME libraries. Hopefully someone will take a look to see what is going on.

ITAlexR
 
Posts: 16
Joined: Tue Jan 01, 2019 10:55 pm

Please be positive and constructive with your questions and comments.