0

Problems Initializing SD Card with Adafruit datalogger shiel
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Problems Initializing SD Card with Adafruit datalogger shiel

by OwenSmith on Fri Feb 01, 2019 7:44 pm

Hi, I am trying to get an 8gb SD Card initialized using an Adafruit datalogger shield (newer version) with the built in "CardInfo" program, but I am having no luck. Whenever I attempt to run the program, I get the following error:
Code: Select all | TOGGLE FULL SIZE
 Initializing SD card...initialization failed. Things to check:
* is a card inserted?
* is your wiring correct?
* did you change the chipSelect pin to match your shield or module?

So far I have tried the following:
-Changing the chipSelect pin to 10
-Downloading and installed the most recent version of the SD Card library
-Replacing all of my components (datalogger shield, Arduino Uno, SD card) with new ones.

I formatted the 8gb SD card through: https://www.sdcard.org/downloads/formatter_4/

I am using an Arduino Uno and Arduino IDE version 1.8.7 for reference.

OwenSmith
 
Posts: 3
Joined: Fri Feb 01, 2019 7:25 pm

Re: Problems Initializing SD Card with Adafruit datalogger s

by adafruit_support_bill on Fri Feb 01, 2019 8:08 pm

Please post some clear photos showing your soldering to the shield.

adafruit_support_bill
 
Posts: 72753
Joined: Sat Feb 07, 2009 10:11 am

Re: Problems Initializing SD Card with Adafruit datalogger s

by OwenSmith on Sat Feb 02, 2019 6:50 pm


OwenSmith
 
Posts: 3
Joined: Fri Feb 01, 2019 7:25 pm

Re: Problems Initializing SD Card with Adafruit datalogger s

by adafruit_support_bill on Sun Feb 03, 2019 7:33 am

Excellent photos. Thanks. I don't see any problems with the assembly.

Is the UNO you are using an R3 or later UNO (Earlier UNO versions lack the SDA and SCL pins next to the AREF pin).

adafruit_support_bill
 
Posts: 72753
Joined: Sat Feb 07, 2009 10:11 am

Re: Problems Initializing SD Card with Adafruit datalogger s

by OwenSmith on Mon Feb 04, 2019 4:26 pm

Hi, sorry for the late response, but yes I am using an Arduino Uno R3 from Sparkfun
https://www.sparkfun.com/products/11021

OwenSmith
 
Posts: 3
Joined: Fri Feb 01, 2019 7:25 pm

Re: Problems Initializing SD Card with Adafruit datalogger s

by adafruit_support_bill on Mon Feb 04, 2019 4:49 pm

In this line of the CardInfo sketch:
Code: Select all | TOGGLE FULL SIZE
if (!card.init(SPI_HALF_SPEED, chipSelect)) {

Try changing SPI_HALF_SPEED to SPI_QUARTER_SPEED

adafruit_support_bill
 
Posts: 72753
Joined: Sat Feb 07, 2009 10:11 am

Please be positive and constructive with your questions and comments.