Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

MAX31865 module not measuring properly
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

MAX31865 module not measuring properly

by angel6700 on Wed Jul 15, 2020 2:59 pm

Hello,

I have recently bought a MAX31865 module (original adafruit), bought from digikey.
I'm trying to use with a miniature PT100 .
I initially connected everything (4-wires)) loaded the example provided in with your library, but after a few readings it starts giving wrong results. Like -200 Ohm resistance (at room temperature).
Now, even the start is wrong. Even connecting a 100 Ohm resistor in place a sensor the behavior is the same.
I double checked the wiring, the sensor wiring and all seems fine. You can see in the pictures:

Any Idea what can be wrong?

Thanks in advance.

resized_IMG_20200715_145259.jpg
resized_IMG_20200715_145259.jpg (96.39 KiB) Viewed 31 times

resized_IMG_20200715_145229.jpg
resized_IMG_20200715_145229.jpg (137.11 KiB) Viewed 31 times

resized_IMG_20200715_181528.jpg
resized_IMG_20200715_181528.jpg (286.22 KiB) Viewed 31 times

angel6700
 
Posts: 2
Joined: Wed Jul 15, 2020 8:41 am

Re: MAX31865 module not measuring properly

by angel6700 on Thu Jul 16, 2020 4:34 am

I forgot to add the output in the serial Monitor:

First, the code (plain example unmodified (only the line concerning the 4-wire connection)

X axis is time in seconds.
Y axis is temperature in Celsius
Max31865_PT100_serial plotter.png
Max31865_PT100_serial plotter.png (37.34 KiB) Viewed 24 times


Thank you.

angel6700
 
Posts: 2
Joined: Wed Jul 15, 2020 8:41 am

Please be positive and constructive with your questions and comments.