Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

Motor Shield v2.3 and Arudion MEGA 2560
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Motor Shield v2.3 and Arudion MEGA 2560

by DavidDog51 on Mon Jul 27, 2020 3:30 pm

I had the shield attached to my MEGA 2560 and operating a stepper motor several months ago. But for some reason, I took them apart and now can't remember how to connect the two boards.

Thanks in advance.

DavidDog51
 
Posts: 5
Joined: Mon Jul 27, 2020 3:23 pm

Re: Motor Shield v2.3 and Arudion MEGA 2560

by adafruit_support_bill on Mon Jul 27, 2020 3:31 pm

The shield just stacks directly on top of the Mega.

adafruit_support_bill
 
Posts: 78736
Joined: Sat Feb 07, 2009 10:11 am

Re: Motor Shield v2.3 and Arudion MEGA 2560

by DavidDog51 on Tue Jul 28, 2020 3:46 pm

That answer doesn't completely clear things up for me.

The shield has a row of pins on each side. One side has a group of 8 pins and a second group of 6 pins. The other side has a group of 10 pins and a second group of 8 pins.

The Mega has connections for those pins on both sides too. One side with 3 sets of 8 receivers and the other side with 2 sets of 8 and 1 set of 10 receivers.

No combination that I've found lets all the pins on the shield find a home on the Mega.

D

DavidDog51
 
Posts: 5
Joined: Mon Jul 27, 2020 3:23 pm

Re: Motor Shield v2.3 and Arudion MEGA 2560

by adafruit_support_bill on Tue Jul 28, 2020 4:43 pm

Just match up the labels on the pins. The shield has pins labeled 0-13 along the top edge. These mate with the pins labeled 0-13 along the top edge of the Mega.

You will see that the 3v, 5v GND and VIN pins - as well as the other labeled pins along the bottom will match up as well.

Image

Image

adafruit_support_bill
 
Posts: 78736
Joined: Sat Feb 07, 2009 10:11 am

Re: Motor Shield v2.3 and Arudion MEGA 2560

by DavidDog51 on Wed Jul 29, 2020 8:34 am

Well.... that was easy. Thanks for the help.

DavidDog51
 
Posts: 5
Joined: Mon Jul 27, 2020 3:23 pm

Re: Motor Shield v2.3 and Arudion MEGA 2560

by DavidDog51 on Sat Aug 01, 2020 3:02 pm

I'm making progress thanks to your help.

I managed to get one stepper motor running using the "Motor Party" sample sketch. But I stopped it by pressing the reset button on the shield and now it acts as if there is no power to the shield as there is no "green LED" as there was before I reset things. I have a 10vdc power supply hooked to the motor power terminals and my voltmeter indicates 9.5v.

I've tried completely powering down and reloading the sketch with no apparent results.

Appreciate some help, again.

D

DavidDog51
 
Posts: 5
Joined: Mon Jul 27, 2020 3:23 pm

Re: Motor Shield v2.3 and Arudion MEGA 2560

by DavidDog51 on Sun Aug 02, 2020 7:22 am

Never mind.

Turned out the power supply adjustment allows it to completely reverse polarity and I had that horked up.

D

DavidDog51
 
Posts: 5
Joined: Mon Jul 27, 2020 3:23 pm

Please be positive and constructive with your questions and comments.