0

Music Maker Shield Stange Issue (Defective?)
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Music Maker Shield Stange Issue (Defective?)

by alexthecat on Sun Mar 14, 2021 10:30 am

I just received my Music Maker Shield in the mail yesterday and I'm having a really strange issue with it. At first, I didn't get any sound out of it at all and the player_simple example sketch would appear to hang right after listing the files on the SD card. Then I discovered that I could get it to play my audio files if I shook the board while it was trying to play, but the sound would cut in and out as I shook it. I also discovered by accident that if I placed my finger on the pads for digital pins 0 through 7 when running the code, it would play the file for around a quarter of a second and then cut out, regardless of whether I was shaking it or not. I have tried three different SD cards and I have also checked/reflowed my solder joints on all of the pins. In addition, the results are exactly the same whether I am using the line output jack or the amplified speaker output and I have tried this with multiple Arduinos. I should also note that I'm using an Arduino Mega, so I bridged the jumpers for MOSI, MISO, and SCK on the shield. In terms of the code that I am using, it's just the player_simple example sketch that comes with the Adafruit VS1053 library. Does anyone have any suggestions? My guess is that the shield itself is defective.

Thanks for the help!
Alex

alexthecat
 
Posts: 2
Joined: Sat Mar 13, 2021 3:19 pm

Re: Music Maker Shield Stange Issue (Defective?)

by adafruit_support_bill on Sun Mar 14, 2021 11:19 am

Please post some photos showing all of your soldering and connections to the shield.

adafruit_support_bill
 
Posts: 81551
Joined: Sat Feb 07, 2009 10:11 am

Re: Music Maker Shield Stange Issue (Defective?)

by alexthecat on Mon Mar 15, 2021 6:14 am

Never mind! I tried uninstalling and reinstalling the library and the Arduino IDE, and somehow that fixed the problem!

alexthecat
 
Posts: 2
Joined: Sat Mar 13, 2021 3:19 pm

Re: Music Maker Shield Stange Issue (Defective?)

by adafruit_support_bill on Mon Mar 15, 2021 6:18 am

Good to hear you have it working. Thanks for the update.

adafruit_support_bill
 
Posts: 81551
Joined: Sat Feb 07, 2009 10:11 am

Please be positive and constructive with your questions and comments.