Please note: Friday June 18 is a holiday celebrating Juneteenth, please allow extra time for your order to arrive and plan accordingly.
0

MotorShield Failure
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

MotorShield Failure

by Sportsfan927 on Tue Mar 30, 2021 7:45 pm

I have a motor shield connected to an Uno PCB that I purchased in February. I when I installed it this past weekend, and tried to upload a sketch, none of the three DC motors connected moved. This makes me think I received the PCB as defective. How do I go about getting a replacement?

Thank you!

Chris

Sportsfan927
 
Posts: 5
Joined: Tue Mar 30, 2021 7:35 pm

Re: MotorShield Failure

by adafruit_support_bill on Tue Mar 30, 2021 8:07 pm

Please post photos showing your soldering and connections to the shield.

Also please post specs for the motors and power supply you are using.

adafruit_support_bill
 
Posts: 81308
Joined: Sat Feb 07, 2009 10:11 am

Re: MotorShield Failure

by Sportsfan927 on Wed Mar 31, 2021 1:06 am

Below are photos of the soldering and the connections in the power blocks. The power supply connected to the shield is a 12v 3a plug-in wall adapter. The rumble motors I am wanting to drive are the same as those found in a PlayStation controller. Please let me know if I can provide any additional info.

Thank you!

Chris

IMG_4866_edit.jpg
IMG_4866_edit.jpg (145.56 KiB) Viewed 259 times

IMG_4861_edit.jpg
IMG_4861_edit.jpg (123.28 KiB) Viewed 259 times

IMG_4865_edit.jpg
IMG_4865_edit.jpg (111.05 KiB) Viewed 259 times

Sportsfan927
 
Posts: 5
Joined: Tue Mar 30, 2021 7:35 pm

Re: MotorShield Failure

by adafruit_support_bill on Wed Mar 31, 2021 6:57 am

The power LED is not lit. Check the polarity of your power supply. The black wire is usually the ground wire and you have the black wire connected to the '+' terminal.

Is there a part number for those motors?

adafruit_support_bill
 
Posts: 81308
Joined: Sat Feb 07, 2009 10:11 am

Re: MotorShield Failure

by Sportsfan927 on Wed Mar 31, 2021 1:20 pm

The power LED is not on because the board was unplugged from my wall adapter at the time of the photo. When it is plugged in the LED glows bright green. The color of wires was not considered when I was assembling this connection, however the polarity of the wall adapter and its connection to the board are correct.

As for the motors, I do not have a part number. However, I have included some photos below:

s-l1600_edited.jpg
s-l1600_edited.jpg (33.45 KiB) Viewed 249 times

s-l1600 (1)_edited.jpg
s-l1600 (1)_edited.jpg (34.73 KiB) Viewed 249 times

Sportsfan927
 
Posts: 5
Joined: Tue Mar 30, 2021 7:35 pm

Re: MotorShield Failure

by adafruit_support_bill on Wed Mar 31, 2021 1:28 pm

Do you have a multimeter? Can you measure the current draw of the motor when powered directly from your power supply?

adafruit_support_bill
 
Posts: 81308
Joined: Sat Feb 07, 2009 10:11 am

Re: MotorShield Failure

by Sportsfan927 on Wed Mar 31, 2021 3:12 pm

One motor connected to the power supply draws 0.534 amps.

Sportsfan927
 
Posts: 5
Joined: Tue Mar 30, 2021 7:35 pm

Re: MotorShield Failure

by adafruit_support_bill on Wed Mar 31, 2021 3:39 pm

And what do you see on the serial monitor when you run the i2c scanner?

https://playground.arduino.cc/Main/I2cScanner/

adafruit_support_bill
 
Posts: 81308
Joined: Sat Feb 07, 2009 10:11 am

Re: MotorShield Failure

by Sportsfan927 on Thu Apr 01, 2021 12:34 am

This is the result from uploading the i2c scanner:

23:39:45.245 -> Scanning...
23:39:45.280 -> No I2C devices found

I tried separating the shield and re-joining it and had the same results. Let me know what our next steps are.

Thank you!

Chris

Sportsfan927
 
Posts: 5
Joined: Tue Mar 30, 2021 7:35 pm

Re: MotorShield Failure

by adafruit_support_bill on Thu Apr 01, 2021 6:10 am

Sounds like the PCA9685 chip on the board is not functioning. We can replace the shield for you. Please contact support@adafruit.com with a link to this thread.

adafruit_support_bill
 
Posts: 81308
Joined: Sat Feb 07, 2009 10:11 am

Please be positive and constructive with your questions and comments.