There is no USPS pickup on Monday Feb 15th, 2016 because of President's Day. USPS orders placed after 11am EST Fri February 12th will go out Tuesday February 16. UPS orders will ship as normal.

DOA: My Brand New 2.8" LCD/Touchscreen has no touch outputs
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

DOA: My Brand New 2.8" LCD/Touchscreen has no touch outputs

by ericnewman on Thu Nov 29, 2012 12:45 pm

Hi, just unboxed this new shield, plugged it into an new Arduino Duo, and installed the necessary libraries. I'm on a Mac running Arduino 1.0.2 tools.

All the graphics demos work fine. However the "Touchscreendemo" has no output. I modified the code to debug it, changing the " if (p.z > ts.pressureThreshhold) " to "if(1)".

Now I see scrolling outputs as follows:

X = 1017 Y = 546 Pressure = 0
X = 1023 Y = 545 Pressure = -299
X = 1017 Y = 546 Pressure = 0
X = 1023 Y = 545 Pressure = -299

Touching the screen has no effect. This is all using unmodified boards, no wiring, simply stacking the two shields, with nothing else attached.

Any Suggestions? I suspect it's just a bad board...
ericnewman
 
Posts: 5
Joined: Thu Nov 29, 2012 12:04 pm

Re: DOA: My Brand New 2.8" LCD/Touchscreen has no touch outputs

by madhunm on Thu Nov 29, 2012 3:17 pm

Hello,

Do you have an Arduino Uno to try this with?

Thanks,
Madhu.

madhunm
 
Posts: 41
Joined: Thu Dec 16, 2010 6:06 pm

Re: DOA: My Brand New 2.8" LCD/Touchscreen has no touch outputs

by ericnewman on Thu Nov 29, 2012 3:53 pm

Yes - it is plugged into a new Arduino Duo board right now.
ericnewman
 
Posts: 5
Joined: Thu Nov 29, 2012 12:04 pm

Re: DOA: My Brand New 2.8" LCD/Touchscreen has no touch outputs

by madhunm on Thu Nov 29, 2012 5:22 pm

Hello,

Not an Arduino Due; but an Arduino Uno.

Regards,
Madhu.

madhunm
 
Posts: 41
Joined: Thu Dec 16, 2010 6:06 pm

Re: DOA: My Brand New 2.8" LCD/Touchscreen has no touch outputs

by ericnewman on Thu Nov 29, 2012 5:28 pm

Sorry, I meant to say UNO. It is connected only to an UNO, thats the only Arduino boards I have.
ericnewman
 
Posts: 5
Joined: Thu Nov 29, 2012 12:04 pm

Re: DOA: My Brand New 2.8" LCD/Touchscreen has no touch outputs

by adafruit on Fri Nov 30, 2012 1:19 pm

we do check every board for both display and touch

first - lets verify, are you using the BREAKOUT or the SHIELD? they are different to set up but they look very similar :)

adafruit
 
Posts: 12047
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Re: DOA: My Brand New 2.8" LCD/Touchscreen has no touch outputs

by ericnewman on Fri Nov 30, 2012 1:22 pm

This is the shield, mounted directly atop a new Arduino UNO, with no wires, just stacking pins. The display works fine with all the demos. The touchscreen part is the only issue as described above.
ericnewman
 
Posts: 5
Joined: Thu Nov 29, 2012 12:04 pm

Re: DOA: My Brand New 2.8" LCD/Touchscreen has no touch outputs

by adafruit on Fri Nov 30, 2012 1:30 pm

OK, display works then. Now lets try the TFTshieldpaint demo.

make sure you select the SHIELD version! there's two. can you paint on the screen? use a fingernail or stylus (toothpick works in a pinch)

adafruit
 
Posts: 12047
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Re: DOA: My Brand New 2.8" LCD/Touchscreen has no touch outputs

by ericnewman on Fri Nov 30, 2012 2:56 pm

Ok, First off thanks always for the great work you guys do. To make sure this wasn't me -

I did a clean install of the Arduino IDE, added the libraries for the TFT shield, Touchscreen, and SD, and plugged in the UNO with the shield attached. I ran the TFTPaint demo, and voila, it all worked fine.

I'm not sure what happened before, and on two separate development computers, but I suspect it must be another library creating some incompatibility. I had been using other LCD screens so there must be a conflict there.

Everything seems to be working fine.

Thanks again for your help.
ericnewman
 
Posts: 5
Joined: Thu Nov 29, 2012 12:04 pm

Please be positive and constructive with your questions and comments.