There is no USPS pickup on Monday Feb 15th, 2016 because of President's Day. USPS orders placed after 11am EST Fri February 12th will go out Tuesday February 16. UPS orders will ship as normal.

Code doesnt work
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Re: Code doesnt work

by baileygrib on Sat Jan 19, 2013 8:42 pm

Screen Shot 2013-01-19 at 7.41.44 PM.png
Screen Shot 2013-01-19 at 7.41.44 PM.png (62.24 KiB) Viewed 845 times

Screen Shot 2013-01-19 at 7.38.21 PM.png
Screen Shot 2013-01-19 at 7.38.21 PM.png (16.74 KiB) Viewed 845 times

Sorry I havent replied i have been stuck at school doing my science competition.
The following pictures are my directory, preferences, and error message that i get when i run the code. I made sure that everything was identical to yours.
Screen Shot 2013-01-19 at 7.37.52 PM.png
Screen Shot 2013-01-19 at 7.37.52 PM.png (67.25 KiB) Viewed 845 times
baileygrib
 
Posts: 52
Joined: Sun Sep 04, 2011 7:37 am

Re: Code doesnt work

by adafruit_support_rick on Sat Jan 19, 2013 8:52 pm

OK, thanks.

How about a screenshot showing the Adafruit_NFCShield_I2C folder opened up. It should look like this:
Adafruit_NFCShield_I2C.png
Adafruit_NFCShield_I2C.png (82.82 KiB) Viewed 843 times

adafruit_support_rick
 
Posts: 24884
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Code doesnt work

by baileygrib on Sat Jan 19, 2013 10:15 pm

Screen Shot 2013-01-19 at 9.14.08 PM.png
Screen Shot 2013-01-19 at 9.14.08 PM.png (69.23 KiB) Viewed 834 times
baileygrib
 
Posts: 52
Joined: Sun Sep 04, 2011 7:37 am

Re: Code doesnt work

by adafruit_support_bill on Mon Jan 21, 2013 8:21 am

Please post the exact text of the sketch you are trying to compile. We are having trouble trying to reproduce the problem here.

adafruit_support_bill
 
Posts: 45747
Joined: Sat Feb 07, 2009 10:11 am

Re: Code doesnt work

by adafruit_support_rick on Mon Jan 21, 2013 11:59 am

Also, try restarting the Arduino IDE.

adafruit_support_rick
 
Posts: 24884
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Code doesnt work

by baileygrib on Tue Jan 22, 2013 10:35 am

I am trying to compile the read mifare card sketch and I did restart the IDE
baileygrib
 
Posts: 52
Joined: Sun Sep 04, 2011 7:37 am

Re: Code doesnt work

by adafruit_support_rick on Tue Jan 22, 2013 11:12 am

Have you made any changes at all to the readmifare sketch? It compiles just fine for us.

In the Sketch:Import LIbrary... menu - does Adafruit_NFCShield_I2C show up in the pop-up list?

adafruit_support_rick
 
Posts: 24884
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Code doesnt work

by baileygrib on Thu Jan 24, 2013 11:31 pm

I don't believe I made any changes to the code and no it doesn't appear in the drop down menu.
baileygrib
 
Posts: 52
Joined: Sun Sep 04, 2011 7:37 am

Re: Code doesnt work

by adafruit_support_bill on Fri Jan 25, 2013 7:11 am

That is usually an indication that your library is not installed correctly - although from the screen-shots posted it seems to be in the right place. :?
Can you post a screenshot of the File->Preferences dialog? Any chance you have changed the default sketchbook location?

adafruit_support_bill
 
Posts: 45747
Joined: Sat Feb 07, 2009 10:11 am

Re: Code doesnt work

by baileygrib on Mon Jan 28, 2013 12:41 pm

Screen Shot 2013-01-19 at 7.41.44 PM.png
Screen Shot 2013-01-19 at 7.41.44 PM.png (62.24 KiB) Viewed 669 times

I think this is the picture you're requesting...
baileygrib
 
Posts: 52
Joined: Sun Sep 04, 2011 7:37 am

Re: Code doesnt work

by adafruit_support_rick on Mon Jan 28, 2013 1:16 pm

And are the library files in that exact directory, like this:?
/Users/sgribben7/Documents/Arduino/libraries/Adafruit_NFCShield_I2C/Adafruit_NFCShield_I2C.cpp
and
/Users/sgribben7/Documents/Arduino/libraries/Adafruit_NFCShield_I2C/Adafruit_NFCShield_I2C.h

adafruit_support_rick
 
Posts: 24884
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Code doesnt work

by adafruit_support_rick on Mon Jan 28, 2013 1:52 pm

Oh, duhhhhhh!!! :oops: :oops: :oops:
Sorry, Bailey - it was looking right at me and I didn't see it.
The path in your preferences is supposed to be the sketchbook location. You've got the path to libraries in there. Change it to look like this:

/Users/sgribben7/Documents/Arduino

Click OK, and then restart the Arduino application.

Thanks for being patient... :oops:

adafruit_support_rick
 
Posts: 24884
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Code doesnt work

by baileygrib on Tue Feb 19, 2013 5:43 pm

sorry i havent been online in a while but IT WORKED!! I should have seen that too! thank you so much for all of your help and patience!!
-Bailey
baileygrib
 
Posts: 52
Joined: Sun Sep 04, 2011 7:37 am

Re: Code doesnt work

by adafruit_support_rick on Tue Feb 19, 2013 6:51 pm

You're welcome! Good luck with your project! :D

adafruit_support_rick
 
Posts: 24884
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Code doesnt work

by Shug White on Sat Jul 19, 2014 10:36 pm

I'm having the same problem and I have to say before you reply that I have been through all the steps above and I'm still getting this:
Screen Shot 2014-07-19 at 10.34.13 PM.png
Screen Shot 2014-07-19 at 10.34.13 PM.png (62.24 KiB) Viewed 93 times
Shug White
 
Posts: 2
Joined: Fri Oct 18, 2013 3:05 pm

Please be positive and constructive with your questions and comments.


cron