0

Initializing a DS1307
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Initializing a DS1307

by ddavisva on Thu Jul 13, 2017 2:18 pm

I running a Raspberry PI 3 with Openelec OS to run a digital picture frame with a DS1307 RTC to set the clock so a network connection is not needed. I had 10 of the DS1307 kits. Of those, 7 worked perfectly but I can not get the last 3 to be recognized. When I SSH into the box and run hwclock, the error message back is - hwclock: can't open '/dev/misc/rtc': No such file or directory. I've tested the non-working RTC's on the same RP3 that had a working RTC, so I know the config commands to set the i2c device is loaded properly. Of the 7 that worked, some did not seem to work at first, but as I keep trying different commands they then started working. I've very closely looked at the solder points on all the non-working boards and compared them to the working boards and do not see any obvious solder errors. Is there some sequence needed to properly "wake up" a DS1307 or did I just fail on the soldering for the bad ones with too much heat or a static charge? Thanks

ddavisva
 
Posts: 1
Joined: Thu Jul 13, 2017 1:18 pm

Re: Initializing a DS1307

by adafruit_support_carter on Thu Jul 20, 2017 10:39 am

Do the non-working ones show up with an I2C scan?
https://learn.adafruit.com/adding-a-rea ... g-i2c-scan

adafruit_support_carter
 
Posts: 2199
Joined: Tue Nov 29, 2016 2:45 pm

Please be positive and constructive with your questions and comments.