Black Lives Matter - Action and Equality. ... Adafruit is open and shipping.
0

Problems with Firmware Modification
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Problems with Firmware Modification

by nverlee on Mon Nov 16, 2009 7:01 pm

Ahhh the ice tube clock! I waited weeks for it, and when it finally came it worked the first time! So naturally, I had to go right ahead and take it apart and add an ambient light sensor. I figured it would not be too hard to update the firmware. I gave my friend the clock and the hex file because command lines still sort of scare me and he knows how to use linux and has dabbled around with Atmel chips before. Now the clock does not work. Here is a what I have tried:

I initially added the sensor in where R4 and "hacking spot" are - But instead of adding resistor R4, I am using a built in pull down resistor on the sensor. The sensor is a sparkfun TEMT6000 Ambient light sensor, so I have wired it so that the microcontroller powers it and reads its signal pin. Its basically the same as the photocell except with a pull down resistor instead of a pull up resistor... I think... Regardless, I dont think that should affect anything.

After programming the clock, it no longer worked. So I did a lot of reading about how to use the USBtinyISP for mac, and read one of the forums about how to reprogram the atmega in the ice tube clock, what commands to use, etc.

It is my current understanding that all I need to do is select the correct hex file (iv.hex) and everything should work. Unfortunatly, my friend had mentioned to me that it was a possibility that he had accidentally programmed the fuse bits improperly. And that could mean that things are very, very bad.

After playing around with AVRdude to no avail, I finally went to one of my schools labs and have been playing with and AVR stk500 in AVR Studio, I have been able to successfully do things like re flash the chip, erase the chip, and even program the chip with hex files. I have also been furiously searching the net for what the fuse bit settings are supposed to be to compare them to what AVR studio says they are currently. I tried programming the chip with both modified firmware and the original firmware, and neither have produced the little "hello I am alive" chirp when I put the chip back in the clock. I have verified that the power section of the circuit still works. Again, it's my understanding that if the fuse bits are correctly set, all I should have to do it point AVR studio to the correct file, say go, and it should work.

So any suggestions as to what I may be doing wrong? I would ultimately like to be able to realize additional functionality with an ambient light sensor, but just getting the clock to work again is my frist priority right now. Is there any way that I could have damaged any of the circuitry? Could the ATmega have somehow been destroyed in the process of programming?

Thanks in advace to anyone replying to this post!
nverlee
 
Posts: 1
Joined: Mon Nov 16, 2009 6:31 pm

Please be positive and constructive with your questions and comments.