Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

monochron screen issues
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

monochron screen issues

by tms on Sun Mar 07, 2010 2:17 pm

After successully getting the clock running I returned a while later to find the display covered with random dots.
All the suggested tests worked fine during the build, and the clock was working fine for at least 10 minutes. Now when I initially plug in the power supply it will sometimes start normally, but more often it looks like:
m1.jpg
m1.jpg (7.06 KiB) Viewed 1847 times

After time it degrades, like:
m2.jpg
m2.jpg (9.16 KiB) Viewed 1847 times

Is this a bad display, or a bad component, or could it be software? Anyone have suggestions as to how I could determine the cause?

tms
 
Posts: 3
Joined: Sun Mar 07, 2010 11:49 am

Re: monochron screen issues

by adafruit on Mon Mar 08, 2010 11:50 am

oh you've got the special Post Modern firmware installed :)

just kiddin' - that definately looks iffy. first thing we'd do is try taking it out of the enclosure, and making sure the solder joints for the header and the microcontroller are solid. just give 'em a re-solder to make sure. does that fix it?

adafruit
 
Posts: 12151
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Re: monochron screen issues

by wzntme on Mon Mar 08, 2010 6:24 pm

Hey TMS, did resoldering help fix the screen issues. Mine is actually worse than the screenshots you posted. Any and all help appreciated!!
wzntme
 
Posts: 2
Joined: Mon Mar 08, 2010 6:19 pm

Re: monochron screen issues

by tms on Mon Mar 08, 2010 7:03 pm

I resoldered the header connections on both cards, and so far (about an hour later) things seem to be working properly. If the problem occurs again I'll post another message.
TMS

tms
 
Posts: 3
Joined: Sun Mar 07, 2010 11:49 am

Re: monochron screen issues

by tms on Mon Mar 08, 2010 8:49 pm

I spoke too soon. It worked fine for about 2.5 hours, then went back to post-modern mode.
Any other ideas?

tms
 
Posts: 3
Joined: Sun Mar 07, 2010 11:49 am

Re: monochron screen issues

by adafruit on Mon Mar 08, 2010 10:19 pm

tms, email support@adafruit to get a new screen and a return envelope

adafruit
 
Posts: 12151
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Re: monochron screen issues

by wzntme on Tue Mar 09, 2010 2:55 pm

I resolder all the header pins, and still didnt work correctly. After looking over everything again found 1 pin on IC1 wasnt soldered enough. Mines being running for 24hours without issues.
wzntme
 
Posts: 2
Joined: Mon Mar 08, 2010 6:19 pm

Re: monochron screen issues

by adafruit on Tue Mar 09, 2010 3:07 pm

that could do it! please please check your pins before returning screens - we got one return and it works fine which makes us think its a chip soldering problem :(

adafruit
 
Posts: 12151
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Please be positive and constructive with your questions and comments.