Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

ICE Cube clock displays gibberish
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

ICE Cube clock displays gibberish

by jbaber on Fri Apr 23, 2010 2:15 pm

Hello -
My son and I have built the clock, passing every test along the way. We have the correct voltages and beeps however, on final assembly, the display has random segments illuminated. Pushing the menu button changes which segments are lit, one even seems to count as the segments change every second. I have double-checked that all of the components are aligned correctly, that the chips' pin 1s are in the right location, that there are no shorts and that the tube's three unused wires are lined up to the 'Display-NC' on the pcb. I have even resoldered all the components to make sure there were no opens. My clock looks just like the pictures in the build-to. Any ideas? My final thought may be that the VFD boost chip got scrambled by the x-ray that my mail goes through (I live overseas). Thanks in advance for you thoughts.
jbaber
 
Posts: 6
Joined: Fri Apr 23, 2010 1:46 pm

Re: ICE Cube clock displays gibberish

by adafruit on Fri Apr 23, 2010 7:36 pm

please post an image with what the display is showing

adafruit
 
Posts: 12151
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Re: ICE Cube clock displays gibberish

by jbaber on Sat Apr 24, 2010 12:26 pm

This is a time-lapse photo because the light is so dim it wouldn't be photo-graphable otherwise.
It looks something like this:
_ _ _ _
| | |_ | | |_| _|
| |. | |. | . | |. |
Attachments
Lit Segments.JPG
Lit Segments.JPG (119.52 KiB) Viewed 2679 times
jbaber
 
Posts: 6
Joined: Fri Apr 23, 2010 1:46 pm

Re: ICE Cube clock displays gibberish

by adafruit on Sat Apr 24, 2010 11:35 pm

can you post a clear photo of your tube where its soldered in, the half-round PCB and the top & bottom of the kit?

adafruit
 
Posts: 12151
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Re: ICE Cube clock displays gibberish

by jbaber on Mon Apr 26, 2010 3:42 pm

Hi Ada, thanks for responding...
Here are the photos.
Attachments
Tube PCB.jpg
Tube showing solders
Tube PCB.jpg (285.88 KiB) Viewed 2637 times
PCB bottom.jpg
PCB bottom showing solders
PCB bottom.jpg (283.49 KiB) Viewed 2637 times
PCB Top.jpg
PCB top showing the components
PCB Top.jpg (315.86 KiB) Viewed 2637 times
jbaber
 
Posts: 6
Joined: Fri Apr 23, 2010 1:46 pm

Re: ICE Cube clock displays gibberish

by jbaber on Mon Apr 26, 2010 3:49 pm

and finally..
a picture showing the tube's alignment...
Attachments
Tube connect.jpg
This shows the 3 'NC's of the tube going to the 'Display-NC' of the board.
Tube connect.jpg (208.53 KiB) Viewed 2637 times
jbaber
 
Posts: 6
Joined: Fri Apr 23, 2010 1:46 pm

Re: ICE Cube clock displays gibberish

by alishl06 on Mon Apr 26, 2010 4:06 pm

It looks like the display connector is installed on the wrong side of the board. The connector should be mounted on the same side as the tube.

alishl06
 
Posts: 19
Joined: Mon Apr 05, 2010 8:55 pm

Re: ICE Cube clock displays gibberish

by jbaber on Thu Apr 29, 2010 4:41 pm

dang it, cracked the tube trying to de-solder. Got some from e-bay, I'll let you know how it goes.
jbaber
 
Posts: 6
Joined: Fri Apr 23, 2010 1:46 pm

Re: ICE Cube clock displays gibberish

by adafruit on Thu Apr 29, 2010 5:01 pm

you shouldnt be desoldering the tube, its on correctly. its the -connector- thats backwards. see the photos in the instructions, you can click for a larger version

adafruit
 
Posts: 12151
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Re: ICE Cube clock displays gibberish

by jbaber on Tue Jun 22, 2010 4:28 pm

Finally got it all put together. I had broken the tube while de-soldering the 90 deg. double row. I got another from e-bay, even had to get another 90 deg, connector. Put it all together and the clock is working fine. Thanks for your help troubleshooting this. Cheers.
jbaber
 
Posts: 6
Joined: Fri Apr 23, 2010 1:46 pm

Please be positive and constructive with your questions and comments.