Please note: Friday June 18 is a holiday celebrating Juneteenth, please allow extra time for your order to arrive and plan accordingly.
0

Ice Tube Clock stopped working :(
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Ice Tube Clock stopped working :(

by rjhike on Tue Jul 14, 2020 7:21 pm

After five years, my Ice Tube clock stopped working. There was a "pwr rset" (power reset) message, so I unplugged the clock, plugged it back in and it would work for a day or so. I tried three different power supply cords. Same result. Then there was a "bad batt" message, so I replaced the battery. Now today, nothing that I have tried will get it to work.

Is there a component that I could replace? Is there a way to test it? If so how and what parts?

Something different happened today as unplugged it, for a split second all of the digit would flash. Weird.

Thanks for your help.

rjhike
 
Posts: 18
Joined: Thu Jan 29, 2015 8:35 pm

Re: Ice Tube Clock stopped working :(

by adafruit_support_bill on Tue Jul 14, 2020 7:43 pm

I'd start with the Ice Tube troubleshooting guide here: viewtopic.php?f=41&t=27032
Since it has been working OK for some time, the assembly is probably fine. You can skip to the power supply/boost converter section.

adafruit_support_bill
 
Posts: 81308
Joined: Sat Feb 07, 2009 10:11 am

Re: Ice Tube Clock stopped working :(

by rjhike on Tue Dec 15, 2020 3:24 pm

I haven't been able to find the problem. Is there a company or individual for hire that can repair the clock?

rjhike
 
Posts: 18
Joined: Thu Jan 29, 2015 8:35 pm

Re: Ice Tube Clock stopped working :(

by adafruit_support_bill on Tue Dec 15, 2020 3:32 pm

That is not a service that we offer. If you pot some details about what you have found in your troubleshooting efforts, we may be able to offer some advice.

adafruit_support_bill
 
Posts: 81308
Joined: Sat Feb 07, 2009 10:11 am

Re: Ice Tube Clock stopped working :(

by rjhike on Tue Dec 15, 2020 5:28 pm

Since there was a "pwr rset" error and "bad bat", I started by installing a new battery. I tried two different batteries. I verified that the battery voltage is good.
I also tried three different power supplies.
I have another Ice-Tube clock, so I tried the tube from the non-working clock and put it in the other clock, and the tube worked. So I know that the tube is okay.
All the solder joints are good. It was working for years.

I don't know what component to check. Is there a component that "goes bad"?

I was hoping that another reader would know someone who could get it working for me.

rjhike
 
Posts: 18
Joined: Thu Jan 29, 2015 8:35 pm

Re: Ice Tube Clock stopped working :(

by adafruit_support_bill on Tue Dec 15, 2020 5:45 pm

Components do fail over time. And marginal solder joints tend to gradually deteriorate. From the symptoms you describe, I'd suspect something in the power supply/voltage regulator part of the board. The troubleshooting guide I linked earlier has a list of things to check. viewtopic.php?f=41&t=27032

adafruit_support_bill
 
Posts: 81308
Joined: Sat Feb 07, 2009 10:11 am

Please be positive and constructive with your questions and comments.