Voting resources, early voting, and poll worker information - VOTE. ... Adafruit is open and shipping.
0

very low brightness (ICE Tube)
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

very low brightness (ICE Tube)

by monochron on Tue May 06, 2014 7:08 am

I've finished the kit but the brightness is very low.
In MENU the brightness is set to max but the numbers are recognized only in a dark room.
Is this normal?

monochron
 
Posts: 14
Joined: Tue Mar 18, 2014 3:46 am

Re: very low brightness (ICE Tube)

by adafruit_support_bill on Tue May 06, 2014 7:26 am

It should be readable in normal room light. What voltage do you measure on the output of the boost converter? Also, what voltage do you measure on R3? viewtopic.php?f=41&t=27032

adafruit_support_bill
 
Posts: 78659
Joined: Sat Feb 07, 2009 10:11 am

Re: very low brightness (ICE Tube)

by monochron on Tue May 06, 2014 8:55 am

At +UB (the striped end of the diode D5) I measure about 31V. It's too low, I gues.

monochron
 
Posts: 14
Joined: Tue Mar 18, 2014 3:46 am

Re: very low brightness (ICE Tube)

by adafruit_support_bill on Tue May 06, 2014 10:12 am

I measure about 31V.

Is that with or without the tube & VFD chip installed? You will want 40v-7v with no chip or tube. It typically drops to the 15v range with the load from the chip & tube.

adafruit_support_bill
 
Posts: 78659
Joined: Sat Feb 07, 2009 10:11 am

Re: very low brightness (ICE Tube)

by monochron on Tue May 06, 2014 11:20 am

That's with tube and chip installed.
While building the kit at test-step I measured 59V.
May I use a wall-power supply with 12V instead the 9V power-supply? Will this rise the brightness?

monochron
 
Posts: 14
Joined: Tue Mar 18, 2014 3:46 am

Re: very low brightness (ICE Tube)

by adafruit_support_bill on Tue May 06, 2014 12:31 pm

The clock should run at 12v, but It sounds like you have a very good boost voltage already. Check the heater voltage on R3 - on the end closer to Q3.

adafruit_support_bill
 
Posts: 78659
Joined: Sat Feb 07, 2009 10:11 am

Re: very low brightness (ICE Tube)

by monochron on Wed May 07, 2014 2:30 am

The heater voltage on Q3/R3 is 3,25 V
When I use the 12 power-supply, heater voltage stay at 3,25V. Boot voltage then is exact 60V and the brightness is better than with 9V power-pupply. Is heater voltage 3,25V OK?

monochron
 
Posts: 14
Joined: Tue Mar 18, 2014 3:46 am

Re: very low brightness (ICE Tube)

by adafruit_support_bill on Wed May 07, 2014 6:11 am

3.25v is a little low. It should be more in the 4.7v range. If you post some photos of the front & back of the board, we can take a look.

adafruit_support_bill
 
Posts: 78659
Joined: Sat Feb 07, 2009 10:11 am

Re: very low brightness (ICE Tube)

by monochron on Wed May 07, 2014 6:30 am

I've send the photos...
Attachments
IT_front.jpg
Board frontside
IT_front.jpg (287.66 KiB) Viewed 567 times
IT_1.jpg
IT_1.jpg (174.84 KiB) Viewed 567 times
IT_back.jpg
Board backside
IT_back.jpg (354.75 KiB) Viewed 567 times

monochron
 
Posts: 14
Joined: Tue Mar 18, 2014 3:46 am

Re: very low brightness (ICE Tube)

by adafruit_support_bill on Wed May 07, 2014 9:10 am

That looks good. Let's get some other voltage readings:

    Pin 5 of the processor chip
    Pin 13 of the processor chip
    The outer-most pin of Q3

adafruit_support_bill
 
Posts: 78659
Joined: Sat Feb 07, 2009 10:11 am

Re: very low brightness (ICE Tube)

by monochron on Wed May 07, 2014 9:40 am

Pin 5 of the Processor = 0V
Pin 13 of the Prozessor = 1,254V
Emitter of Q3 = 4,66V

All signals against heatsink of 7805

monochron
 
Posts: 14
Joined: Tue Mar 18, 2014 3:46 am

Re: very low brightness (ICE Tube)

by adafruit_support_bill on Wed May 07, 2014 10:24 am

OK. So it looks like the power sense circuit is working right, but Q3 is not turning on completely to send the full voltage to the VFD and the tube. Can you post a close-up photo showing Q3 from the top? Just to make sure it is installed correctly.

Also, just to confirm the diagnosis, try touching a jumper wire (carefully) between the two outer pins of Q3. This will effectively bypass Q3 and should give you a brighter display.

adafruit_support_bill
 
Posts: 78659
Joined: Sat Feb 07, 2009 10:11 am

Re: very low brightness (ICE Tube)

by monochron on Wed May 07, 2014 11:27 am

When I shortcut Q3 the brightness of the display is OK. It's a little difference, but OK.
Attachments
Q3_1.jpg
Q3
Q3_1.jpg (170.53 KiB) Viewed 546 times

monochron
 
Posts: 14
Joined: Tue Mar 18, 2014 3:46 am

Re: very low brightness (ICE Tube)

by adafruit_support_bill on Wed May 07, 2014 12:41 pm

It sounds like possibly a flaky Q3. If you contact support@adafruit.com with a link to this thread we can send out a replacement.

These MOSFETs are quite static sensitive. Handle with care on an anti-static surface, if possible.

adafruit_support_bill
 
Posts: 78659
Joined: Sat Feb 07, 2009 10:11 am

Re: very low brightness (ICE Tube)

by monochron on Wed May 07, 2014 1:50 pm

Thanks for the excellent support.
But to save shipping costs I will buy this transistor here in Germany. It will not cost so much (i guess :-). Which designation has Q3? Which type should I order?

monochron
 
Posts: 14
Joined: Tue Mar 18, 2014 3:46 am

Please be positive and constructive with your questions and comments.