Black Lives Matter - Action and Equality. ... Adafruit is open and shipping.
0

timesquare with homemade pcb
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

timesquare with homemade pcb

by johnka on Thu Jul 31, 2014 12:10 pm

Hello,
I have copied the timesquare schematic to make my own timesquare watch.
I want to use smd components so my schematic is a little bit different from adafruit's.
Also my matrix display(1088BS) has a different pinout (anodes and cathodes are reversed), so I have to connect it in a different way with the microcontroller and rotate it 90 or 180 degrees.
My logic is this: On adafruit's timesquare the upper row is anode 7/pin16 (since the matrix is rotated) and it's connected with PD7. On my matrix the upper row is anode 0 which is the pin 9 of my matrix, so I have to connect pin 9 of my matrix with PD7, which is pin 11 of ATMEGA328P-AU.
This is myt schematic
http://cl.ly/2X1I1u1a2n2R
I used an arduino bootloader with custom fuses to use the internal 8MHz oscillator and I created the pcb.
I uploaded a few sketches to verify that everything is connected properly. I was able to turn on each led of the monitor individually, I could read the time from the RTC on the monitor and read the buttons states.
I uploaded the timesquare code but I couldn't make this to work. Right after connecting the power supply, all leds are turning on for a moment and then turning off. If I press a button all the leds are turning on and staying on for about 3 seconds. The weird thing is that, although all leds are on when I press a button, there is something like scrolling text with lower brightness. See this video that I captured in slow motion.
http://youtu.be/92jGMwvi9CY

What could be the problem? I have verified that everything on the PCB is connected according to my schematic.
johnka
 
Posts: 13
Joined: Wed Jan 15, 2014 5:42 pm

Please be positive and constructive with your questions and comments.