0

Mydata how-to and bit of hacking ....
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Re: Mydata how-to and bit of hacking ....

by alphatronique on Sun May 03, 2015 8:11 am

Hi also in a different subject i find this tool while googling ..

http://www.rohrhofer.org/r-tec/index.ph ... cadconvert

was really useful small tool , great job Hannes

have fun ,best regard ...

alphatronique
 
Posts: 229
Joined: Fri Jun 25, 2010 8:30 am

Re: Mydata how-to and bit of hacking ....

by madrat on Sun May 03, 2015 12:24 pm

Alphatronique wrote:HI

machine not able to talk correctly to feeder via the data bus ,so may probably bad contact

1-) check that all socket IC was properly seated on the PCB under the Feeder , it may move in shipping

2-) scrub a pencil eraser on the card edge contact ,and ideally put a drop of Stabilant 22A on it

did it mag that was whit the 4000$ machine on ebay ?

have fun ..


Thanks for the info, the card connector is very clean and I've tried it in a few slots. I'll check the IC sockets, that's a good thought. Doesn't seem to even try to read the magazine, just fails very quickly. No I couldn't get hold of the ebay seller with the $4k machine to discuss shipping so had to leave that one! Thanks for that software link by the way...

madrat
 
Posts: 8
Joined: Thu Apr 16, 2015 2:23 pm

Re: Mydata how-to and bit of hacking ....

by alphatronique on Sun May 03, 2015 12:41 pm

Hi at least it try to read the feeder since it report it as error

you may still try to swap car whit another one for confirm it really the card or try to slave card from a flex or other broke feeder

alphatronique
 
Posts: 229
Joined: Fri Jun 25, 2010 8:30 am

Re: Mydata how-to and bit of hacking ....

by madrat on Sun May 03, 2015 12:45 pm

Alphatronique wrote:Hi at least it try to read the feeder since it report it as error

you may still try to swap car whit another one for confirm it really the card or try to slave card from a flex or other broke feeder


Its certainly trying to see the feeder, I wonder how many software revisions these went through and how backward compatible they are. Its a shame the older TM8B magazines don't work, I've got loads of them!

madrat
 
Posts: 8
Joined: Thu Apr 16, 2015 2:23 pm

Re: Mydata how-to and bit of hacking ....

by alphatronique on Sun May 03, 2015 1:20 pm

and seem that control card was hard to put hand on only time i see it was very expensive

not look to really complex but mydata love PAL chip so hard to make replacement board
if you have ton of that old feeder it may good to put logic analyse on the bus and try to read and understand the protocol
normally it not very complex ,so may implement it later on a ardunino ;-) , i never try it since on my side all my feeder have blue button

as long i kont it have 3 kind of feeder ,old one prior blue button that may not work on current machine ,the one whit blue button
the finally the canbus agilis whit linear actuator ( first agilis M8 was similar interface to blue button)

regard

alphatronique
 
Posts: 229
Joined: Fri Jun 25, 2010 8:30 am

Re: Mydata how-to and bit of hacking ....

by madrat on Sun May 03, 2015 1:59 pm

Yeah we had intended to snoop the protocol to see if we can patch the old feeders to work with the newer machine. Just need to get this one to work so we can see how they are talking!

madrat
 
Posts: 8
Joined: Thu Apr 16, 2015 2:23 pm

Re: Mydata how-to and bit of hacking ....

by alphatronique on Sun May 03, 2015 2:46 pm

if you not have it i have some were the pinout of the connector

so more easy to identify signal and it purpose

last time i look it seem quite simple , the data bus was used only for type and serial number exchange then use it as adress decoder
the remain of signal was direct to MI card for handel all motor and timing signal so intelligence was on MI/mot card on computer rack

also on all of my machine MI was in pair whit mot-3 ,that may related to the blue button to ?

but morel likely only a flag bit on data bus reguster that ident it as TMxC Box

may a good idea to check your feeder on another machine ,since from my memory the incompatibility whit old feeder was on verry old venix software
so it may have something else like the mot-3 on MI card ?

alphatronique
 
Posts: 229
Joined: Fri Jun 25, 2010 8:30 am

Re: Mydata how-to and bit of hacking ....

by smtek on Fri Jul 17, 2015 5:17 am

Hello

We have a problem with our MyData TP11 UFP from 1997. Axis theta is not initialized... We have a message " Lower end point not repetable" or "Upper...... ". We change motor theta but it's still not work. Please look picture and video.. Thanks for Your help.

http://sendfile.pl/pokaz/428462---CVco.html
http://sendfile.pl/pokaz/428461---XXxq.html
Attachments
20150704_1133539.jpg
20150704_1133539.jpg (311.57 KiB) Viewed 544 times

smtek
 
Posts: 2
Joined: Fri Jul 17, 2015 4:33 am

Re: Mydata how-to and bit of hacking ....

by alphatronique on Fri Jul 17, 2015 9:43 am

Hi

try swap MOT card if not it may the encoder

alphatronique
 
Posts: 229
Joined: Fri Jun 25, 2010 8:30 am

Re: Mydata how-to and bit of hacking ....

by smtek on Mon Jul 20, 2015 2:04 am

We change MOT Card.. still don't work.. we check encoder... thanks!!

smtek
 
Posts: 2
Joined: Fri Jul 17, 2015 4:33 am

Re: Mydata how-to and bit of hacking ....

by alphatronique on Mon Jul 20, 2015 3:06 pm

for check encoder go in servive and look for the transducer value

alphatronique
 
Posts: 229
Joined: Fri Jun 25, 2010 8:30 am

Re: Mydata how-to and bit of hacking ....

by mikestrauser on Wed Oct 19, 2016 7:59 pm

Is this thread still active?

We have a TP9-2 that is having a problem with the centering jaws. It measures parts much larger than they are which makes me think that either the jaws are not fully closing or whatever they use to measure the opening is not working. It doesn't happen on all package sizes - mostly larger ones DPAK, SO14, etc. Mechanically, it feels fine. We have checked for loose parts in that area and there are none.

Any ideas?

mikestrauser
 
Posts: 2
Joined: Wed Oct 19, 2016 7:31 pm

Re: Mydata how-to and bit of hacking ....

by alphatronique on Wed Oct 19, 2016 9:19 pm

HI

actually on machine start-up it validate the centering JAW and that measure was repeatable and if it screw machine pop a error in red

so it may the force setting that was to low or part was measured a wrong height ( measure lead when you not what to )
or wrong orientation measure 90 deg when you think it 0

but for big part vision centering may a better option ,TP-9 centering JAW was no longer made so better to try to not wear it to much ....

if all fail one option was to put off the measure ,but i don think it may mechanical issue since if encoder become random machine find it and fail initialization

hope it help

alphatronique
 
Posts: 229
Joined: Fri Jun 25, 2010 8:30 am

Re: Mydata how-to and bit of hacking ....

by mikestrauser on Thu Oct 20, 2016 7:45 pm

Thank you very much for your response. It was that the Force was too low (we are new to pick-n-place so we are still learning). We will investigate using vision more to keep from wearing out the centering jaws.

Mike.

mikestrauser
 
Posts: 2
Joined: Wed Oct 19, 2016 7:31 pm

Re: Mydata how-to and bit of hacking ....

by alphatronique on Fri Oct 21, 2016 9:45 pm

Hi

no problem ,if need it still have the yahoo group

and i monitor here to

Best reagrd

alphatronique
 
Posts: 229
Joined: Fri Jun 25, 2010 8:30 am

Please be positive and constructive with your questions and comments.


cron