Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.


by daguro on Tue Apr 25, 2017 6:48 pm

I just got one of these from Adafruit.

The armstart.com and armstart.co web sites seem to be off line. The only documentation is a two page PDF that isn't very complete.

When I plugged this into my Linux machine, it showed up with lsusb.

When I plugged it into my Windows 10 machine, it showed up as an HID USB device with an ID string that said something about "vendor".

It did not show up as an IBDAP-LPC11U35 CMSIS-DAP or anything like that.

On both computers, I could press and release both switches and get a USB MSC with a single file, firmware.bin.

The binary on Amazon AWS seems to be gone. I downloaded the source from github and built it. It is around 8k. I copied the code, per the instructions, and now it no longer shows up on my Linux machine when I run lsusb.

I can still press both switches and get a USB MSC with a single file, firmware.bin.

Does anyone have a binary file that is known to work?

What happened to the company that made this?

Are there more directions for this debug board?

Posts: 3
Joined: Tue Apr 25, 2017 6:15 pm

Re: IBDAP-CMSIS issues

by daguro on Tue Apr 25, 2017 9:00 pm

It looks like the company behind this thing is no longer in business.

The company did a kickstarter thing, wicam, and it looks like they never delivered. Was this a kickstarter also?

Adafruit should not be selling it.

Posts: 3
Joined: Tue Apr 25, 2017 6:15 pm

Re: IBDAP-CMSIS issues

by adafruit2 on Wed Apr 26, 2017 11:08 am

huh thats odd, we were just chatting with them to place a new order a few weeks ago. this wasnt a kickstarter that we know of, we have been carrying it for a year and a half, https://blog.adafruit.com/2015/10/16/ne ... apter-kit/

their github repo is still up @ https://github.com/Armstart-com/IBDAP-CMSIS-DAP

the IBDAP is really nice as a CMSIS device, and should work. we'll contact them to see whats up - hopefully they will reply! :)

Site Admin
Posts: 19186
Joined: Fri Mar 11, 2005 7:36 pm

Re: IBDAP-CMSIS issues

by daguro on Fri May 26, 2017 11:07 am

It has been a month since posting.

The IBDAP-CMSIS I purchased still doesn't work.

Is there anything happening with this?

Posts: 3
Joined: Tue Apr 25, 2017 6:15 pm

Re: IBDAP-CMSIS issues

by adafruit2 on Fri May 26, 2017 12:51 pm

hiya, we haven't gotten a response. if you can't use it email support@adafruit for a refund or credit. we suggest a jlink - they work great!

Site Admin
Posts: 19186
Joined: Fri Mar 11, 2005 7:36 pm

Re: IBDAP-CMSIS issues

by DanaK6JQ on Thu Jun 15, 2017 2:45 pm

Looks like Armstart's domain and GitHub went dark rather suddenly, though there's still a Tindie page.

The good news, for me at least, is that my IBDAP works great with an STM32/SW4STM set-up. I just tweaked the debugger config file to use 'interface cmsis-dap' and 'transport select swd' and away it went. Attached is a current project using the IBDAP with an STM32F030K6 on a protoboard.

I did not need to update the firmware on the IBDAP.

Edit: here's a sample debug config file I'm using with SW4STM:

Code: Select all | TOGGLE FULL SIZE
# This is an BC-Rock-10 board with a single STM32F030K6Tx chip
# Generated by System Workbench for STM32
# Take care that such file, as generated, may be overridden without any early notice. Please have a look to debug launch configuration setup(s)

interface cmsis-dap


transport select swd


# Enable debug when in low power modes

# Stop Watchdog counters when halt

# STlink Debug clock frequency
set CLOCK_FREQ 4000

# use hardware reset, connect under reset
# connect_assert_srst needed if low power mode application running (WFI...)
reset_config srst_only srst_nogate srst_push_pull connect_assert_srst

source [find target/stm32f0x.cfg]

You also need to set the debug configuration to use this file rather than auto-generate it.

ibdap-1.jpg (307.19 KiB) Viewed 1465 times

Posts: 18
Joined: Thu Jun 15, 2017 2:38 pm

Re: IBDAP-CMSIS issues

by PurpleHaze on Sat Jul 01, 2017 4:36 pm

This is affecting me as well. I got a IBDAP adapter so that I could start flashing on my Laird eval kit (DVK-BL652_1.0) via Keil.

Finally got around to plugging it in, and the board shows up as "CRP_DISABLED". That's weird... I'll update the firmware...

Website domain gone
GitHub has a 404 error
..great. Looks like these guys either packed up or they need to fire their web admin.

If anyone has some other suggestions on how to debug using this kit, I would also appreciate it. Right now I have a little blue LED and that's about it.

Posts: 3
Joined: Sat Jul 01, 2017 4:32 pm

Re: IBDAP-CMSIS issues

by franklin97355 on Sun Jul 02, 2017 1:01 pm

Send a note containing a link to this thread and your order number to support@adafruit.com. The folks there will help you arrange a return and store credit.

Posts: 21493
Joined: Mon Apr 21, 2008 2:33 pm
Location: Lacomb, OR.

Re: IBDAP-CMSIS issues

by lvd on Sat Mar 24, 2018 8:52 am

Same problem for me,I just ordered the IBDAP...

But I found another github which might contain what we need:

I'll try it out when my order arrives.

Ok, it arrived & it works.
When I connect it it shows up as a USB Disk Drive with the firmware.bin in it.
But when I press once the RST_SW it goes to CMSIS-DAP mode.
After some looking up how to configure openocd I finally can debug my Arduino due!

Posts: 1
Joined: Sat Mar 24, 2018 7:49 am

Re: IBDAP-CMSIS issues

by jkpdx on Wed Apr 11, 2018 6:30 pm

I just got one of these and couldn't get it to work with Rowley. But I re-flashed using the LPC1768 pre-built image from https://os.mbed.com/platforms/SWDAP-LPC11U35/ and now it works fine. Agree Adafruit probably shouldn't be selling these with so little support.

Posts: 1
Joined: Wed Apr 11, 2018 6:28 pm

Re: IBDAP-CMSIS issues

by fbo_memfault on Thu Apr 25, 2019 12:56 pm

I bought one of these recently and ran into the same issues. Thanks to some hints above, I was able to get everything working. I wrote a short blog post about it for posterity: https://interrupt.memfault.com/blog/get ... tsamd21g18. Hope it helps!

Posts: 1
Joined: Thu Apr 25, 2019 12:55 pm

Re: IBDAP-CMSIS issues

by lotharyx on Sat Apr 27, 2019 1:12 pm

I just dug this dude out of my pile of stuff and had my own travails with it. Here's a really important thing I think I discovered:

When you copy a new firmware.bin onto the device (when it's showing up as a removable media device), you have to hit the reset button before unmounting it from the computer. For some reason, if you umount / eject / whatever_macs_do before you reset, the device will just keep coming up as CRP_DISABLD removable drive.

Note that I've tried these things:

-- Original firmware, OpenOCP says "JTAG supported"
-- Firmware built from the githup repo appears to brick the device
-- The firmware linked a couple posts up works, but OpenOCP then says "JTAG not supported"

So, I've found the original firmware seems to be the best bet, at least for the specific one I have.

That said, I have yet to connect it to anything but itself (connecting its own ribbon cable from its own TGT_DBG to its own DEBUG header), but that seems to work, perhaps surprisingly...it can debug itself! Probably not if I tried to halt it, though. But I can see registers and dump the image, so I say with cautious optimism that it's working (and if I don't connect the ribbon cable as described, openocd fails to start).

Posts: 5
Joined: Fri Oct 18, 2013 9:43 am

Re: IBDAP-CMSIS issues

by adafruit2 on Fri May 03, 2019 3:50 pm

thanks! ive addeda link to the blog post on the product page

Site Admin
Posts: 19186
Joined: Fri Mar 11, 2005 7:36 pm

Please be positive and constructive with your questions and comments.