Black Lives Matter - Action and Equality. ... Adafruit is open and shipping.
0

No find match device, please insert camera first
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

No find match device, please insert camera first

by ferguson_forge9 on Sat Nov 02, 2019 3:13 pm

This USB digital microscope does not work. Delivered yesterday. I keep getting "No find match device, please insert camera first" upon attempt to install software.
Have tried all 4 USB plugsins. Power to LEDs on scope.
Order Confirmation No: 2173371-1018282979. model ID 636,

ferguson_forge9
 
Posts: 2
Joined: Sat Nov 02, 2019 3:00 pm

Re: No find match device, please insert camera first

by mikeysklar on Sat Nov 02, 2019 8:08 pm

This sounds familiar. I wonder if we have a batch of unsoldered usb pins on the PCB as this thread mentioned:

viewtopic.php?f=19&t=128912&p=765834&hilit=usb+microscope+windows#p765834

Also, just found the problem with the first 'scope. The internal PCB connector for the USB cable had two loose crimp contact pins (power, D+) that weren't fully inserted. The most difficult part of the fix was figuring out how to open the case. The domed end cap can be released with a quarter-turn (no tools).


Have you already installed the latest drivers for this device. Are you using Windows 10?

mikeysklar
 
Posts: 1330
Joined: Mon Aug 01, 2016 8:10 pm

Re: No find match device, please insert camera first

by ferguson_forge9 on Sat Nov 02, 2019 8:41 pm

I saw that, and pulled the back off with a quarter turn. I didn't see any loose pins. It is Windows 10 software,and I saw a post about the scope being labeled "Venus USB2.0 camera"
which is how this one is labeled in the settings.

ferguson_forge9
 
Posts: 2
Joined: Sat Nov 02, 2019 3:00 pm

Re: No find match device, please insert camera first

by mikeysklar on Sun Nov 03, 2019 7:14 pm

Gotcha. Thank you for checking the inside for any loose connections.

Do you have another machine (non windows-10) which you could try this with just to confirm that it is a scope issue and not a driver issue?

mikeysklar
 
Posts: 1330
Joined: Mon Aug 01, 2016 8:10 pm

Please be positive and constructive with your questions and comments.